summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorRoss Burton <ross@burtonini.com>2022-02-01 21:26:40 +0000
committerKhem Raj <raj.khem@gmail.com>2022-02-03 08:44:32 -0800
commit8bddd0f1b3823a381c7f0159fddf086636cc6ad7 (patch)
treeb53e8e7d54e0a7c51ec3f473fd762f60f464854a /meta-oe
parentc8544b3627fdd026a0e3e85a64f8af37e0417919 (diff)
downloadmeta-openembedded-8bddd0f1b3823a381c7f0159fddf086636cc6ad7.tar.gz
s-nail: add a maintained mail(1) fork
Heirloom Mailx hasn't been maintained for some time: the last release on their web site was 11.25 in 2005 and Debian shipped 12.5 in 2016, but this appears to be a Debian-specific fork which is also now dead. s-nail is an alternative mail(1) fork which is actively maintained, so add a recipe for that. It provides an alternative for ${bindir}/mailx, so should be a drop-in replacement. Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb1
-rw-r--r--meta-oe/recipes-extended/s-nail/files/make-errors.patch45
-rw-r--r--meta-oe/recipes-extended/s-nail/s-nail_14.9.23.bb44
3 files changed, 90 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
index a600b24cc..de7239287 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
@@ -421,6 +421,7 @@ RDEPENDS:packagegroup-meta-oe-extended ="\
421 sedutil \ 421 sedutil \
422 libsigrok \ 422 libsigrok \
423 libsigrokdecode \ 423 libsigrokdecode \
424 s-nail \
424 sigrok-cli \ 425 sigrok-cli \
425 snappy \ 426 snappy \
426 tipcutils \ 427 tipcutils \
diff --git a/meta-oe/recipes-extended/s-nail/files/make-errors.patch b/meta-oe/recipes-extended/s-nail/files/make-errors.patch
new file mode 100644
index 000000000..68de68cdb
--- /dev/null
+++ b/meta-oe/recipes-extended/s-nail/files/make-errors.patch
@@ -0,0 +1,45 @@
1Don't wrap CC in quotes as our CC has options and this breaks command lookup.
2
3Upstream-Status: Backport [https://git.sdaoden.eu/browse/s-nail.git/commit/?h=next&id=c08f3c898def715edf9164e169c3b3522f4c7a1f]
4Signed-off-by: Ross Burton <ross.burton@arm.com>
5
6From c08f3c898def715edf9164e169c3b3522f4c7a1f Mon Sep 17 00:00:00 2001
7From: Steffen Nurpmeso <steffen@sdaoden.eu>
8Date: Tue, 1 Feb 2022 18:54:16 +0100
9Subject: [-] Remove even more bogus quotation marks (Ross Burton)..
10
11On top of (mk/su-find-command.sh: clearly define space behaviour)
12and (mx-test.sh: remove bogus quotation marks) Ross Burton
13reported some more on the ML. I looked around and hope this was it.
14---
15 mk/pcb-cc.sh | 2 +-
16 mk/su-make-errors.sh | 2 +-
17 2 files changed, 2 insertions(+), 2 deletions(-)
18
19diff --git a/mk/pcb-cc.sh b/mk/pcb-cc.sh
20index 2697c5cf..075f8988 100755
21--- a/mk/pcb-cc.sh
22+++ b/mk/pcb-cc.sh
23@@ -18,7 +18,7 @@ if dowemayhave "$@"; then
24 if acmd_set CC clang || acmd_set CC gcc ||
25 acmd_set CC tcc || acmd_set CC pcc ||
26 acmd_set CC c89 || acmd_set CC c99; then
27- exec "$CC" "$@"
28+ exec $CC "$@"
29 else
30 echo >&2 'boing booom tschak'
31 echo >&2 'ERROR: I cannot find a compiler!'
32diff --git a/mk/su-make-errors.sh b/mk/su-make-errors.sh
33index f5c5144e..7fede15e 100644
34--- a/mk/su-make-errors.sh
35+++ b/mk/su-make-errors.sh
36@@ -157,7 +157,7 @@ compile_time() { # {{{
37 # The problem is that at least (some versions of) gcc mangle output.
38 # Ensure we get both arguments on one line.
39 # While here sort numerically.
40- "${CC}" -E "${TARGET}".c |
41+ ${CC} -E "${TARGET}".c |
42 ${awk} '
43 function stripsym(sym){
44 sym = substr(sym, 2)
45--
diff --git a/meta-oe/recipes-extended/s-nail/s-nail_14.9.23.bb b/meta-oe/recipes-extended/s-nail/s-nail_14.9.23.bb
new file mode 100644
index 000000000..4dbb99b3d
--- /dev/null
+++ b/meta-oe/recipes-extended/s-nail/s-nail_14.9.23.bb
@@ -0,0 +1,44 @@
1SUMMARY = "Feature-rich BSD mail(1)"
2HOMEPAGE = "https://www.sdaoden.eu/code.html#s-mailx"
3SECTION = "console/network"
4
5LICENSE = "ISC & BSD-3-Clause & BSD-4-Clause"
6LIC_FILES_CHKSUM = "file://COPYING;md5=87266591c81260f10221f1f38872d023"
7
8SRC_URI = "https://ftp.sdaoden.eu/${BP}.tar.xz \
9 file://make-errors.patch"
10SRC_URI[sha256sum] = "2c717b22f4cd8719b82b6618640da6031382d2bf8eb51283bca2c6266957bca8"
11
12DEPENDS = "coreutils-native"
13
14B = "${WORKDIR}/build"
15
16inherit update-alternatives
17
18EXTRA_OEMAKE = "VERBOSE=yes \
19 CONFIG=minimal \
20 OPT_AUTOCC=no \
21 OPT_CROSS_BUILD=yes \
22 OBJDIR=${B} \
23 strip=true \
24 VAL_PREFIX=${prefix} \
25 VAL_BINDIR=${bindir} \
26 VAL_LIBEXECDIR=${libexecdir} \
27 VAL_MANDIR=${mandir} \
28 VAL_SYSCONFDIR=${sysconfdir}"
29
30do_configure[cleandirs] += "${B}"
31do_configure() {
32 oe_runmake -C ${S} config
33}
34
35do_compile() {
36 oe_runmake -C ${S} build
37}
38
39do_install() {
40 oe_runmake -C ${S} install DESTDIR=${D}
41}
42
43ALTERNATIVE:${PN} = "mailx"
44ALTERNATIVE_TARGET[mailx] = "${bindir}/s-nail"