summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorChangqing Li <changqing.li@windriver.com>2022-03-03 11:32:48 +0800
committerKhem Raj <raj.khem@gmail.com>2022-03-03 08:50:19 -0800
commit8ae1498fa9f60a6252bfd4ead993d6684b0a7c27 (patch)
tree926f6c5248a9175743b20501a726f5b6a57820af /meta-oe
parent5e8f4720aaa3da7350ead06959cae0492133cd61 (diff)
downloadmeta-openembedded-8ae1498fa9f60a6252bfd4ead993d6684b0a7c27.tar.gz
hstr: add new recipe
hstr is bash and zsh shell history suggest box - easily view, navigate, search and manage your command history. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb1
-rw-r--r--meta-oe/recipes-support/hstr/files/0001-Use-OE-specific-checks-for-ncurses.patch42
-rw-r--r--meta-oe/recipes-support/hstr/files/0001-configure.ac-Don-t-use-AC_CHECK_FILE.patch33
-rw-r--r--meta-oe/recipes-support/hstr/hstr_2.5.0.bb17
4 files changed, 93 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
index d7076c211..5992cdd95 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
@@ -759,6 +759,7 @@ RDEPENDS:packagegroup-meta-oe-support ="\
759 gpm \ 759 gpm \
760 gsoap \ 760 gsoap \
761 hdf5 \ 761 hdf5 \
762 hstr \
762 htop \ 763 htop \
763 hunspell-dictionaries \ 764 hunspell-dictionaries \
764 hunspell \ 765 hunspell \
diff --git a/meta-oe/recipes-support/hstr/files/0001-Use-OE-specific-checks-for-ncurses.patch b/meta-oe/recipes-support/hstr/files/0001-Use-OE-specific-checks-for-ncurses.patch
new file mode 100644
index 000000000..d7eb558a9
--- /dev/null
+++ b/meta-oe/recipes-support/hstr/files/0001-Use-OE-specific-checks-for-ncurses.patch
@@ -0,0 +1,42 @@
1From f3fb4f12fac75efe0d8f1a923ad5992a7433d0db Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Wed, 2 Mar 2022 06:22:15 +0000
4Subject: [PATCH] Use OE-specific checks for ncurses
5
6Upstream-Status: Inappropriate[oe specific]
7
8Signed-off-by: Changqing Li <changqing.li@windriver.com>
9---
10 src/include/hstr.h | 2 +-
11 src/include/hstr_curses.h | 2 +-
12 2 files changed, 2 insertions(+), 2 deletions(-)
13
14diff --git a/src/include/hstr.h b/src/include/hstr.h
15index 5eac881..c47cadb 100644
16--- a/src/include/hstr.h
17+++ b/src/include/hstr.h
18@@ -26,7 +26,7 @@
19 #elif defined(__FreeBSD__)
20 #include <ncurses.h>
21 #else
22- #include <ncursesw/curses.h>
23+ #include <curses.h>
24 #endif
25 #include <readline/chardefs.h>
26 #include <signal.h>
27diff --git a/src/include/hstr_curses.h b/src/include/hstr_curses.h
28index 8a50ab9..1f081a8 100644
29--- a/src/include/hstr_curses.h
30+++ b/src/include/hstr_curses.h
31@@ -24,7 +24,7 @@
32 #elif defined(__FreeBSD__)
33 #include <ncurses.h>
34 #else
35-#include <ncursesw/curses.h>
36+#include <curses.h>
37 #endif
38
39 #define color_attr_on(C) if(terminal_has_colors()) { attron(C); }
40--
412.31.1
42
diff --git a/meta-oe/recipes-support/hstr/files/0001-configure.ac-Don-t-use-AC_CHECK_FILE.patch b/meta-oe/recipes-support/hstr/files/0001-configure.ac-Don-t-use-AC_CHECK_FILE.patch
new file mode 100644
index 000000000..e9b44c4c9
--- /dev/null
+++ b/meta-oe/recipes-support/hstr/files/0001-configure.ac-Don-t-use-AC_CHECK_FILE.patch
@@ -0,0 +1,33 @@
1From d5ad538adb9fcbad8a3b4e46f266b668301cb1c4 Mon Sep 17 00:00:00 2001
2From: Changqing Li <changqing.li@windriver.com>
3Date: Wed, 2 Mar 2022 05:36:48 +0000
4Subject: [PATCH] configure.ac: Don't use AC_CHECK_FILE
5
6AC_CHECK_FILE is not suitable for cross-compile, so
7remove it to fix configure error:
8cannot check for file existence when cross compiling
9
10Upstream-Status: Inappropriate[oe specific]
11
12Signed-off-by: Changqing Li <changqing.li@windriver.com>
13---
14 configure.ac | 3 ---
15 1 file changed, 3 deletions(-)
16
17diff --git a/configure.ac b/configure.ac
18index 775c795..bd99188 100644
19--- a/configure.ac
20+++ b/configure.ac
21@@ -116,9 +116,6 @@ AC_TYPE_SIZE_T
22 AC_FUNC_MALLOC
23 AC_CHECK_FUNCS([memset strdup strstr])
24
25-# Bash@Ubuntu@Windows
26-AC_CHECK_FILE(/tmp/hstr-ms-wsl,AC_DEFINE(__MS_WSL__), [])
27-
28 # Bash CLI autocomplete
29 AC_ARG_WITH([bash-completion-dir],
30 AS_HELP_STRING([--with-bash-completion-dir[=PATH]],
31--
322.31.1
33
diff --git a/meta-oe/recipes-support/hstr/hstr_2.5.0.bb b/meta-oe/recipes-support/hstr/hstr_2.5.0.bb
new file mode 100644
index 000000000..6c9f65e82
--- /dev/null
+++ b/meta-oe/recipes-support/hstr/hstr_2.5.0.bb
@@ -0,0 +1,17 @@
1SUMMARY = "bash and zsh shell history suggest box - easily view, navigate, search and manage your command history."
2HOMEPAGE = "http://dvorka.github.io/hstr/"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314"
6
7DEPENDS = "ncurses readline"
8
9SRC_URI = "https://github.com/dvorka/hstr/releases/download/2.5/hstr-${PV}-tarball.tgz \
10 file://0001-configure.ac-Don-t-use-AC_CHECK_FILE.patch \
11 file://0001-Use-OE-specific-checks-for-ncurses.patch"
12
13S = "${WORKDIR}/${BPN}"
14
15SRC_URI[sha256sum] = "44bb6d93ef064536218f8ae5464772861bfccfe364a436397d9f770207cd306d"
16
17inherit autotools pkgconfig bash-completion