summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-02-13 14:52:06 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 17:45:45 +0100
commit841ecdc58dd1d920d327fe4c7a29a6f8e7ba8857 (patch)
tree29c92c5cba589bc11d9b4b9411731ba26a348cf2 /meta-oe
parent4b84687da0a9c27a2d10cf90719b8b3d55d79035 (diff)
downloadmeta-openembedded-841ecdc58dd1d920d327fe4c7a29a6f8e7ba8857.tar.gz
source-han-sans-kr-fonts: initial add 1.004
Based on [1]. [1] https://projects.archlinux.org/svntogit/community.git/tree/trunk?h=packages/adobe-source-han-sans-fonts Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/source-han-sans-kr-fonts/44-source-han-sans-kr.conf19
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/source-han-sans-kr-fonts_1.004.bb34
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/ttf-fonts/source-han-sans-kr-fonts/44-source-han-sans-kr.conf b/meta-oe/recipes-graphics/ttf-fonts/source-han-sans-kr-fonts/44-source-han-sans-kr.conf
new file mode 100644
index 000000000..dee73ae77
--- /dev/null
+++ b/meta-oe/recipes-graphics/ttf-fonts/source-han-sans-kr-fonts/44-source-han-sans-kr.conf
@@ -0,0 +1,19 @@
1<?xml version="1.0" encoding="UTF-8"?>
2<!DOCTYPE fontconfig SYSTEM "../fonts.dtd">
3<fontconfig>
4 <!--
5 - Medium variant is used instead of Regular on Qt apps:
6 https://bugs.launchpad.net/ubuntu-font-family/+bug/744812
7 - Medium and Bold looks the same in certain applications:
8 https://bugs.launchpad.net/ubuntu/+source/gnome-specimen/+bug/813373
9 -->
10 <match target="scan">
11 <test name="fullname" compare="eq">
12 <string>Source Han Sans KR Medium</string>
13 </test>
14 <edit name="weight" mode="assign">
15 <const>demibold</const>
16 </edit>
17 </match>
18</fontconfig>
19
diff --git a/meta-oe/recipes-graphics/ttf-fonts/source-han-sans-kr-fonts_1.004.bb b/meta-oe/recipes-graphics/ttf-fonts/source-han-sans-kr-fonts_1.004.bb
new file mode 100644
index 000000000..c91d1671f
--- /dev/null
+++ b/meta-oe/recipes-graphics/ttf-fonts/source-han-sans-kr-fonts_1.004.bb
@@ -0,0 +1,34 @@
1require ttf.inc
2
3SUMMARY = "Adobe OpenType Pan-CJK font family for Korean"
4HOMEPAGE = "https://github.com/adobe-fonts/source-han-sans"
5LICENSE = "OFL-1.1"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=55719faa0112708e946b820b24b14097"
7
8inherit allarch fontcache
9
10# Download tends to break - so - or not?
11#EXCLUDE_FROM_WORLD = "1"
12
13SRC_URI = " \
14 https://github.com/adobe-fonts/source-han-sans/raw/release/SubsetOTF/SourceHanSansKR.zip \
15 file://44-source-han-sans-kr.conf \
16"
17SRC_URI[md5sum] = "f8d1bd6c87d8575afdb25e2f46bd81d4"
18SRC_URI[sha256sum] = "38fd15c80f9980492faaa1af39ff873d8a38e45027023fb17d5b10d4b4b0e6af"
19
20S = "${WORKDIR}/SourceHanSansKR"
21
22do_install() {
23 install -d ${D}${sysconfdir}/fonts/conf.d/
24 install -m 0644 ${WORKDIR}/44-source-han-sans-kr.conf ${D}${sysconfdir}/fonts/conf.d/
25
26 install -d ${D}${datadir}/fonts/truetype/
27 find ./ -name '*.otf' -exec install -m 0644 {} ${D}${datadir}/fonts/truetype/ \;
28}
29
30FILES_${PN} = " \
31 ${sysconfdir}/fonts \
32 ${datadir}/fonts \
33"
34