summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorPeter Kjellerstedt <pkj@axis.com>2023-11-22 01:50:42 +0100
committerKhem Raj <raj.khem@gmail.com>2023-11-21 17:26:10 -0800
commit837b2b346c9b711c566e425e436730fa04ac36b3 (patch)
tree0c0811790740701cf27ba5f6575413a992a80a8a /meta-oe
parentba89a9058acbc1d20987373e60e528cc2518aff1 (diff)
downloadmeta-openembedded-837b2b346c9b711c566e425e436730fa04ac36b3.tar.gz
zeromq: Update to 4.3.5
A backported patch has been removed as it is no longer needed. License-Update: Relicensed as MPL-2.0 Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-connectivity/zeromq/files/0001-src-secure_allocator.hpp-define-missing-rebind-type.patch64
-rw-r--r--meta-oe/recipes-connectivity/zeromq/zeromq_4.3.5.bb (renamed from meta-oe/recipes-connectivity/zeromq/zeromq_4.3.4.bb)8
2 files changed, 3 insertions, 69 deletions
diff --git a/meta-oe/recipes-connectivity/zeromq/files/0001-src-secure_allocator.hpp-define-missing-rebind-type.patch b/meta-oe/recipes-connectivity/zeromq/files/0001-src-secure_allocator.hpp-define-missing-rebind-type.patch
deleted file mode 100644
index d32190818..000000000
--- a/meta-oe/recipes-connectivity/zeromq/files/0001-src-secure_allocator.hpp-define-missing-rebind-type.patch
+++ /dev/null
@@ -1,64 +0,0 @@
1From 66e72389cc90625ed74e8ba1ea3a65234bdb06b5 Mon Sep 17 00:00:00 2001
2From: Sergei Trofimovich <slyich@gmail.com>
3Date: Tue, 20 Dec 2022 21:45:16 +0000
4Subject: [PATCH] src/secure_allocator.hpp: define missing 'rebind' type
5
6`gcc-13` added an assert to standard headers to make sure custom
7allocators have intended implementation of rebind type instead
8of inherited rebind. gcc change:
9 https://gcc.gnu.org/git/?p=gcc.git;a=commitdiff;h=64c986b49558a7
10
11Without the fix build fails on this week's `gcc-13` as:
12
13 [ 92%] Building CXX object tests/CMakeFiles/test_security_curve.dir/test_security_curve.cpp.o
14 In file included from /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/ext/alloc_traits.h:34,
15 from /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/stl_uninitialized.h:64,
16 from /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/memory:69,
17 from tests/../src/secure_allocator.hpp:42,
18 from tests/../src/curve_client_tools.hpp:49,
19 from tests/test_security_curve.cpp:53:
20 /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h: In instantiation of 'struct std::__allocator_traits_base::__rebind<zmq::secure_allocator_t<unsigned char>, unsigned char, void>':
21 /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h:94:11: required by substitution of 'template<class _Alloc, class _Up> using std::__alloc_rebind = typename std::__allocator_traits_base::__rebind<_Alloc, _Up>::type [with _Alloc = zmq::secure_allocator_t<unsigned char>; _Up = unsigned char]'
22 /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h:228:8: required by substitution of 'template<class _Alloc> template<class _Tp> using std::allocator_traits< <template-parameter-1-1> >::rebind_alloc = std::__alloc_rebind<_Alloc, _Tp> [with _Tp = unsigned char; _Alloc = zmq::secure_allocator_t<unsigned char>]'
23 /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/ext/alloc_traits.h:126:65: required from 'struct __gnu_cxx::__alloc_traits<zmq::secure_allocator_t<unsigned char>, unsigned char>::rebind<unsigned char>'
24 /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/stl_vector.h:88:21: required from 'struct std::_Vector_base<unsigned char, zmq::secure_allocator_t<unsigned char> >'
25 /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/stl_vector.h:423:11: required from 'class std::vector<unsigned char, zmq::secure_allocator_t<unsigned char> >'
26 tests/../src/curve_client_tools.hpp:64:76: required from here
27 /<<NIX>>/gcc-13.0.0/include/c++/13.0.0/bits/alloc_traits.h:70:31: error: static assertion failed: allocator_traits<A>::rebind_alloc<A::value_type> must be A
28 70 | _Tp>::value,
29 | ^~~~~
30
31The change adds trivial `rebind` definition with expected return type
32and satisfies conversion requirements.
33
34Upstream-Status: Backport [https://github.com/zeromq/libzmq/commit/438d5d88]
35Signed-off-by: Khem Raj <raj.khem@gmail.com>
36---
37 src/secure_allocator.hpp | 11 +++++++++++
38 1 file changed, 11 insertions(+)
39
40diff --git a/src/secure_allocator.hpp b/src/secure_allocator.hpp
41index 0d37e7ed..5b8de9e2 100644
42--- a/src/secure_allocator.hpp
43+++ b/src/secure_allocator.hpp
44@@ -95,6 +95,17 @@ bool operator!= (const secure_allocator_t<T> &, const secure_allocator_t<U> &)
45 #else
46 template <typename T> struct secure_allocator_t : std::allocator<T>
47 {
48+ secure_allocator_t () ZMQ_DEFAULT;
49+
50+ template <class U>
51+ secure_allocator_t (const secure_allocator_t<U> &) ZMQ_NOEXCEPT
52+ {
53+ }
54+
55+ template <class U> struct rebind
56+ {
57+ typedef secure_allocator_t<U> other;
58+ };
59 };
60 #endif
61 }
62--
632.39.1
64
diff --git a/meta-oe/recipes-connectivity/zeromq/zeromq_4.3.4.bb b/meta-oe/recipes-connectivity/zeromq/zeromq_4.3.5.bb
index cd319b5d3..555458217 100644
--- a/meta-oe/recipes-connectivity/zeromq/zeromq_4.3.4.bb
+++ b/meta-oe/recipes-connectivity/zeromq/zeromq_4.3.5.bb
@@ -1,18 +1,16 @@
1DESCRIPTION = "ZeroMQ looks like an embeddable networking library but acts like a concurrency framework" 1DESCRIPTION = "ZeroMQ looks like an embeddable networking library but acts like a concurrency framework"
2HOMEPAGE = "http://www.zeromq.org" 2HOMEPAGE = "http://www.zeromq.org"
3LICENSE = "LGPL-3.0-with-zeromq-exception" 3LICENSE = "MPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=d5311495d952062e0e4fbba39cbf3de1" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=9741c346eef56131163e13b9db1241b3"
5 5
6PACKAGECONFIG ??= "libsodium" 6PACKAGECONFIG ??= "libsodium"
7PACKAGECONFIG[libsodium] = "-DWITH_LIBSODIUM=ON,-DWITH_LIBSODIUM=OFF, libsodium" 7PACKAGECONFIG[libsodium] = "-DWITH_LIBSODIUM=ON,-DWITH_LIBSODIUM=OFF, libsodium"
8 8
9SRC_URI = "http://github.com/zeromq/libzmq/releases/download/v${PV}/zeromq-${PV}.tar.gz \ 9SRC_URI = "http://github.com/zeromq/libzmq/releases/download/v${PV}/zeromq-${PV}.tar.gz \
10 file://0001-CMakeLists-txt-Avoid-host-specific-path-to-libsodium.patch \ 10 file://0001-CMakeLists-txt-Avoid-host-specific-path-to-libsodium.patch \
11 file://0001-src-secure_allocator.hpp-define-missing-rebind-type.patch \
12 file://run-ptest \ 11 file://run-ptest \
13" 12"
14SRC_URI[md5sum] = "c897d4005a3f0b8276b00b7921412379" 13SRC_URI[sha256sum] = "6653ef5910f17954861fe72332e68b03ca6e4d9c7160eb3a8de5a5a913bfab43"
15SRC_URI[sha256sum] = "c593001a89f5a85dd2ddf564805deb860e02471171b3f204944857336295c3e5"
16 14
17UPSTREAM_CHECK_URI = "https://github.com/${BPN}/libzmq/releases" 15UPSTREAM_CHECK_URI = "https://github.com/${BPN}/libzmq/releases"
18 16