summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2022-04-03 19:36:06 +0200
committerKhem Raj <raj.khem@gmail.com>2022-04-06 20:25:34 -0400
commit8253fe2a9cd699c1f3709c721b911b64c830e314 (patch)
treebd6e7cd761830acd4d01f8a8989ad650b93b497b /meta-oe
parentbcb6af4c10d4092bb8ca92900f815434565f63c2 (diff)
downloadmeta-openembedded-8253fe2a9cd699c1f3709c721b911b64c830e314.tar.gz
upower: upgrade 0.99.13 -> 0.99.17 / build with mesom
Port to meson turned into total overhaul of recipe Version 0.99.17 --------------- Released: 2022-03-09 Bug fixes: - Fix FD handling issues that may cause lid to not be detected Version 0.99.16 --------------- Released: 2022-02-23 Bug fixes: - Silence unnecessary udev event warnings - Increase test timeout (#171) - Explicitly link with plist - Fix UpClient reference leak - Fix DisplayDevice state on battery hotplug - Fix critical action to work after it was cancelled (#172) Version 0.99.15 --------------- Released: 2022-02-09 Bug fixes: - Various build fixes - Update bluetooth device alias when it changes (#169) No info for 0.99.14 Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/upower/upower_0.99.13.bb38
-rw-r--r--meta-oe/recipes-support/upower/upower_0.99.17.bb44
2 files changed, 44 insertions, 38 deletions
diff --git a/meta-oe/recipes-support/upower/upower_0.99.13.bb b/meta-oe/recipes-support/upower/upower_0.99.13.bb
deleted file mode 100644
index 55a735482..000000000
--- a/meta-oe/recipes-support/upower/upower_0.99.13.bb
+++ /dev/null
@@ -1,38 +0,0 @@
1DESCRIPTION = "UPower is an abstraction for enumerating power devices, listening to device events and querying history and statistics. "
2LICENSE = "GPL-2.0-or-later"
3LIC_FILES_CHKSUM = "file://COPYING;md5=0de8fbf1d97a140d1d93b9f14dcfbf08"
4
5DEPENDS = "intltool-native libusb1 libgudev glib-2.0 dbus-glib"
6
7SRC_URI = "git://gitlab.freedesktop.org/upower/upower.git;protocol=https;branch=master"
8SRCREV = "0f6cc0a10be22d7ddd684e1cd851e4364a440494"
9S = "${WORKDIR}/git"
10
11UPSTREAM_CHECK_GITTAGREGEX = "UPOWER_(?P<pver>\d+(\_\d+)+)"
12
13inherit autotools pkgconfig gtk-doc gettext gobject-introspection systemd
14
15PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
16PACKAGECONFIG[idevice] = "--with-idevice,--without-idevice,libimobiledevice libplist"
17PACKAGECONFIG[systemd] = "--with-systemdutildir=${systemd_unitdir} --with-systemdsystemunitdir=${systemd_system_unitdir}, \
18 --without-systemdutildir --without-systemdsystemunitdir,systemd"
19
20EXTRA_OECONF = " --with-backend=linux"
21
22SYSTEMD_SERVICE:${PN} = "upower.service"
23# don't start on boot by default - dbus does that on demand
24SYSTEMD_AUTO_ENABLE = "disable"
25
26do_configure:prepend() {
27 touch ${S}/ABOUT-NLS
28 mkdir -p ${S}/build-aux
29 touch ${S}/build-aux/config.rpath
30 sed -i -e s:-nonet:\:g ${S}/doc/man/Makefile.am
31 sed -i -e 's: doc : :g' ${S}/Makefile.am
32}
33
34RDEPENDS:${PN} += "dbus"
35RRECOMMENDS:${PN} += "pm-utils"
36FILES:${PN} += "${datadir}/dbus-1/ \
37 ${base_libdir}/udev/* \
38"
diff --git a/meta-oe/recipes-support/upower/upower_0.99.17.bb b/meta-oe/recipes-support/upower/upower_0.99.17.bb
new file mode 100644
index 000000000..d30fcea87
--- /dev/null
+++ b/meta-oe/recipes-support/upower/upower_0.99.17.bb
@@ -0,0 +1,44 @@
1SUMMARY = "UPower is an abstraction for enumerating power devices"
2DESCRIPTION = "UPower is an abstraction for enumerating power devices, listening to device events and querying history and statistics."
3LICENSE = "GPL-2.0-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0de8fbf1d97a140d1d93b9f14dcfbf08"
5
6DEPENDS = " \
7 intltool-native \
8 libusb1 \
9 libgudev \
10 glib-2.0 \
11 dbus-glib \
12"
13
14SRC_URI = "git://gitlab.freedesktop.org/upower/upower.git;protocol=https;branch=master"
15SRCREV = "c889154ec8e3e2239db9260d48b2e198d72ba002"
16S = "${WORKDIR}/git"
17
18UPSTREAM_CHECK_GITTAGREGEX = "UPOWER_(?P<pver>\d+(\_\d+)+)"
19
20GIR_MESON_ENABLE_FLAG = "enabled"
21GIR_MESON_DISABLE_FLAG = "disabled"
22GTKDOC_MESON_OPTION = "gtk-doc"
23
24inherit meson pkgconfig gtk-doc gettext gobject-introspection systemd
25
26PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
27PACKAGECONFIG[idevice] = "-Didevice=enabled,-Didevice=disabled,libimobiledevice libplist"
28PACKAGECONFIG[systemd] = "-Dsystemdsystemunitdir=${systemd_system_unitdir},-Dsystemdsystemunitdir=no,systemd"
29
30EXTRA_OEMESON = " \
31 -Dos_backend=linux \
32 -Dman=false \
33"
34
35SYSTEMD_SERVICE:${PN} = "upower.service"
36# don't start on boot by default - dbus does that on demand
37SYSTEMD_AUTO_ENABLE = "disable"
38
39RDEPENDS:${PN} += "dbus"
40RRECOMMENDS:${PN} += "pm-utils"
41FILES:${PN} += " \
42 ${datadir}/dbus-1/ \
43 ${base_libdir}/udev/* \
44"