summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2024-05-10 07:47:08 +0200
committerKhem Raj <raj.khem@gmail.com>2024-05-19 08:27:51 -0700
commit7cceba0e2cbe5b045c1dc175cfdfefd7fbd3bc62 (patch)
treef873f01541bce368873f89e89d6ae833692638b2 /meta-oe
parentc16704f6a38dabfccc7a0651fa9ba4c67b6f510a (diff)
downloadmeta-openembedded-7cceba0e2cbe5b045c1dc175cfdfefd7fbd3bc62.tar.gz
fuse3: move from meta-filesystems to meta-oe
Technically flatpak and xdg-desktop-portal have a runtime dependency on fuse3-utils. I was worried that adding it might cause problems with CI since fuse3 is not included in meta-oe. Given that both packages also require fuse3 at buildtime it could be a good idea to move fuse3 to avoid a meta-filesystems dependency for meta-oe Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/fuse/fuse3/run-ptest3
-rw-r--r--meta-oe/recipes-support/fuse/fuse3_3.16.2.bb83
2 files changed, 86 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fuse/fuse3/run-ptest b/meta-oe/recipes-support/fuse/fuse3/run-ptest
new file mode 100644
index 000000000..b63c4de0d
--- /dev/null
+++ b/meta-oe/recipes-support/fuse/fuse3/run-ptest
@@ -0,0 +1,3 @@
1#!/bin/sh
2
3pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-oe/recipes-support/fuse/fuse3_3.16.2.bb b/meta-oe/recipes-support/fuse/fuse3_3.16.2.bb
new file mode 100644
index 000000000..307544bf3
--- /dev/null
+++ b/meta-oe/recipes-support/fuse/fuse3_3.16.2.bb
@@ -0,0 +1,83 @@
1SUMMARY = "Implementation of a fully functional filesystem in a userspace program"
2DESCRIPTION = "FUSE (Filesystem in Userspace) is a simple interface for userspace \
3 programs to export a virtual filesystem to the Linux kernel. FUSE \
4 also aims to provide a secure method for non privileged users to \
5 create and mount their own filesystem implementations. \
6 "
7HOMEPAGE = "https://github.com/libfuse/libfuse"
8SECTION = "libs"
9LICENSE = "GPL-2.0-only & LGPL-2.0-only"
10LIC_FILES_CHKSUM = " \
11 file://GPL2.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
12 file://LGPL2.txt;md5=4fbd65380cdd255951079008b364516c \
13 file://LICENSE;md5=a55c12a2d7d742ecb41ca9ae0a6ddc66 \
14"
15
16SRC_URI = "https://github.com/libfuse/libfuse/releases/download/fuse-${PV}/fuse-${PV}.tar.gz"
17SRC_URI[sha256sum] = "f797055d9296b275e981f5f62d4e32e089614fc253d1ef2985851025b8a0ce87"
18
19S = "${WORKDIR}/fuse-${PV}"
20
21UPSTREAM_CHECK_URI = "https://github.com/libfuse/libfuse/releases"
22UPSTREAM_CHECK_REGEX = "fuse\-(?P<pver>3(\.\d+)+).tar.xz"
23
24CVE_PRODUCT = "fuse_project:fuse"
25
26inherit meson pkgconfig ptest
27
28SRC_URI += " \
29 file://run-ptest \
30"
31
32RDEPENDS:${PN}-ptest += " \
33 python3-pytest \
34 python3-looseversion \
35 bash \
36"
37RRECOMMENDS:${PN}-ptest += " kernel-module-cuse"
38
39do_install_ptest() {
40 install -d ${D}${PTEST_PATH}/test
41 install -d ${D}${PTEST_PATH}/example
42 install -d ${D}${PTEST_PATH}/util
43 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
44
45 example_excutables=`find ${B}/example -type f -executable`
46 util_excutables=`find ${B}/util -type f -executable`
47 test_excutables=`find ${B}/test -type f -executable`
48
49 for e in $example_excutables
50 do
51 cp -rf $e ${D}${PTEST_PATH}/example/
52 done
53
54 for e in $util_excutables
55 do
56 cp -rf $e ${D}${PTEST_PATH}/util/
57 done
58
59 for e in $test_excutables
60 do
61 cp -rf $e ${D}${PTEST_PATH}/test
62 done
63}
64
65DEPENDS = "udev"
66
67PACKAGES =+ "fuse3-utils"
68
69RPROVIDES:${PN}-dbg += "fuse3-utils-dbg"
70
71RRECOMMENDS:${PN}:class-target = "kernel-module-fuse fuse3-utils"
72
73FILES:${PN} += "${libdir}/libfuse3.so.*"
74FILES:${PN}-dev += "${libdir}/libfuse3*.la"
75
76# Forbid auto-renaming to libfuse3-utils
77FILES:fuse3-utils = "${bindir} ${base_sbindir}"
78DEBIAN_NOAUTONAME:fuse3-utils = "1"
79DEBIAN_NOAUTONAME:${PN}-dbg = "1"
80
81do_install:append() {
82 rm -rf ${D}${base_prefix}/dev
83}