summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorakuster <akuster808@gmail.com>2021-02-17 20:29:33 +0000
committerKhem Raj <raj.khem@gmail.com>2021-02-17 14:01:51 -0800
commit7b7a8412a41ba96cc19ee330c764753fdb04ceb8 (patch)
tree97c023082c9763b4230d7b4a1986bdf354bd328e /meta-oe
parentac4c2dc26d935d89fa7de498ddbb1f8dee7b3718 (diff)
downloadmeta-openembedded-7b7a8412a41ba96cc19ee330c764753fdb04ceb8.tar.gz
softhsm: update to 2.6.1 and align
meta-security has this pkg to but newer. Move from meta-sec to meta-oe minor cleanups. Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-security/softhsm/softhsm_2.6.1.bb30
-rw-r--r--meta-oe/recipes-security/softhsm/softhsm_git.bb18
2 files changed, 30 insertions, 18 deletions
diff --git a/meta-oe/recipes-security/softhsm/softhsm_2.6.1.bb b/meta-oe/recipes-security/softhsm/softhsm_2.6.1.bb
new file mode 100644
index 000000000..aa91ab37f
--- /dev/null
+++ b/meta-oe/recipes-security/softhsm/softhsm_2.6.1.bb
@@ -0,0 +1,30 @@
1SUMMARY = "PKCS#11 HSM/Token Emulator"
2HOMEPAGE = "https://www.opendnssec.org/softhsm/"
3LICENSE = "BSD-2-Clause & ISC"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=ef3f77a3507c3d91e75b9f2bdaee4210"
5
6DEPENDS = "sqlite3"
7
8SRC_URI = "https://dist.opendnssec.org/source/softhsm-2.6.1.tar.gz"
9SRC_URI[sha256sum] = "61249473054bcd1811519ef9a989a880a7bdcc36d317c9c25457fc614df475f2"
10
11inherit autotools pkgconfig siteinfo
12
13EXTRA_OECONF += " --with-sqlite3=${STAGING_DIR_HOST}/usr"
14EXTRA_OECONF += "${@oe.utils.conditional('SITEINFO_BITS', '64', ' --enable-64bit', '', d)}"
15
16PACKAGECONFIG ?= "ecc eddsa pk11 openssl"
17
18PACKAGECONFIG[npm] = ",--disable-non-paged-memory"
19PACKAGECONFIG[ecc] = "--enable-ecc,--disable-ecc"
20PACKAGECONFIG[gost] = "--enable-gost,--disable-gost"
21PACKAGECONFIG[eddsa] = "--enable-eddsa, --disable-eddsa"
22PACKAGECONFIG[fips] = "--enable-fips, --disable-fips"
23PACKAGECONFIG[notvisable] = "--disable-visibility"
24PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}/usr --with-crypto-backend=openssl, --without-openssl, openssl, openssl"
25PACKAGECONFIG[botan] = "--with-botan=${STAGING_DIR_HOST}/usr --with-crypto-backend=botan, --without-botan, botan"
26PACKAGECONFIG[migrate] = "--with-migrate"
27PACKAGECONFIG[pk11] = "--enable-p11-kit --with-p11-kit==${STAGING_DIR_HOST}/usr, --without-p11-kit, p11-kit, p11-kit"
28
29RDEPENDS_${PN} = "sqlite3"
30BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-oe/recipes-security/softhsm/softhsm_git.bb b/meta-oe/recipes-security/softhsm/softhsm_git.bb
deleted file mode 100644
index 3236cb9a6..000000000
--- a/meta-oe/recipes-security/softhsm/softhsm_git.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1SUMMARY = "PKCS#11 HSM/Token Emulator"
2HOMEPAGE = "https://www.opendnssec.org/softhsm/"
3LICENSE = "BSD-2-Clause & ISC"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=ef3f77a3507c3d91e75b9f2bdaee4210"
5DEPENDS = "openssl"
6PV = "2.5.0"
7
8SRC_URI = "git://github.com/opendnssec/SoftHSMv2.git;branch=master"
9SRCREV = "369df0383d101bc8952692c2a368ac8bc887d1b4"
10
11S = "${WORKDIR}/git"
12
13inherit autotools pkgconfig
14
15# EdDSA requires OpenSSL >= 1.1.1
16EXTRA_OECONF = "--enable-eddsa --disable-gost"
17
18BBCLASSEXTEND = "native"