summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-05 10:37:49 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-08 13:32:11 -0700
commit764eb5d9f8f94f394293e3706aa3be3a4d70cf76 (patch)
tree275969749f3dff59b64f190a3bf7bb90a30f49c1 /meta-oe
parent26f251fb1e0d2b5d7c2179504a6984020292fc5f (diff)
downloadmeta-openembedded-764eb5d9f8f94f394293e3706aa3be3a4d70cf76.tar.gz
asio: Upgrade to 1.12.1
* Fixes build with openSSL 1.1.x * Merge .inc into .bb its a single recipe using it License-Update: Change Copyright years Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/asio/asio/0001-Automatically-handle-glibc-variant-of-strerror_r-wit.patch46
-rw-r--r--meta-oe/recipes-support/asio/asio/0001-use-POSIX-poll.h-instead-of-sys-poll.h.patch64
-rw-r--r--meta-oe/recipes-support/asio/asio_1.10.6.bb11
-rw-r--r--meta-oe/recipes-support/asio/asio_1.12.1.bb (renamed from meta-oe/recipes-support/asio/asio.inc)7
4 files changed, 7 insertions, 121 deletions
diff --git a/meta-oe/recipes-support/asio/asio/0001-Automatically-handle-glibc-variant-of-strerror_r-wit.patch b/meta-oe/recipes-support/asio/asio/0001-Automatically-handle-glibc-variant-of-strerror_r-wit.patch
deleted file mode 100644
index 4244b97a8..000000000
--- a/meta-oe/recipes-support/asio/asio/0001-Automatically-handle-glibc-variant-of-strerror_r-wit.patch
+++ /dev/null
@@ -1,46 +0,0 @@
1From 45c855400842fd40f200ae9b7abf9debf4ab5436 Mon Sep 17 00:00:00 2001
2From: Christopher Kohlhoff <chris@kohlhoff.com>
3Date: Sun, 28 Aug 2016 09:21:53 +1000
4Subject: [PATCH] Automatically handle glibc variant of strerror_r without
5 #ifdefs.
6
7---
8Upstream-Status: Backport https://github.com/chriskohlhoff/asio/commit/443bc17d13eb5e37de780ea6e23157493cf7b3b9
9 include/asio/impl/error_code.ipp | 16 +++++++---------
10 1 file changed, 7 insertions(+), 9 deletions(-)
11
12diff --git a/include/asio/impl/error_code.ipp b/include/asio/impl/error_code.ipp
13index ccb70dd..a117658 100644
14--- a/include/asio/impl/error_code.ipp
15+++ b/include/asio/impl/error_code.ipp
16@@ -97,20 +97,18 @@ public:
17 #if defined(__sun) || defined(__QNX__) || defined(__SYMBIAN32__)
18 using namespace std;
19 return strerror(value);
20-#elif defined(__MACH__) && defined(__APPLE__) \
21- || defined(__NetBSD__) || defined(__FreeBSD__) || defined(__OpenBSD__) \
22- || defined(_AIX) || defined(__hpux) || defined(__osf__) \
23- || defined(__ANDROID__)
24- char buf[256] = "";
25- using namespace std;
26- strerror_r(value, buf, sizeof(buf));
27- return buf;
28 #else
29 char buf[256] = "";
30- return strerror_r(value, buf, sizeof(buf));
31+ using namespace std;
32+ return strerror_result(strerror_r(value, buf, sizeof(buf)), buf);
33 #endif
34 #endif // defined(ASIO_WINDOWS)
35 }
36+
37+private:
38+ // Helper function to adapt the result from glibc's variant of strerror_r.
39+ static const char* strerror_result(int, const char* s) { return s; }
40+ static const char* strerror_result(const char* s, const char*) { return s; }
41 };
42
43 } // namespace detail
44--
452.9.3
46
diff --git a/meta-oe/recipes-support/asio/asio/0001-use-POSIX-poll.h-instead-of-sys-poll.h.patch b/meta-oe/recipes-support/asio/asio/0001-use-POSIX-poll.h-instead-of-sys-poll.h.patch
deleted file mode 100644
index 7f95f5a25..000000000
--- a/meta-oe/recipes-support/asio/asio/0001-use-POSIX-poll.h-instead-of-sys-poll.h.patch
+++ /dev/null
@@ -1,64 +0,0 @@
1From dac36a170188917e2f61b0394ba8a2f6509ddf3a Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andr=C3=A9=20Draszik?= <adraszik@tycoint.com>
3Date: Tue, 8 Nov 2016 20:39:55 +0000
4Subject: [PATCH] use POSIX poll.h instead of sys/poll.h
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9POSIX specifies that <poll.h> is the correct header to
10include for poll()
11 http://pubs.opengroup.org/onlinepubs/009695399/functions/poll.html
12whereas <sys/poll.h> is only needed for ancient glibc (<2.3),
13so let's follow POSIX instead.
14
15As a side-effect, this silences numerous compilation warnings
16when compiling against the musl C-library:
17
18In file included from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/detail/socket_types.hpp:57:0,
19 from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/impl/error_code.ipp:29,
20 from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/error_code.hpp:185,
21 from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/detail/throw_error.hpp:19,
22 from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/detail/impl/posix_tss_ptr.ipp:23,
23 from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/detail/posix_tss_ptr.hpp:74,
24 from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/detail/tss_ptr.hpp:27,
25 from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/detail/call_stack.hpp:20,
26 from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/impl/handler_alloc_hook.ipp:19,
27 from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/handler_alloc_hook.hpp:78,
28 from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/detail/handler_alloc_helpers.hpp:21,
29 from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/detail/bind_handler.hpp:19,
30 from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/detail/wrapped_handler.hpp:18,
31 from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/io_service.hpp:24,
32 from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/basic_io_object.hpp:19,
33 from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/basic_socket.hpp:20,
34 from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio/basic_datagram_socket.hpp:20,
35 from ../../../../asio-1.10.6/src/examples/cpp03/../../../include/asio.hpp:19,
36 from ../../../../asio-1.10.6/src/examples/cpp03/buffers/reference_counted.cpp:11:
37<sysroot>/usr/include/sys/poll.h:1:2: warning: #warning redirecting incorrect #include <sys/poll.h> to <poll.h> [-Wcpp]
38 #warning redirecting incorrect #include <sys/poll.h> to <poll.h>
39 ^~~~~~~
40
41etc.
42
43Signed-off-by: André Draszik <adraszik@tycoint.com>
44---
45Upstream-Status: Submitted https://svn.boost.org/trac/boost/ticket/12419
46 include/asio/detail/socket_types.hpp | 2 +-
47 1 file changed, 1 insertion(+), 1 deletion(-)
48
49diff --git a/include/asio/detail/socket_types.hpp b/include/asio/detail/socket_types.hpp
50index f2600c2..cb61b8e 100644
51--- a/include/asio/detail/socket_types.hpp
52+++ b/include/asio/detail/socket_types.hpp
53@@ -54,7 +54,7 @@
54 #else
55 # include <sys/ioctl.h>
56 # if !defined(__SYMBIAN32__)
57-# include <sys/poll.h>
58+# include <poll.h>
59 # endif
60 # include <sys/types.h>
61 # include <sys/stat.h>
62--
632.10.2
64
diff --git a/meta-oe/recipes-support/asio/asio_1.10.6.bb b/meta-oe/recipes-support/asio/asio_1.10.6.bb
deleted file mode 100644
index 565603984..000000000
--- a/meta-oe/recipes-support/asio/asio_1.10.6.bb
+++ /dev/null
@@ -1,11 +0,0 @@
1require asio.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=fede5286a78559dd646e355ab0cc8f04"
4
5SRC_URI[md5sum] = "85d014a356a6e004cd30ccd4c9b6a5c2"
6SRC_URI[sha256sum] = "e0d71c40a7b1f6c1334008fb279e7361b32a063e020efd21e40d9d8ff037195e"
7
8SRC_URI += "\
9 file://0001-Automatically-handle-glibc-variant-of-strerror_r-wit.patch \
10 file://0001-use-POSIX-poll.h-instead-of-sys-poll.h.patch \
11"
diff --git a/meta-oe/recipes-support/asio/asio.inc b/meta-oe/recipes-support/asio/asio_1.12.1.bb
index 54f78e41d..28cd9c0e1 100644
--- a/meta-oe/recipes-support/asio/asio.inc
+++ b/meta-oe/recipes-support/asio/asio_1.12.1.bb
@@ -13,3 +13,10 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/asio/${BP}.tar.bz2"
13inherit autotools 13inherit autotools
14 14
15ALLOW_EMPTY_${PN} = "1" 15ALLOW_EMPTY_${PN} = "1"
16
17LIC_FILES_CHKSUM = "file://COPYING;md5=3e73f311a3af69e6df275e8c3b1c09b5"
18
19SRC_URI[md5sum] = "037854d113024f57c9753d6326b339bc"
20SRC_URI[sha256sum] = "a9091b4de847539fa5b2259bf76a5355339c7eaaa5e33d7d4ae74d614c21965a"
21
22SRC_URI = "${SOURCEFORGE_MIRROR}/asio/${BP}.tar.bz2"