summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-03-18 00:19:51 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-17 19:46:35 -0700
commit6adacfcdbb29f3ed003307d1584167b7d2e92910 (patch)
treef4e018e68d1e620089547d11b714bbdf39cefe4c /meta-oe
parent3758a2d9c5aa75ad1b928a9bfbf1be94b0cbd9f5 (diff)
downloadmeta-openembedded-6adacfcdbb29f3ed003307d1584167b7d2e92910.tar.gz
rocksdb: upgrade 6.5.2 -> 6.6.4
0001-Fix-build-breakage-from-lock_guard-error-6161.patch removed since it is included in 6.6.4 Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-dbs/rocksdb/files/0001-Fix-build-breakage-from-lock_guard-error-6161.patch36
-rw-r--r--meta-oe/recipes-dbs/rocksdb/rocksdb_git.bb7
2 files changed, 3 insertions, 40 deletions
diff --git a/meta-oe/recipes-dbs/rocksdb/files/0001-Fix-build-breakage-from-lock_guard-error-6161.patch b/meta-oe/recipes-dbs/rocksdb/files/0001-Fix-build-breakage-from-lock_guard-error-6161.patch
deleted file mode 100644
index ac87d0c60..000000000
--- a/meta-oe/recipes-dbs/rocksdb/files/0001-Fix-build-breakage-from-lock_guard-error-6161.patch
+++ /dev/null
@@ -1,36 +0,0 @@
1From b626703de7ece507f360507e49d3ecb448b12e07 Mon Sep 17 00:00:00 2001
2From: Maysam Yabandeh <myabandeh@fb.com>
3Date: Thu, 12 Dec 2019 13:48:50 -0800
4Subject: [PATCH] Fix build breakage from lock_guard error (#6161)
5
6Summary:
7This change fixes a source issue that caused compile time error which breaks build for many fbcode services in that setup. The size() member function of channel is a const member, so member variables accessed within it are implicitly const as well. This caused error when clang fails to resolve to a constructor that takes std::mutex because the suitable constructor got rejected due to loss of constness for its argument. The fix is to add mutable modifier to the lock_ member of channel.
8Pull Request resolved: https://github.com/facebook/rocksdb/pull/6161
9
10Differential Revision: D18967685
11
12Pulled By: maysamyabandeh
13
14Upstream-Status: Backport
15
16fbshipit-source-id: 698b6a5153c3c92eeacb842c467aa28cc350d432
17---
18 util/channel.h | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/util/channel.h b/util/channel.h
22index 0225482c0..a8a47680a 100644
23--- a/util/channel.h
24+++ b/util/channel.h
25@@ -60,7 +60,7 @@ class channel {
26
27 private:
28 std::condition_variable cv_;
29- std::mutex lock_;
30+ mutable std::mutex lock_;
31 std::queue<T> buffer_;
32 bool eof_;
33 };
34--
352.24.1
36
diff --git a/meta-oe/recipes-dbs/rocksdb/rocksdb_git.bb b/meta-oe/recipes-dbs/rocksdb/rocksdb_git.bb
index 713d5bb14..e82b77e14 100644
--- a/meta-oe/recipes-dbs/rocksdb/rocksdb_git.bb
+++ b/meta-oe/recipes-dbs/rocksdb/rocksdb_git.bb
@@ -6,12 +6,11 @@ LIC_FILES_CHKSUM = "file://LICENSE.Apache;md5=3b83ef96387f14655fc854ddc3c6bd57 \
6 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ 6 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://LICENSE.leveldb;md5=fb04ff57a14f308f2eed4a9b87d45837" 7 file://LICENSE.leveldb;md5=fb04ff57a14f308f2eed4a9b87d45837"
8 8
9SRCREV = "4cfbd87afd08a16df28436fb990ef6b154ee6114" 9SRCREV = "551a110918493a19d11243f53408b97485de1411"
10SRCBRANCH = "6.5.fb" 10SRCBRANCH = "6.6.fb"
11PV = "6.5.2" 11PV = "6.6.4"
12 12
13SRC_URI = "git://github.com/facebook/${BPN}.git;branch=${SRCBRANCH} \ 13SRC_URI = "git://github.com/facebook/${BPN}.git;branch=${SRCBRANCH} \
14 file://0001-Fix-build-breakage-from-lock_guard-error-6161.patch \
15 file://0001-db-write_thread.cc-Initialize-state.patch \ 14 file://0001-db-write_thread.cc-Initialize-state.patch \
16 " 15 "
17 16