summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-18 23:41:54 -0800
committerKhem Raj <raj.khem@gmail.com>2018-12-23 13:29:20 -0800
commit640002dedc7718bbda6c6c516caf040aa6e3e20c (patch)
treee051b5d822f33c95a1e5f299cdf149bb040665cc /meta-oe
parentd8730f4328c32b2674e9ff76cb8f2c663c8a8dad (diff)
downloadmeta-openembedded-640002dedc7718bbda6c6c516caf040aa6e3e20c.tar.gz
modemmanager: Fix build with gcc9
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-connectivity/modemmanager/modemmanager/0001-Do-not-pass-null-string-to-s-printf-formatted-string.patch31
-rw-r--r--meta-oe/recipes-connectivity/modemmanager/modemmanager_1.8.2.bb1
2 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/modemmanager/modemmanager/0001-Do-not-pass-null-string-to-s-printf-formatted-string.patch b/meta-oe/recipes-connectivity/modemmanager/modemmanager/0001-Do-not-pass-null-string-to-s-printf-formatted-string.patch
new file mode 100644
index 000000000..5fbafbb5d
--- /dev/null
+++ b/meta-oe/recipes-connectivity/modemmanager/modemmanager/0001-Do-not-pass-null-string-to-s-printf-formatted-string.patch
@@ -0,0 +1,31 @@
1From b8862e6af1c6d022b8c182098e7deddb874ece19 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 18 Dec 2018 23:10:44 -0800
4Subject: [PATCH] Do not pass null string to %s printf formatted string
5
6Here the string is already decided to be NULL and passing
7a null pointer to %s will not work
8
9Fixes
10error: '%s' directive argument is null
11
12Upstream-Status: Submitted [https://gitlab.freedesktop.org/mobile-broadband/ModemManager/merge_requests/67]
13
14Signed-off-by: Khem Raj <raj.khem@gmail.com>
15---
16 plugins/mtk/mm-broadband-modem-mtk.c | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/plugins/mtk/mm-broadband-modem-mtk.c b/plugins/mtk/mm-broadband-modem-mtk.c
20index 475a63ac..541de4a5 100644
21--- a/plugins/mtk/mm-broadband-modem-mtk.c
22+++ b/plugins/mtk/mm-broadband-modem-mtk.c
23@@ -191,7 +191,7 @@ get_supported_modes_ready (MMBaseModem *self,
24
25 response = mm_base_modem_at_command_finish (MM_BASE_MODEM (self), res, &error);
26 if (!response) {
27- mm_dbg ("Fail to get response %s", response);
28+ mm_dbg ("Fail to get response");
29 g_task_return_error (task, error);
30 g_object_unref (task);
31 return;
diff --git a/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.8.2.bb b/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.8.2.bb
index e198bd588..f8e074a87 100644
--- a/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.8.2.bb
+++ b/meta-oe/recipes-connectivity/modemmanager/modemmanager_1.8.2.bb
@@ -13,6 +13,7 @@ DEPENDS = "glib-2.0 libgudev dbus-glib intltool-native"
13 13
14SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz \ 14SRC_URI = "http://www.freedesktop.org/software/ModemManager/ModemManager-${PV}.tar.xz \
15 file://0001-Do-not-set-Wno-unused-but-set-variable.patch \ 15 file://0001-Do-not-set-Wno-unused-but-set-variable.patch \
16 file://0001-Do-not-pass-null-string-to-s-printf-formatted-string.patch \
16 " 17 "
17 18
18SRC_URI[md5sum] = "a49c9f73e46c7b89e5efedda250d22c0" 19SRC_URI[md5sum] = "a49c9f73e46c7b89e5efedda250d22c0"