summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2022-01-14 09:39:08 +0800
committerKhem Raj <raj.khem@gmail.com>2022-01-18 09:01:51 -0800
commit5dd27b4a9f42c57bbba8b69ac179924dfaab0b76 (patch)
treefe89eb16730190af06419b87e9ea0afe15188f47 /meta-oe
parent57d127e81e5778ee8ab418a03f73ff277f3d1b9f (diff)
downloadmeta-openembedded-5dd27b4a9f42c57bbba8b69ac179924dfaab0b76.tar.gz
openldap: ignore the mkdir errors in Makefile
Ignore the mkdir errors to fix the parallel build failure: ../../build/shtool mkdir -p TOPDIR/tmp-glibc/work/cortexa15t2hf-neon-wrs-linux-gnueabi/openldap/2.5.9-r0/image/usr/lib mkdir: cannot create directory 'TOPDIR/tmp-glibc/work/cortexa15t2hf-neon-wrs-linux-gnueabi/openldap/2.5.9-r0/image/usr/lib': File exists make[1]: *** [Makefile:288: install-local] Error 1 Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/openldap/openldap/0001-libraries-Makefile.in-ignore-the-mkdir-errors.patch33
-rw-r--r--meta-oe/recipes-support/openldap/openldap_2.5.9.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/openldap/openldap/0001-libraries-Makefile.in-ignore-the-mkdir-errors.patch b/meta-oe/recipes-support/openldap/openldap/0001-libraries-Makefile.in-ignore-the-mkdir-errors.patch
new file mode 100644
index 000000000..552726bb0
--- /dev/null
+++ b/meta-oe/recipes-support/openldap/openldap/0001-libraries-Makefile.in-ignore-the-mkdir-errors.patch
@@ -0,0 +1,33 @@
1From 690f69791eb6cd0d7e94b4d73219ee864de27f62 Mon Sep 17 00:00:00 2001
2From: Yi Zhao <yi.zhao@windriver.com>
3Date: Mon, 10 Jan 2022 10:13:51 +0800
4Subject: [PATCH] libraries/Makefile.in: ignore the mkdir errors
5
6Ignore the mkdir errors to fix the parallel build failure:
7
8../../build/shtool mkdir -p TOPDIR/tmp-glibc/work/cortexa15t2hf-neon-wrs-linux-gnueabi/openldap/2.5.9-r0/image/usr/lib
9mkdir: cannot create directory 'TOPDIR/tmp-glibc/work/cortexa15t2hf-neon-wrs-linux-gnueabi/openldap/2.5.9-r0/image/usr/lib': File exists
10
11Upstream-Status: Pending
12
13Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
14---
15 libraries/Makefile.in | 2 +-
16 1 file changed, 1 insertion(+), 1 deletion(-)
17
18diff --git a/libraries/Makefile.in b/libraries/Makefile.in
19index d9cb2ff..c6b251f 100644
20--- a/libraries/Makefile.in
21+++ b/libraries/Makefile.in
22@@ -24,7 +24,7 @@ PKGCONFIG_DIR=$(DESTDIR)$(libdir)/pkgconfig
23 PKGCONFIG_SRCDIRS=liblber libldap
24
25 install-local:
26- @$(MKDIR) $(PKGCONFIG_DIR)
27+ @-$(MKDIR) $(PKGCONFIG_DIR)
28 @for i in $(PKGCONFIG_SRCDIRS); do \
29 $(INSTALL_DATA) $$i/*.pc $(PKGCONFIG_DIR); \
30 done
31--
322.17.1
33
diff --git a/meta-oe/recipes-support/openldap/openldap_2.5.9.bb b/meta-oe/recipes-support/openldap/openldap_2.5.9.bb
index c008c7b4b..f3b8c6c98 100644
--- a/meta-oe/recipes-support/openldap/openldap_2.5.9.bb
+++ b/meta-oe/recipes-support/openldap/openldap_2.5.9.bb
@@ -22,6 +22,7 @@ SRC_URI = "http://www.openldap.org/software/download/OpenLDAP/openldap-release/$
22 file://remove-user-host-pwd-from-version.patch \ 22 file://remove-user-host-pwd-from-version.patch \
23 file://0001-ldif-filter-fix-parallel-build-failure.patch \ 23 file://0001-ldif-filter-fix-parallel-build-failure.patch \
24 file://0001-build-top.mk-unset-STRIP_OPTS.patch \ 24 file://0001-build-top.mk-unset-STRIP_OPTS.patch \
25 file://0001-libraries-Makefile.in-ignore-the-mkdir-errors.patch \
25" 26"
26 27
27SRC_URI[md5sum] = "237fc2d881c27f8dd5d9f396e2865c11" 28SRC_URI[md5sum] = "237fc2d881c27f8dd5d9f396e2865c11"