summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAnkit Navik <ankit.tarot@gmail.com>2018-12-22 23:15:21 +0530
committerKhem Raj <raj.khem@gmail.com>2018-12-22 15:37:35 -0800
commit547ba317de0d4a22cf535f82fcc039687cd4385f (patch)
tree413c21a1639102a3fc016c77cebce118368401dc /meta-oe
parent47d5d28972bc564fec90f22a24e1b2bc24fa5ce6 (diff)
downloadmeta-openembedded-547ba317de0d4a22cf535f82fcc039687cd4385f.tar.gz
spirv-shader-generator: Initial recipe for SPIRV-Cross
Add generic recipe for SPIRV-Cross tool. SPIRV-Cross is a practical tool and library for performing reflection on SPIR-V and disassembling SPIR-V back to high level languages. Signed-off-by: Ankit Navik <ankit.tarot@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-graphics/spir/files/0001-Add-install-PHONY-target-in-Makefile.patch31
-rw-r--r--meta-oe/recipes-graphics/spir/spirv-shader-generator_git.bb22
2 files changed, 53 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/spir/files/0001-Add-install-PHONY-target-in-Makefile.patch b/meta-oe/recipes-graphics/spir/files/0001-Add-install-PHONY-target-in-Makefile.patch
new file mode 100644
index 000000000..78598ea1e
--- /dev/null
+++ b/meta-oe/recipes-graphics/spir/files/0001-Add-install-PHONY-target-in-Makefile.patch
@@ -0,0 +1,31 @@
1From 8d9870b66c3cfcf12ce7e8e013946e2a215bb722 Mon Sep 17 00:00:00 2001
2From: Ankit Navik <ankit.tarot@gmail.com>
3Date: Sat, 22 Dec 2018 19:16:02 +0530
4Subject: [PATCH] Add install PHONY target in Makefile
5
6---
7 Makefile | 8 +++++++-
8 1 file changed, 7 insertions(+), 1 deletion(-)
9
10diff --git a/Makefile b/Makefile
11index 0564b65..0993372 100644
12--- a/Makefile
13+++ b/Makefile
14@@ -35,7 +35,13 @@ $(STATIC_LIB): $(OBJECTS)
15 %.o: %.cpp
16 $(CXX) -c -o $@ $< $(CXXFLAGS) -MMD
17
18+install:
19+ mkdir -p $(TARGET_DIR_BIN)
20+ mkdir -p $(TARGET_DIR_LIB)
21+ cp $(TARGET) $(TARGET_DIR_BIN)/
22+ cp $(STATIC_LIB) $(TARGET_DIR_LIB)/
23+
24 clean:
25 rm -f $(TARGET) $(OBJECTS) $(CLI_OBJECTS) $(STATIC_LIB) $(DEPS)
26
27-.PHONY: clean
28+.PHONY: all install clean
29--
302.7.4
31
diff --git a/meta-oe/recipes-graphics/spir/spirv-shader-generator_git.bb b/meta-oe/recipes-graphics/spir/spirv-shader-generator_git.bb
new file mode 100644
index 000000000..b787972da
--- /dev/null
+++ b/meta-oe/recipes-graphics/spir/spirv-shader-generator_git.bb
@@ -0,0 +1,22 @@
1SUMMARY = "SPIRV-Cross is a tool designed for parsing and converting SPIR-V \
2to other shader languages"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5SECTION = "graphics"
6
7S = "${WORKDIR}/git"
8SRCREV = "ed16b3e69985feaf565efbecea70a1cc2fca2a58"
9SRC_URI = "git://github.com/KhronosGroup/SPIRV-Cross.git \
10 file://0001-Add-install-PHONY-target-in-Makefile.patch \
11"
12
13EXTRA_OEMAKE += 'TARGET_DIR_LIB="${D}${libdir}"'
14EXTRA_OEMAKE += 'TARGET_DIR_BIN="${D}${bindir}"'
15
16do_compile () {
17 cd ${S} && oe_runmake
18}
19
20do_install () {
21 cd ${S} && oe_runmake install
22}