summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2020-01-27 17:36:06 +0000
committerKhem Raj <raj.khem@gmail.com>2020-01-27 13:10:31 -0800
commit4933ca545736903972cf609abc678f838b56f325 (patch)
tree5db290932f0821185ba26e8a98613d902cbb1e4d /meta-oe
parent70a5edc4b52e9a615e86284ee60f992e20da1017 (diff)
downloadmeta-openembedded-4933ca545736903972cf609abc678f838b56f325.tar.gz
pcsc-lite: update recipe to use python3
Update pcsc-lite recipe to target python3 since python2 is EOL and has been dropped from OE-Core. Signed-off-by: Laurent Bonnans <laurent.bonnans@here.com> Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/pcsc-lite/pcsc-lite/0001-pcsc-spy-use-python3-only.patch43
-rw-r--r--meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.26.bb7
2 files changed, 48 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/pcsc-lite/pcsc-lite/0001-pcsc-spy-use-python3-only.patch b/meta-oe/recipes-support/pcsc-lite/pcsc-lite/0001-pcsc-spy-use-python3-only.patch
new file mode 100644
index 0000000000..3e7b0adda6
--- /dev/null
+++ b/meta-oe/recipes-support/pcsc-lite/pcsc-lite/0001-pcsc-spy-use-python3-only.patch
@@ -0,0 +1,43 @@
1From 75dd98876951d86890ceb30be521de57fd31e3c7 Mon Sep 17 00:00:00 2001
2From: Andrey Zhizhikin <andrey.z@gmail.com>
3Date: Mon, 27 Jan 2020 13:27:12 +0000
4Subject: [PATCH] pcsc-spy: use python3 only
5
6Python2 has been EOL and most distributions would not provide any
7support for it anymore. Since Python3 is available in all distributions
8now, switch pcsc-spy to use it exclusively.
9
10Upstream-Status: Pending
11
12Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
13---
14 src/spy/pcsc-spy | 9 ++-------
15 1 file changed, 2 insertions(+), 7 deletions(-)
16
17diff --git a/src/spy/pcsc-spy b/src/spy/pcsc-spy
18index 85222c6..965138e 100755
19--- a/src/spy/pcsc-spy
20+++ b/src/spy/pcsc-spy
21@@ -1,4 +1,4 @@
22-#! /usr/bin/python
23+#!/usr/bin/env python3
24
25 """
26 # Display PC/SC functions arguments
27@@ -22,12 +22,7 @@ from __future__ import print_function
28 import os
29 import signal
30 import time
31-try:
32- # for Python3
33- from queue import Queue
34-except ImportError:
35- # for Python2
36- from Queue import Queue
37+from queue import Queue
38 from threading import Thread
39 from operator import attrgetter
40
41--
422.17.1
43
diff --git a/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.26.bb b/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.26.bb
index 5e60846561..fb8c4a202f 100644
--- a/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.26.bb
+++ b/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.26.bb
@@ -10,7 +10,10 @@ LICENSE_${PN}-spy = "GPLv3+"
10LICENSE_${PN}-spy-dev = "GPLv3+" 10LICENSE_${PN}-spy-dev = "GPLv3+"
11LIC_FILES_CHKSUM = "file://COPYING;md5=628c01ba985ecfa21677f5ee2d5202f6" 11LIC_FILES_CHKSUM = "file://COPYING;md5=628c01ba985ecfa21677f5ee2d5202f6"
12 12
13SRC_URI = "https://pcsclite.apdu.fr/files/${BP}.tar.bz2" 13SRC_URI = "\
14 https://pcsclite.apdu.fr/files/${BP}.tar.bz2 \
15 file://0001-pcsc-spy-use-python3-only.patch \
16"
14SRC_URI[md5sum] = "9d36882998449daceec267c68a21ff0d" 17SRC_URI[md5sum] = "9d36882998449daceec267c68a21ff0d"
15SRC_URI[sha256sum] = "3eb7be7d6ef618c0a444316cf5c1f2f9d7227aedba7a192f389fe3e7c0dfbbd9" 18SRC_URI[sha256sum] = "3eb7be7d6ef618c0a444316cf5c1f2f9d7227aedba7a192f389fe3e7c0dfbbd9"
16 19
@@ -50,6 +53,6 @@ RPROVIDES_${PN} += "${PN}-systemd"
50RREPLACES_${PN} += "${PN}-systemd" 53RREPLACES_${PN} += "${PN}-systemd"
51RCONFLICTS_${PN} += "${PN}-systemd" 54RCONFLICTS_${PN} += "${PN}-systemd"
52SYSTEMD_SERVICE_${PN} = "pcscd.socket" 55SYSTEMD_SERVICE_${PN} = "pcscd.socket"
53RDEPENDS_${PN}-spy +="python" 56RDEPENDS_${PN}-spy +="python3"
54 57
55BBCLASSEXTEND = "native" 58BBCLASSEXTEND = "native"