summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorPotin Lai <potin.lai@quantatw.com>2022-04-06 16:24:56 +0800
committerKhem Raj <raj.khem@gmail.com>2022-04-06 20:40:42 -0400
commit41b44264e36cb4d7c63176b8f695e3c7515e6fae (patch)
treef3d1bd281cd42260ac919028f6a3bc51da236737 /meta-oe
parent6e6f6fd6523b40e74455ffec21c3b3938a27355a (diff)
downloadmeta-openembedded-41b44264e36cb4d7c63176b8f695e3c7515e6fae.tar.gz
libimobiledevice-glue: update recipe
remove patch 0001-fix-undefined-bswap32-and-bswap64-errors-for-MIPS-ma.patch Upstream Status: Accepted [https://github.com/libimobiledevice/libimobiledevice-glue/commit/17a2b964ca9c94f6615994ba2179bf4228e31236] subtree update: ecb0996fd2..bc6c44b920 Nikias Bassen (4): [github-actions] Use windows-2019 instead of windows-latest for now socket: Add socket_get_socket_port function utils: Close file if buffer allocation fails in buffer_read_from_filename() Updated README with pkg-config requirement Potin Lai (1): Fix undefined bswap32 and bswap64 for MIPS machine Signed-off-by: Potin Lai <potin.lai@quantatw.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-connectivity/libimobiledevice-glue/files/0001-fix-undefined-bswap32-and-bswap64-errors-for-MIPS-ma.patch32
-rw-r--r--meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb7
2 files changed, 2 insertions, 37 deletions
diff --git a/meta-oe/recipes-connectivity/libimobiledevice-glue/files/0001-fix-undefined-bswap32-and-bswap64-errors-for-MIPS-ma.patch b/meta-oe/recipes-connectivity/libimobiledevice-glue/files/0001-fix-undefined-bswap32-and-bswap64-errors-for-MIPS-ma.patch
deleted file mode 100644
index cff37fb5d..000000000
--- a/meta-oe/recipes-connectivity/libimobiledevice-glue/files/0001-fix-undefined-bswap32-and-bswap64-errors-for-MIPS-ma.patch
+++ /dev/null
@@ -1,32 +0,0 @@
1From 73fcf0b54f4c1fc07a2aa003dddaeb5a97177cce Mon Sep 17 00:00:00 2001
2From: Potin Lai <potin.lai@quantatw.com>
3Date: Thu, 31 Mar 2022 08:44:31 +0800
4Subject: [PATCH 1/1] fix undefined bswap32 and bswap64 errors for MIPS machine
5
6Replace bswap32 and bswap64 with internal defined version (__bswap_X)
7
8Upstream Status: Submitted [libimobiledevice-devel@libimobiledevice.org]
9
10Signed-off-by: Potin Lai <potin.lai@quantatw.com>
11---
12 include/endianness.h | 4 ++--
13 1 file changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/include/endianness.h b/include/endianness.h
16index 099877a..88b63db 100644
17--- a/include/endianness.h
18+++ b/include/endianness.h
19@@ -113,8 +113,8 @@
20 && !defined(__FLOAT_WORD_ORDER__)) \
21 || (defined(__FLOAT_WORD_ORDER__) \
22 && __FLOAT_WORD_ORDER__ == __ORDER_BIG_ENDIAN__)
23-#define float_bswap64(x) bswap64(x)
24-#define float_bswap32(x) bswap32(x)
25+#define float_bswap64(x) __bswap_64(x)
26+#define float_bswap32(x) __bswap_32(x)
27 #else
28 #define float_bswap64(x) (x)
29 #define float_bswap32(x) (x)
30--
312.17.1
32
diff --git a/meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb b/meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb
index d5d90ea13..6d872b9f8 100644
--- a/meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb
+++ b/meta-oe/recipes-connectivity/libimobiledevice-glue/libimobiledevice-glue_git.bb
@@ -10,11 +10,8 @@ DEPENDS = "libplist"
10 10
11PV = "1.0.0+git${SRCPV}" 11PV = "1.0.0+git${SRCPV}"
12 12
13SRCREV = "ecb0996fd2a3b0539153dd3ef901d137bf498ffe" 13SRCREV = "bc6c44b92091c9587a9bed0ed3f2c3248bfd13b3"
14SRC_URI = "\ 14SRC_URI = "git://github.com/libimobiledevice/libimobiledevice-glue;protocol=https;branch=master"
15 git://github.com/libimobiledevice/libimobiledevice-glue;protocol=https;branch=master \
16 file://0001-fix-undefined-bswap32-and-bswap64-errors-for-MIPS-ma.patch \
17"
18 15
19S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
20inherit autotools pkgconfig 17inherit autotools pkgconfig