diff options
author | Khem Raj <raj.khem@gmail.com> | 2024-08-24 14:41:14 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-08-24 15:46:31 -0700 |
commit | 2f57fc64f4417a0d839ba2692477cdc79fd7f278 (patch) | |
tree | 4c623a99b48389b8c17f1cdb03f764837a1b17a4 /meta-oe | |
parent | 8648720c00e00495afa770e36bb64ae21b09015a (diff) | |
download | meta-openembedded-2f57fc64f4417a0d839ba2692477cdc79fd7f278.tar.gz |
raptor2: Do not use curl-config to detect curl
it fails in cross build environment, use pkg-config instead
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-support/raptor2/raptor2/raptor-2.0.16-dont_use_curl-config.patch | 73 | ||||
-rw-r--r-- | meta-oe/recipes-support/raptor2/raptor2_2.0.16.bb | 6 |
2 files changed, 76 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/raptor2/raptor2/raptor-2.0.16-dont_use_curl-config.patch b/meta-oe/recipes-support/raptor2/raptor2/raptor-2.0.16-dont_use_curl-config.patch new file mode 100644 index 0000000000..b12beff6cb --- /dev/null +++ b/meta-oe/recipes-support/raptor2/raptor2/raptor-2.0.16-dont_use_curl-config.patch | |||
@@ -0,0 +1,73 @@ | |||
1 | Do not use curl-config | ||
2 | |||
3 | Sourced from | ||
4 | https://bugs.gentoo.org/552474 | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- a/configure.ac | ||
9 | +++ b/configure.ac | ||
10 | @@ -596,49 +596,12 @@ else | ||
11 | PKG_CHECK_MODULES([XSLT], [libxslt > $libxslt_min_version], [have_libxslt=1], [have_libxslt=0]) | ||
12 | fi | ||
13 | |||
14 | -dnl curl | ||
15 | -AC_ARG_WITH(curl-config, [ --with-curl-config=PATH Location of libcurl curl-config []], curl_config="$withval", curl_config="") | ||
16 | - | ||
17 | -if test "X$curl_config" != "Xno" ; then | ||
18 | - if test "X$curl_config" != "X" ; then | ||
19 | - AC_MSG_CHECKING(for $curl_config) | ||
20 | - | ||
21 | - if test -f $curl_config ; then | ||
22 | - CURL_CONFIG=$curl_config | ||
23 | - AC_MSG_RESULT(yes) | ||
24 | - else | ||
25 | - AC_MSG_RESULT(no - searching PATH) | ||
26 | - fi | ||
27 | - fi | ||
28 | - if test "X$CURL_CONFIG" = "X" ; then | ||
29 | - AC_CHECK_PROGS(CURL_CONFIG, curl-config) | ||
30 | - fi | ||
31 | -fi | ||
32 | - | ||
33 | libcurl_source=no | ||
34 | -if test "X$CURL_CONFIG" != "X"; then | ||
35 | - LIBCURL_CFLAGS=`$CURL_CONFIG --cflags` | ||
36 | - LIBCURL_LIBS=`$CURL_CONFIG --libs` | ||
37 | - | ||
38 | - CPPFLAGS="$LIBCURL_CFLAGS $CPPFLAGS" | ||
39 | - LIBS="$LIBS $LIBCURL_LIBS" | ||
40 | - AC_CHECK_HEADER(curl/curl.h) | ||
41 | - AC_CHECK_FUNC(curl_easy_init, have_curl_easy_init=yes, have_curl_easy_init=no) | ||
42 | - | ||
43 | - AC_MSG_CHECKING(for libcurl via curl-config) | ||
44 | - if test $have_curl_easy_init = yes; then | ||
45 | - libcurl_source="curl-config" | ||
46 | - LIBCURL_VERSION=`$CURL_CONFIG --version | sed -e 's/^libcurl *//'` | ||
47 | - fi | ||
48 | - CPPFLAGS="$oCPPFLAGS" | ||
49 | - LIBS="$oLIBS" | ||
50 | -else | ||
51 | - PKG_CHECK_MODULES([LIBCURL],[libcurl],[ | ||
52 | - LIBCURL_VERSION=`$PKG_CONFIG libcurl --modversion` | ||
53 | - libcurl_source="pkg-config" | ||
54 | - ], [:]) | ||
55 | - AC_MSG_CHECKING(for libcurl via pkg-config) | ||
56 | -fi | ||
57 | +PKG_CHECK_MODULES([LIBCURL],[libcurl],[ | ||
58 | + LIBCURL_VERSION=`$PKG_CONFIG libcurl --modversion` | ||
59 | + libcurl_source="pkg-config" | ||
60 | +], [:]) | ||
61 | +AC_MSG_CHECKING(for libcurl via pkg-config) | ||
62 | |||
63 | if test "$libcurl_source" = "no"; then | ||
64 | AC_MSG_RESULT(no - not found) | ||
65 | @@ -1033,7 +996,7 @@ need_libcurl=0 | ||
66 | need_libxml_www=0 | ||
67 | need_libfetch=0 | ||
68 | |||
69 | -if test "X$CURL_CONFIG" != X; then | ||
70 | +if test "$libcurl_source" != "no"; then | ||
71 | CPPFLAGS="$CPPFLAGS $LIBCURL_CFLAGS" | ||
72 | LIBS="$LIBS $LIBCURL_LIBS" | ||
73 | AC_CHECK_HEADER(curl/curl.h) | ||
diff --git a/meta-oe/recipes-support/raptor2/raptor2_2.0.16.bb b/meta-oe/recipes-support/raptor2/raptor2_2.0.16.bb index 85012bcfb3..7014a28c02 100644 --- a/meta-oe/recipes-support/raptor2/raptor2_2.0.16.bb +++ b/meta-oe/recipes-support/raptor2/raptor2_2.0.16.bb | |||
@@ -7,18 +7,18 @@ LIC_FILES_CHKSUM = " \ | |||
7 | file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57 \ | 7 | file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57 \ |
8 | " | 8 | " |
9 | 9 | ||
10 | DEPENDS = "libxml2 libxslt curl yajl" | 10 | DEPENDS = "bison-native flex-native libxml2 libxslt curl yajl" |
11 | 11 | ||
12 | SRC_URI = " \ | 12 | SRC_URI = " \ |
13 | http://download.librdf.org/source/${BPN}-${PV}.tar.gz \ | 13 | http://download.librdf.org/source/${BPN}-${PV}.tar.gz \ |
14 | file://0001-Remove-the-access-to-entities-checked-private-symbol.patch \ | 14 | file://0001-Remove-the-access-to-entities-checked-private-symbol.patch \ |
15 | file://raptor-2.0.16-dont_use_curl-config.patch \ | ||
15 | " | 16 | " |
16 | SRC_URI[sha256sum] = "089db78d7ac982354bdbf39d973baf09581e6904ac4c92a98c5caadb3de44680" | 17 | SRC_URI[sha256sum] = "089db78d7ac982354bdbf39d973baf09581e6904ac4c92a98c5caadb3de44680" |
17 | 18 | ||
18 | inherit autotools pkgconfig gtk-doc | 19 | inherit autotools pkgconfig gtk-doc perlnative |
19 | 20 | ||
20 | EXTRA_OECONF = " \ | 21 | EXTRA_OECONF = " \ |
21 | --without-xml2-config \ | 22 | --without-xml2-config \ |
22 | --without-curl-config \ | ||
23 | --without-xslt-config \ | 23 | --without-xslt-config \ |
24 | " | 24 | " |