summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorniko.mauno@vaisala.com <niko.mauno@vaisala.com>2018-04-11 12:44:48 +0300
committerArmin Kuster <akuster808@gmail.com>2018-05-01 18:11:13 -0700
commit2b974db822b586715a6f9d7592706f49c0e87e10 (patch)
tree1b51f9fb3a1337b8a137f8f1761bd1a66193aba4 /meta-oe
parentddda5e7b68a7df73e28099dafeaf77f29e0575d3 (diff)
downloadmeta-openembedded-2b974db822b586715a6f9d7592706f49c0e87e10.tar.gz
tslib: Align recipe content to better match v1.15
Respective changes to recipe: - updated AUTHOR field to match current author in tslib/AUTHORS file - updated LICENSE field to 'LGPLv2+ & GPLv2+' to reflect licenses in v1.15 (LGPLv2+ for shared library parts, GPLv2+ for command line utility parts) - updated LIC_FILES_CHECKSUM to contain COPYING files for both license families - Replaced EXTRA_OECONF with PACKAGECONFIG that is aligned to current configure defaults, with exception that "Tatung Webpad support" was disabled (as it was enabled by default for some reason despite being seemingly specific to a single manufacturer/product). - removed commented-out detect-stylus lines (a detect-stylus recipe was apparently available in OE-Classic) Signed-off-by: Niko Mauno <niko.mauno@vaisala.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-graphics/tslib/tslib_1.15.bb40
1 files changed, 33 insertions, 7 deletions
diff --git a/meta-oe/recipes-graphics/tslib/tslib_1.15.bb b/meta-oe/recipes-graphics/tslib/tslib_1.15.bb
index e87b411a8..7ae941a3c 100644
--- a/meta-oe/recipes-graphics/tslib/tslib_1.15.bb
+++ b/meta-oe/recipes-graphics/tslib/tslib_1.15.bb
@@ -5,10 +5,13 @@ Tslib is generally used on embedded devices to provide a common user \
5space interface to touchscreen functionality." 5space interface to touchscreen functionality."
6HOMEPAGE = "http://tslib.org/" 6HOMEPAGE = "http://tslib.org/"
7 7
8AUTHOR = "Russell King w/ plugins by Chris Larson et. al." 8AUTHOR = "Martin Kepplinger <martink@posteo.de>"
9SECTION = "base" 9SECTION = "base"
10LICENSE = "LGPLv2" 10LICENSE = "LGPLv2+ & GPLv2+"
11LIC_FILES_CHKSUM = "file://COPYING;md5=fc178bcd425090939a8b634d1d6a9594" 11LIC_FILES_CHKSUM = "\
12 file://COPYING;md5=fc178bcd425090939a8b634d1d6a9594 \
13 file://tests/COPYING;md5=a23a74b3f4caf9616230789d94217acb \
14"
12 15
13SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \ 16SRC_URI = "https://github.com/kergoth/tslib/releases/download/${PV}/tslib-${PV}.tar.xz;downloadfilename=tslib-${PV}.tar.xz \
14 file://ts.conf \ 17 file://ts.conf \
@@ -21,7 +24,33 @@ UPSTREAM_CHECK_URI = "https://github.com/kergoth/tslib/releases"
21 24
22inherit autotools pkgconfig 25inherit autotools pkgconfig
23 26
24EXTRA_OECONF = "--enable-shared --disable-h3600 --enable-input --disable-corgi --disable-collie --disable-mk712 --disable-arctic2 --disable-ucb1x00" 27PACKAGECONFIG ??= "debounce dejitter iir linear median pthres skip lowpass invert variance input touchkit waveshare"
28PACKAGECONFIG[debounce] = "--enable-debounce,--disable-debounce"
29PACKAGECONFIG[dejitter] = "--enable-dejitter,--disable-dejitter"
30PACKAGECONFIG[iir] = "--enable-iir,--disable-iir"
31PACKAGECONFIG[linear] = "--enable-linear,--disable-linear"
32PACKAGECONFIG[median] = "--enable-median,--disable-median"
33PACKAGECONFIG[pthres] = "--enable-pthres,--disable-pthres"
34PACKAGECONFIG[skip] = "--enable-skip,--disable-skip"
35PACKAGECONFIG[lowpass] = "--enable-lowpass,--disable-lowpass"
36PACKAGECONFIG[invert] = "--enable-invert,--disable-invert"
37PACKAGECONFIG[variance] = "--enable-variance,--disable-variance"
38PACKAGECONFIG[input] = "--enable-input,--disable-input"
39PACKAGECONFIG[tatung] = "--enable-tatung,--disable-tatung"
40PACKAGECONFIG[touchkit] = "--enable-touchkit,--disable-touchkit"
41PACKAGECONFIG[waveshare] = "--enable-waveshare,--disable-waveshare"
42PACKAGECONFIG[ucb1x00] = "--enable-ucb1x00,--disable-ucb1x00"
43PACKAGECONFIG[mk712] = "--enable-mk712,--disable-mk712"
44PACKAGECONFIG[h3600] = "--enable-h3600,--disable-h3600"
45PACKAGECONFIG[dmc] = "--enable-dmc,--disable-dmc"
46PACKAGECONFIG[linear-h2200] = "--enable-linear-h2200,--disable-linear-h2200"
47PACKAGECONFIG[corgi] = "--enable-corgi,--disable-corgi"
48PACKAGECONFIG[collie] = "--enable-collie,--disable-collie"
49PACKAGECONFIG[arctic2] = "--enable-arctic2,--disable-arctic2"
50PACKAGECONFIG[dmc_dus3000] = "--enable-dmc_dus3000,--disable-dmc_dus3000"
51PACKAGECONFIG[cy8mrln-palmpre] = "--enable-cy8mrln-palmpre,--disable-cy8mrln-palmpre"
52PACKAGECONFIG[galax] = "--enable-galax,--disable-galax"
53PACKAGECONFIG[debug] = "--enable-debug,--disable-debug"
25 54
26do_install_prepend() { 55do_install_prepend() {
27 install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf 56 install -m 0644 ${WORKDIR}/ts.conf ${S}/etc/ts.conf
@@ -32,9 +61,6 @@ do_install_append() {
32 install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/ 61 install -m 0755 ${WORKDIR}/tslib.sh ${D}${sysconfdir}/profile.d/
33} 62}
34 63
35# People should consider using udev's /dev/input/touchscreen0 symlink
36# instead of detect-stylus
37#RDEPENDS_tslib-conf_weird-machine = "detect-stylus"
38RPROVIDES_tslib-conf = "libts-0.0-conf" 64RPROVIDES_tslib-conf = "libts-0.0-conf"
39 65
40PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate tslib-uinput" 66PACKAGES =+ "tslib-conf tslib-tests tslib-calibrate tslib-uinput"