summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-05 20:14:46 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-08 13:32:12 -0700
commit226e889f6b9b6367d80861968a30b36a1a9c99d9 (patch)
treeec72de75ce5bfd7fd74d31675d2ad690e3d83e5d /meta-oe
parentf42e527c92b5703d18ac4c44db0e05ed036ec91a (diff)
downloadmeta-openembedded-226e889f6b9b6367d80861968a30b36a1a9c99d9.tar.gz
poco: Fix cross compilation
Backport a pull request to fix build error seen during cross compiling Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/poco/poco/0001-Don-t-try-to-install-non-existing-Encodings-testsuit.patch31
-rw-r--r--meta-oe/recipes-support/poco/poco_1.9.0.bb5
2 files changed, 34 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/poco/poco/0001-Don-t-try-to-install-non-existing-Encodings-testsuit.patch b/meta-oe/recipes-support/poco/poco/0001-Don-t-try-to-install-non-existing-Encodings-testsuit.patch
new file mode 100644
index 000000000..f4a358f47
--- /dev/null
+++ b/meta-oe/recipes-support/poco/poco/0001-Don-t-try-to-install-non-existing-Encodings-testsuit.patch
@@ -0,0 +1,31 @@
1From fa079dfc5e1d22ea35762bf4c5b09999bdc5e731 Mon Sep 17 00:00:00 2001
2From: Jochen Sprickerhof <git@jochen.sprickerhof.de>
3Date: Wed, 22 Aug 2018 21:42:09 +0200
4Subject: [PATCH] Don't try to install non existing Encodings/testsuite/data
5
6Upstream-Status: Backport [https://github.com/pocoproject/poco/pull/2437]
7---
8 Encodings/testsuite/CMakeLists.txt | 5 +----
9 1 file changed, 1 insertion(+), 4 deletions(-)
10
11diff --git a/Encodings/testsuite/CMakeLists.txt b/Encodings/testsuite/CMakeLists.txt
12index 7508e5522..79495ae02 100644
13--- a/Encodings/testsuite/CMakeLists.txt
14+++ b/Encodings/testsuite/CMakeLists.txt
15@@ -19,12 +19,9 @@ POCO_SOURCES_AUTO_PLAT( TEST_SRCS WINCE
16 add_executable( ${TESTUNIT} ${TEST_SRCS} )
17 if(ANDROID)
18 add_test(NAME ${LIBNAME} WORKING_DIRECTORY ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}
19- COMMAND ${CMAKE_COMMAND} -DANDROID_NDK=${ANDROID_NDK} "-DTEST_FILES=${CMAKE_CURRENT_SOURCE_DIR}/data;" -DLIBRARY_DIR=${CMAKE_BINARY_DIR}/lib -DUNITTEST=${CMAKE_BINARY_DIR}/bin/${TESTUNIT} -DTEST_PARAMETER=-all -P ${CMAKE_SOURCE_DIR}/cmake/ExecuteOnAndroid.cmake)
20+ COMMAND ${CMAKE_COMMAND} -DANDROID_NDK=${ANDROID_NDK} -DLIBRARY_DIR=${CMAKE_BINARY_DIR}/lib -DUNITTEST=${CMAKE_BINARY_DIR}/bin/Encodings-testrunner -DTEST_PARAMETER=-all -P ${CMAKE_SOURCE_DIR}/cmake/ExecuteOnAndroid.cmake)
21 else()
22 add_test(NAME ${LIBNAME} WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR} COMMAND ${TESTUNIT} -all)
23- # The test is run in the build directory. So the test data is copied there too
24- add_custom_command(TARGET ${TESTUNIT} POST_BUILD
25- COMMAND ${CMAKE_COMMAND} -E copy_directory ${CMAKE_CURRENT_SOURCE_DIR}/data ${CMAKE_CURRENT_BINARY_DIR}/data )
26 endif()
27 #set_target_properties( ${TESTUNIT} PROPERTIES COMPILE_FLAGS ${RELEASE_CXX_FLAGS} )
28 target_link_libraries( ${TESTUNIT} PocoEncodings PocoFoundation CppUnit )
29--
302.18.0
31
diff --git a/meta-oe/recipes-support/poco/poco_1.9.0.bb b/meta-oe/recipes-support/poco/poco_1.9.0.bb
index a4f8a0518..258cc4994 100644
--- a/meta-oe/recipes-support/poco/poco_1.9.0.bb
+++ b/meta-oe/recipes-support/poco/poco_1.9.0.bb
@@ -9,10 +9,11 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=4267f48fc738f50380cbeeb76f95cebc"
9DEPENDS = "libpcre zlib" 9DEPENDS = "libpcre zlib"
10 10
11SRC_URI = " \ 11SRC_URI = " \
12 git://github.com/pocoproject/poco.git \ 12 git://github.com/pocoproject/poco.git;branch=poco-${PV} \
13 file://0001-Don-t-try-to-install-non-existing-Encodings-testsuit.patch \
13 file://run-ptest \ 14 file://run-ptest \
14 " 15 "
15SRCREV = "94966785a8f9ad0191dffd075ebd67826e6e4b6d" 16SRCREV = "daf00da73ab917e4d4581e3aa00c0ee61e0cc58b"
16 17
17S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
18 19