diff options
author | Alistair Francis <alistair.francis@wdc.com> | 2019-11-06 16:49:59 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-11-06 19:58:01 -0800 |
commit | 1115eb44bc47f3ec6e58bda554908b69f2a20de1 (patch) | |
tree | ce127afab60f839f824ca377e4a9bcfc04f541e5 /meta-oe | |
parent | b5eac5d26b8a9b36fd57d8fc6f700efe6f54d4ff (diff) | |
download | meta-openembedded-1115eb44bc47f3ec6e58bda554908b69f2a20de1.tar.gz |
openocd: Update to latest git version
Update to the latest git version and allow native builds.
The 0001-esirisc_flash-Rename-PAGE_SIZE-to-FLASH_PAGE_SIZE.patch has
been merged into master, so we can remove it.
Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r-- | meta-oe/recipes-devtools/openocd/openocd/0001-esirisc_flash-Rename-PAGE_SIZE-to-FLASH_PAGE_SIZE.patch | 59 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/openocd/openocd_git.bb | 9 |
2 files changed, 4 insertions, 64 deletions
diff --git a/meta-oe/recipes-devtools/openocd/openocd/0001-esirisc_flash-Rename-PAGE_SIZE-to-FLASH_PAGE_SIZE.patch b/meta-oe/recipes-devtools/openocd/openocd/0001-esirisc_flash-Rename-PAGE_SIZE-to-FLASH_PAGE_SIZE.patch deleted file mode 100644 index c80d9f19f8..0000000000 --- a/meta-oe/recipes-devtools/openocd/openocd/0001-esirisc_flash-Rename-PAGE_SIZE-to-FLASH_PAGE_SIZE.patch +++ /dev/null | |||
@@ -1,59 +0,0 @@ | |||
1 | From bee22f143ffa0457aefcf31053f76416e6d242e5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 20 May 2019 23:24:26 -0700 | ||
4 | Subject: [PATCH] esirisc_flash: Rename PAGE_SIZE to FLASH_PAGE_SIZE | ||
5 | |||
6 | PAGE_SIZE is defined in system includes on some systems, this would | ||
7 | avoid the unintended conflict | ||
8 | |||
9 | Fixes | ||
10 | | src/flash/nor/esirisc_flash.c:95:9: error: 'PAGE_SIZE' macro redefined [-Werror,-Wmacro-redefined] | ||
11 | | #define PAGE_SIZE 4096 | ||
12 | | ^ | ||
13 | | /mnt/a/yoe/build/tmp/work/core2-64-yoe-linux-musl/openocd/0.10+gitrAUTOINC+7ee618692f-r0/recipe-sysroot/usr/inclu | ||
14 | de/limits.h:89:9: note: previous definition is here | ||
15 | | #define PAGE_SIZE PAGESIZE | ||
16 | |||
17 | Upstream-Status: Submitted [http://openocd.zylin.com/#/c/5180/2] | ||
18 | Change-Id: I195b303fc88a7c848ca4e55fd6ba893796df55cc | ||
19 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
20 | --- | ||
21 | src/flash/nor/esirisc_flash.c | 8 ++++---- | ||
22 | 1 file changed, 4 insertions(+), 4 deletions(-) | ||
23 | |||
24 | diff --git a/src/flash/nor/esirisc_flash.c b/src/flash/nor/esirisc_flash.c | ||
25 | index 4e33b942..3bed0658 100644 | ||
26 | --- a/src/flash/nor/esirisc_flash.c | ||
27 | +++ b/src/flash/nor/esirisc_flash.c | ||
28 | @@ -92,7 +92,7 @@ | ||
29 | #endif | ||
30 | |||
31 | #define CONTROL_TIMEOUT 5000 /* 5s */ | ||
32 | -#define PAGE_SIZE 4096 | ||
33 | +#define FLASH_PAGE_SIZE 4096 | ||
34 | #define PB_MAX 32 | ||
35 | |||
36 | #define NUM_NS_PER_S 1000000000ULL | ||
37 | @@ -264,7 +264,7 @@ static int esirisc_flash_erase(struct flash_bank *bank, int first, int last) | ||
38 | (void)esirisc_flash_disable_protect(bank); | ||
39 | |||
40 | for (int page = first; page < last; ++page) { | ||
41 | - uint32_t address = page * PAGE_SIZE; | ||
42 | + uint32_t address = page * FLASH_PAGE_SIZE; | ||
43 | |||
44 | target_write_u32(target, esirisc_info->cfg + ADDRESS, address); | ||
45 | |||
46 | @@ -464,8 +464,8 @@ static int esirisc_flash_probe(struct flash_bank *bank) | ||
47 | if (target->state != TARGET_HALTED) | ||
48 | return ERROR_TARGET_NOT_HALTED; | ||
49 | |||
50 | - bank->num_sectors = bank->size / PAGE_SIZE; | ||
51 | - bank->sectors = alloc_block_array(0, PAGE_SIZE, bank->num_sectors); | ||
52 | + bank->num_sectors = bank->size / FLASH_PAGE_SIZE; | ||
53 | + bank->sectors = alloc_block_array(0, FLASH_PAGE_SIZE, bank->num_sectors); | ||
54 | |||
55 | retval = esirisc_flash_init(bank); | ||
56 | if (retval != ERROR_OK) { | ||
57 | -- | ||
58 | 2.21.0 | ||
59 | |||
diff --git a/meta-oe/recipes-devtools/openocd/openocd_git.bb b/meta-oe/recipes-devtools/openocd/openocd_git.bb index 241b4baa33..9ec77fdc4d 100644 --- a/meta-oe/recipes-devtools/openocd/openocd_git.bb +++ b/meta-oe/recipes-devtools/openocd/openocd_git.bb | |||
@@ -9,22 +9,21 @@ SRC_URI = " \ | |||
9 | git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl \ | 9 | git://repo.or.cz/r/git2cl.git;protocol=http;destsuffix=tools/git2cl;name=git2cl \ |
10 | git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl \ | 10 | git://repo.or.cz/r/jimtcl.git;protocol=http;destsuffix=git/jimtcl;name=jimtcl \ |
11 | git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \ | 11 | git://repo.or.cz/r/libjaylink.git;protocol=http;destsuffix=git/src/jtag/drivers/libjaylink;name=libjaylink \ |
12 | file://0001-esirisc_flash-Rename-PAGE_SIZE-to-FLASH_PAGE_SIZE.patch \ | ||
13 | file://0001-Do-not-include-syscrtl.h-with-glibc.patch \ | 12 | file://0001-Do-not-include-syscrtl.h-with-glibc.patch \ |
14 | " | 13 | " |
15 | 14 | ||
16 | SRCREV_FORMAT = "openocd" | 15 | SRCREV_FORMAT = "openocd" |
17 | SRCREV_openocd = "7ee618692f56b0efea864890da45d73d28e393d9" | 16 | SRCREV_openocd = "ded67990255cc1e63c77832ffd6e6bef9120873d" |
18 | SRCREV_git2cl = "8373c9f74993e218a08819cbcdbab3f3564bbeba" | 17 | SRCREV_git2cl = "8373c9f74993e218a08819cbcdbab3f3564bbeba" |
19 | SRCREV_jimtcl = "a9bf5975fd0f89974d689a2d9ebd0873c8d64787" | 18 | SRCREV_jimtcl = "dc4ba7770d580800634f90b67a24e077b4a26d98" |
20 | SRCREV_libjaylink = "8645845c1abebd004e991ba9a7f808f4fd0c608b" | 19 | SRCREV_libjaylink = "cfccbc9d6763733f1d14dff3c2dc5b75aaef136b" |
21 | 20 | ||
22 | PV = "0.10+gitr${SRCPV}" | 21 | PV = "0.10+gitr${SRCPV}" |
23 | S = "${WORKDIR}/git" | 22 | S = "${WORKDIR}/git" |
24 | 23 | ||
25 | inherit pkgconfig autotools-brokensep gettext | 24 | inherit pkgconfig autotools-brokensep gettext |
26 | 25 | ||
27 | BBCLASSEXTEND += "nativesdk" | 26 | BBCLASSEXTEND += "native nativesdk" |
28 | 27 | ||
29 | EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html --disable-werror" | 28 | EXTRA_OECONF = "--enable-ftdi --disable-doxygen-html --disable-werror" |
30 | 29 | ||