summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-09-05 14:58:48 -0700
committerKhem Raj <raj.khem@gmail.com>2018-09-08 13:32:12 -0700
commit0eab9697b3f9cf9280fbfda5968ba2a6b8c51a39 (patch)
tree8bcf616a6b913fee2c7e9261370bf2034e14d822 /meta-oe
parent0d69645f3b6084fefd97cf362a4d7a693b2bf26b (diff)
downloadmeta-openembedded-0eab9697b3f9cf9280fbfda5968ba2a6b8c51a39.tar.gz
links,links-x11: Upgrade to 2.16
* Fixes build with OpenSSL 1.1.x License-Update: Corrected formatting Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/links/files/ac-prog-cxx.patch24
-rw-r--r--meta-oe/recipes-support/links/links-x11_2.16.bb53
-rw-r--r--meta-oe/recipes-support/links/links-x11_2.7.bb31
-rw-r--r--meta-oe/recipes-support/links/links.inc2
-rw-r--r--meta-oe/recipes-support/links/links_2.16.bb (renamed from meta-oe/recipes-support/links/links_2.7.bb)6
5 files changed, 75 insertions, 41 deletions
diff --git a/meta-oe/recipes-support/links/files/ac-prog-cxx.patch b/meta-oe/recipes-support/links/files/ac-prog-cxx.patch
index 41c382685..2dc57a5c8 100644
--- a/meta-oe/recipes-support/links/files/ac-prog-cxx.patch
+++ b/meta-oe/recipes-support/links/files/ac-prog-cxx.patch
@@ -1,11 +1,21 @@
1--- links-2.1pre20/configure.in.orig 2005-12-21 15:23:49.000000000 +0000 1From c00668541f68c17a5e453a4dcc2a86022b20af87 Mon Sep 17 00:00:00 2001
2+++ links-2.1pre20/configure.in 2005-12-21 15:23:59.000000000 +0000 2From: Martin Jansa <Martin.Jansa@gmail.com>
3@@ -18,7 +18,7 @@ 3Date: Mon, 30 Jul 2012 23:52:49 +0200
4
5---
6 configure.in | 2 +-
7 1 file changed, 1 insertion(+), 1 deletion(-)
8
9diff --git a/configure.in b/configure.in
10index 7c15b6b..9896631 100644
11--- a/configure.in
12+++ b/configure.in
13@@ -23,7 +23,7 @@ AM_CONFIG_HEADER(config.h)
4 dnl Checks for programs. 14 dnl Checks for programs.
5 AC_PROG_CC 15 AC_PROG_CC
6 16
7-#AC_PROG_CXX 17-dnl AC_PROG_CXX
8+AC_PROG_CXX 18+AC_PROG_CXX
9 #AC_PROG_AWK 19 dnl AC_PROG_AWK
10 #AM_PROG_LEX 20 dnl AM_PROG_LEX
11 #AC_PROG_YACC 21 dnl AC_PROG_YACC
diff --git a/meta-oe/recipes-support/links/links-x11_2.16.bb b/meta-oe/recipes-support/links/links-x11_2.16.bb
new file mode 100644
index 000000000..f55a6fc7b
--- /dev/null
+++ b/meta-oe/recipes-support/links/links-x11_2.16.bb
@@ -0,0 +1,53 @@
1# FIXME: the LIC_FILES_CHKSUM values have been updated by 'devtool upgrade'.
2# The following is the difference between the old and the new license text.
3# Please update the LICENSE value if needed, and summarize the changes in
4# the commit message via 'License-Update:' tag.
5# (example: 'License-Update: copyright years updated.')
6#
7# The changes:
8#
9# --- COPYING
10# +++ COPYING
11# @@ -293,7 +293,7 @@
12# <one line to give the program's name and a brief idea of what it does.>
13# Copyright (C) <year> <name of author>
14#
15# - on, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USAThis program is free software; you can redistribute it and/or modify
16# + This program is free software; you can redistribute it and/or modify
17# it under the terms of the GNU General Public License as published by
18# the Free Software Foundation; either version 2 of the License, or
19# (at your option) any later version.
20#
21#
22
23require links.inc
24
25DEPENDS += "virtual/libx11"
26RCONFLICTS_${PN} = "links"
27
28inherit distro_features_check
29# depends on virtual/libx11
30REQUIRED_DISTRO_FEATURES = "x11"
31
32SRC_URI += " file://links2.desktop \
33 http://www.xora.org.uk/oe/links2.png;name=icon"
34
35S = "${WORKDIR}/links-${PV}"
36
37EXTRA_OECONF = "--enable-graphics \
38 --with-ssl=${STAGING_LIBDIR}/.. --with-libjpeg \
39 --without-libtiff --without-svgalib --without-fb \
40 --without-directfb --without-pmshell --without-atheos \
41 --with-x --without-gpm"
42
43do_install_append() {
44 install -d ${D}/${datadir}/applications
45 install -m 0644 ${WORKDIR}/links2.desktop ${D}/${datadir}/applications
46 install -d ${D}/${datadir}/pixmaps
47 install -m 0644 ${WORKDIR}/links2.png ${D}/${datadir}/pixmaps
48}
49
50SRC_URI[md5sum] = "645fb0c0294e4c3268f94d307d394ffb"
51SRC_URI[sha256sum] = "82f03038d5e050a65681b9888762af41c40fd42dec7e59a8d630bfb0ee134a3f"
52SRC_URI[icon.md5sum] = "477e8787927c634614bac01b44355a33"
53SRC_URI[icon.sha256sum] = "eddcd8b8c8698aa621d1a453943892d77b72ed492e0d14e0dbac5c6a57e52f47"
diff --git a/meta-oe/recipes-support/links/links-x11_2.7.bb b/meta-oe/recipes-support/links/links-x11_2.7.bb
deleted file mode 100644
index 2ae11ac97..000000000
--- a/meta-oe/recipes-support/links/links-x11_2.7.bb
+++ /dev/null
@@ -1,31 +0,0 @@
1require links.inc
2
3DEPENDS += "virtual/libx11"
4RCONFLICTS_${PN} = "links"
5
6inherit distro_features_check
7# depends on virtual/libx11
8REQUIRED_DISTRO_FEATURES = "x11"
9
10SRC_URI += " file://links2.desktop \
11 http://www.xora.org.uk/oe/links2.png;name=icon"
12
13S = "${WORKDIR}/links-${PV}"
14
15EXTRA_OECONF = "--enable-graphics \
16 --with-ssl=${STAGING_LIBDIR}/.. --with-libjpeg \
17 --without-libtiff --without-svgalib --without-fb \
18 --without-directfb --without-pmshell --without-atheos \
19 --with-x --without-gpm"
20
21do_install_append() {
22 install -d ${D}/${datadir}/applications
23 install -m 0644 ${WORKDIR}/links2.desktop ${D}/${datadir}/applications
24 install -d ${D}/${datadir}/pixmaps
25 install -m 0644 ${WORKDIR}/links2.png ${D}/${datadir}/pixmaps
26}
27
28SRC_URI[md5sum] = "d06aa6e14b2172d73188871a5357185a"
29SRC_URI[sha256sum] = "0c182b1cbcdfd5cdcd2f75a6032d1a4b660d07c1225c1e07757cec81d3302130"
30SRC_URI[icon.md5sum] = "477e8787927c634614bac01b44355a33"
31SRC_URI[icon.sha256sum] = "eddcd8b8c8698aa621d1a453943892d77b72ed492e0d14e0dbac5c6a57e52f47"
diff --git a/meta-oe/recipes-support/links/links.inc b/meta-oe/recipes-support/links/links.inc
index e07240820..d6aa2d2d4 100644
--- a/meta-oe/recipes-support/links/links.inc
+++ b/meta-oe/recipes-support/links/links.inc
@@ -3,7 +3,7 @@ browser, similar to Lynx."
3HOMEPAGE = "http://links.twibright.com/" 3HOMEPAGE = "http://links.twibright.com/"
4SECTION = "console/network" 4SECTION = "console/network"
5LICENSE = "GPLv2" 5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=65e735be2e05d5943803344148f57603" 6LIC_FILES_CHKSUM = "file://COPYING;md5=b0c80473f97008e42e29a9f80fcc55ff"
7DEPENDS = "jpeg libpng flex openssl zlib" 7DEPENDS = "jpeg libpng flex openssl zlib"
8 8
9SRC_URI = "http://links.twibright.com/download/links-${PV}.tar.bz2 \ 9SRC_URI = "http://links.twibright.com/download/links-${PV}.tar.bz2 \
diff --git a/meta-oe/recipes-support/links/links_2.7.bb b/meta-oe/recipes-support/links/links_2.16.bb
index e80dd7bca..19ea7a67b 100644
--- a/meta-oe/recipes-support/links/links_2.7.bb
+++ b/meta-oe/recipes-support/links/links_2.16.bb
@@ -9,5 +9,7 @@ EXTRA_OECONF = "--enable-graphics \
9 --without-directfb --without-pmshell --without-atheos \ 9 --without-directfb --without-pmshell --without-atheos \
10 --without-x" 10 --without-x"
11 11
12SRC_URI[md5sum] = "d06aa6e14b2172d73188871a5357185a" 12SRC_URI[md5sum] = "645fb0c0294e4c3268f94d307d394ffb"
13SRC_URI[sha256sum] = "0c182b1cbcdfd5cdcd2f75a6032d1a4b660d07c1225c1e07757cec81d3302130" 13SRC_URI[sha256sum] = "82f03038d5e050a65681b9888762af41c40fd42dec7e59a8d630bfb0ee134a3f"
14SRC_URI[icon.md5sum] = "477e8787927c634614bac01b44355a33"
15SRC_URI[icon.sha256sum] = "eddcd8b8c8698aa621d1a453943892d77b72ed492e0d14e0dbac5c6a57e52f47"