summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-02-01 14:23:40 +0000
committerJoe MacDonald <joe_macdonald@mentor.com>2018-03-05 11:45:40 -0500
commit0db9697dc6b8cb470cd97377638af69dc1052189 (patch)
treec22262d4a8729e2b9de0afdb0f070ffee59a13f7 /meta-oe
parent29e280ee11c9a6f13c004ff25299668e4616f275 (diff)
downloadmeta-openembedded-0db9697dc6b8cb470cd97377638af69dc1052189.tar.gz
samba, openwsman, pam-ssh-agent-auth, sblim-sfcb, passwdqc, python-pam, smbnetfs: require pam in DISTRO_FEATURES
* there is explicit dependency on libpam without respecting pam in DISTRO_FEATURES so add the check to prevent people building it against broken libpam Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb3
-rw-r--r--meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb3
-rw-r--r--meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb3
-rw-r--r--meta-oe/recipes-security/passwdqc/passwdqc_1.3.1.bb3
4 files changed, 12 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb b/meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb
index c4778ca38..f618f02b5 100644
--- a/meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb
+++ b/meta-oe/recipes-extended/openwsman/openwsman_2.6.3.bb
@@ -12,6 +12,9 @@ SECTION = "Applications/System"
12 12
13DEPENDS = "curl libxml2 openssl libpam" 13DEPENDS = "curl libxml2 openssl libpam"
14 14
15inherit distro_features_check
16REQUIRED_DISTRO_FEATURES = "pam"
17
15SRCREV = "feb7ec9b004fcaea0dbe65ce8a1a79cc29dd994c" 18SRCREV = "feb7ec9b004fcaea0dbe65ce8a1a79cc29dd994c"
16PV = "2.6.3" 19PV = "2.6.3"
17 20
diff --git a/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb b/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb
index ff88533ff..1638c41c8 100644
--- a/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb
+++ b/meta-oe/recipes-extended/pam/pam-ssh-agent-auth_0.10.3.bb
@@ -13,6 +13,9 @@ SRC_URI[sha256sum] = "3c53d358d6eaed1b211239df017c27c6f9970995d14102ae67bae16d4f
13 13
14DEPENDS += "libpam openssl" 14DEPENDS += "libpam openssl"
15 15
16inherit distro_features_check
17REQUIRED_DISTRO_FEATURES = "pam"
18
16# This gets us ssh-agent, which we are almost certain to want. 19# This gets us ssh-agent, which we are almost certain to want.
17# 20#
18RDEPENDS_${PN} += "openssh-misc" 21RDEPENDS_${PN} += "openssh-misc"
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
index c6b9f1019..152ae2290 100644
--- a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
+++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
@@ -11,6 +11,9 @@ LICENSE = "EPL-1.0"
11LIC_FILES_CHKSUM = "file://COPYING;md5=f300afd598546add034364cd0a533261" 11LIC_FILES_CHKSUM = "file://COPYING;md5=f300afd598546add034364cd0a533261"
12DEPENDS = "curl libpam openssl sblim-sfc-common unzip-native" 12DEPENDS = "curl libpam openssl sblim-sfc-common unzip-native"
13 13
14inherit distro_features_check
15REQUIRED_DISTRO_FEATURES = "pam"
16
14SRC_URI = "http://downloads.sourceforge.net/sblim/${BP}.tar.bz2 \ 17SRC_URI = "http://downloads.sourceforge.net/sblim/${BP}.tar.bz2 \
15 file://sfcb.service \ 18 file://sfcb.service \
16 file://sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch \ 19 file://sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch \
diff --git a/meta-oe/recipes-security/passwdqc/passwdqc_1.3.1.bb b/meta-oe/recipes-security/passwdqc/passwdqc_1.3.1.bb
index 198db3ce7..8fc0b3591 100644
--- a/meta-oe/recipes-security/passwdqc/passwdqc_1.3.1.bb
+++ b/meta-oe/recipes-security/passwdqc/passwdqc_1.3.1.bb
@@ -21,6 +21,9 @@ SECTION = "System Environment/Base"
21 21
22DEPENDS += "libpam" 22DEPENDS += "libpam"
23 23
24inherit distro_features_check
25REQUIRED_DISTRO_FEATURES = "pam"
26
24LICENSE = "BSD" 27LICENSE = "BSD"
25LIC_FILES_CHKSUM = "file://LICENSE;md5=1b4af6f3d4ee079a38107366e93b334d" 28LIC_FILES_CHKSUM = "file://LICENSE;md5=1b4af6f3d4ee079a38107366e93b334d"
26 29