summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorAndrea Ricchi <andrea.ricchi@amarulasolutions.com>2024-10-31 10:22:22 +0100
committerKhem Raj <raj.khem@gmail.com>2024-10-31 06:24:13 -0700
commit06ac0733cc94261276dea5ea42cb4e6eb3210590 (patch)
treed10958edbdd026d973b9e8ef4f26cbdd8c917c3d /meta-oe
parentec67268d5e74cf4774f842e63bc00139d327e457 (diff)
downloadmeta-openembedded-06ac0733cc94261276dea5ea42cb4e6eb3210590.tar.gz
asyncmqtt: add recipe
async_mqtt is an C++ library for asynchronous MQTT communication. The library is header-only using C++17 and Boost libraries; the main features are client and server support, MQTT v3.1.1 and v5.0 support, continuous packet sending and auto acquiring/mapping topic alias is supported. Signed-off-by: Andrea Ricchi <andrea.ricchi@amarulasolutions.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-connectivity/asyncmqtt/asyncmqtt_9.0.2.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta-oe/recipes-connectivity/asyncmqtt/asyncmqtt_9.0.2.bb b/meta-oe/recipes-connectivity/asyncmqtt/asyncmqtt_9.0.2.bb
new file mode 100644
index 000000000..dac83065c
--- /dev/null
+++ b/meta-oe/recipes-connectivity/asyncmqtt/asyncmqtt_9.0.2.bb
@@ -0,0 +1,14 @@
1SUMMARY = "MQTT communication C++ library using Boost.Asio"
2HOMEPAGE = "https://github.com/redboltz/async_mqtt"
3LICENSE = "BSL-1.0"
4
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e4224ccaecb14d942c71d31bef20d78c"
6
7SRC_URI = "git://github.com/redboltz/async_mqtt;protocol=http;branch=main;protocol=https"
8SRCREV = "51a97adfd022cf5205c3bb31f38ace1f7fbd21a1"
9
10DEPENDS = "openssl boost"
11
12S = "${WORKDIR}/git"
13
14inherit cmake