summaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2023-07-10 13:41:25 +0100
committerKhem Raj <raj.khem@gmail.com>2023-07-10 11:01:40 -0700
commit00a00cec2a88fdc023a0bd895ccaa921861df755 (patch)
treead712324c79b4263092875a097ff11be8eaa104a /meta-oe
parented0c5261ad886e8424aeb573d227b055187334c4 (diff)
downloadmeta-openembedded-00a00cec2a88fdc023a0bd895ccaa921861df755.tar.gz
liblbxutil: remove obsolete library
This is the client-side library for the LBX extension, which was removed from xserver 1.2 (released 2007). Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb1
-rw-r--r--meta-oe/recipes-graphics/xorg-lib/liblbxutil-1.1.0/0001-lbx_zlib-Mark-declration-with-extern.patch36
-rw-r--r--meta-oe/recipes-graphics/xorg-lib/liblbxutil-1.1.0/mkg3states-1.1.patch57
-rw-r--r--meta-oe/recipes-graphics/xorg-lib/liblbxutil_1.1.0.bb18
4 files changed, 0 insertions, 112 deletions
diff --git a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
index 469e20217..c555ade62 100644
--- a/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
+++ b/meta-oe/recipes-core/packagegroups/packagegroup-meta-oe.bb
@@ -595,7 +595,6 @@ RDEPENDS:packagegroup-meta-oe-graphics ="\
595 font-cursor-misc \ 595 font-cursor-misc \
596 font-misc-misc \ 596 font-misc-misc \
597 xorg-fonts-100dpi \ 597 xorg-fonts-100dpi \
598 liblbxutil \
599 libxaw6 \ 598 libxaw6 \
600 libxkbui \ 599 libxkbui \
601 libxpresent \ 600 libxpresent \
diff --git a/meta-oe/recipes-graphics/xorg-lib/liblbxutil-1.1.0/0001-lbx_zlib-Mark-declration-with-extern.patch b/meta-oe/recipes-graphics/xorg-lib/liblbxutil-1.1.0/0001-lbx_zlib-Mark-declration-with-extern.patch
deleted file mode 100644
index 32a24b4be..000000000
--- a/meta-oe/recipes-graphics/xorg-lib/liblbxutil-1.1.0/0001-lbx_zlib-Mark-declration-with-extern.patch
+++ /dev/null
@@ -1,36 +0,0 @@
1From 95ed4b743f197e20f1884a326d5a7128187a7ba6 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 13 Aug 2020 17:56:30 -0700
4Subject: [PATCH] lbx_zlib: Mark declration with extern
5
6Fixes build with gcc10/-fno-common
7
8Upstream-Status: Pending
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 src/lbx_zlib/lbx_zlib.h | 12 ++++++------
12 1 file changed, 6 insertions(+), 6 deletions(-)
13
14diff --git a/src/lbx_zlib/lbx_zlib.h b/src/lbx_zlib/lbx_zlib.h
15index 8ae8956..bec3b96 100644
16--- a/src/lbx_zlib/lbx_zlib.h
17+++ b/src/lbx_zlib/lbx_zlib.h
18@@ -136,9 +136,9 @@ extern void Xfree(pointer /*ptr*/);
19 #endif
20
21 /* lbx_zlib.c */
22-unsigned long stream_out_compressed;
23-unsigned long stream_out_uncompressed;
24-unsigned long stream_out_plain;
25-unsigned long stream_in_compressed;
26-unsigned long stream_in_uncompressed;
27-unsigned long stream_in_plain;
28+extern unsigned long stream_out_compressed;
29+extern unsigned long stream_out_uncompressed;
30+extern unsigned long stream_out_plain;
31+extern unsigned long stream_in_compressed;
32+extern unsigned long stream_in_uncompressed;
33+extern unsigned long stream_in_plain;
34--
352.28.0
36
diff --git a/meta-oe/recipes-graphics/xorg-lib/liblbxutil-1.1.0/mkg3states-1.1.patch b/meta-oe/recipes-graphics/xorg-lib/liblbxutil-1.1.0/mkg3states-1.1.patch
deleted file mode 100644
index af7d20828..000000000
--- a/meta-oe/recipes-graphics/xorg-lib/liblbxutil-1.1.0/mkg3states-1.1.patch
+++ /dev/null
@@ -1,57 +0,0 @@
1Upstream-Status: Pending
2
3diff -uNr liblbxutil-1.1.0.orig/configure.ac liblbxutil-1.1.0/configure.ac
4--- liblbxutil-1.1.0.orig/configure.ac 2009-12-04 23:52:04.000000000 +0100
5+++ liblbxutil-1.1.0/configure.ac 2009-12-16 10:45:00.000000000 +0100
6@@ -50,4 +50,5 @@
7
8 AC_OUTPUT([Makefile
9 src/Makefile
10+ src/image/Makefile
11 lbxutil.pc])
12diff -uNr liblbxutil-1.1.0.orig/src/image/Makefile.am liblbxutil-1.1.0/src/image/Makefile.am
13--- liblbxutil-1.1.0.orig/src/image/Makefile.am 1970-01-01 01:00:00.000000000 +0100
14+++ liblbxutil-1.1.0/src/image/Makefile.am 2009-12-16 10:45:00.000000000 +0100
15@@ -0,0 +1,15 @@
16+# evil hack
17+CFLAGS=$(CFLAGS_FOR_BUILD)
18+CPPFLAGS=$(CPPFLAGS_FOR_BUILD)
19+LDFLAGS=$(LDFLAGS_FOR_BUILD)
20+
21+CC=$(CC_FOR_BUILD)
22+LIBTOOL = @LIBTOOL@ --tag=CC
23+
24+noinst_PROGRAMS = mkg3states
25+
26+mkg3states_SOURCES = \
27+ mkg3states.c
28+
29+mkg3states_CFLAGS=$(CFLAGS_FOR_BUILD)
30+mkg3states_LDFLAGS=$(LDFLAGS_FOR_BUILD)
31diff -uNr liblbxutil-1.1.0.orig/src/Makefile.am liblbxutil-1.1.0/src/Makefile.am
32--- liblbxutil-1.1.0.orig/src/Makefile.am 2009-12-16 10:48:11.000000000 +0100
33+++ liblbxutil-1.1.0/src/Makefile.am 2009-12-16 10:46:47.000000000 +0100
34@@ -3,10 +3,7 @@
35 AM_CFLAGS = $(CWARNFLAGS) $(LBXUTIL_CFLAGS)
36 INCLUDES = -I$(top_srcdir)/include
37
38-noinst_PROGRAMS = mkg3states
39-
40-mkg3states_SOURCES = \
41- $(srcdir)/image/mkg3states.c
42+SUBDIRS = image
43
44 liblbxutil_la_SOURCES = \
45 $(srcdir)/lbx_zlib/reqstats.h \
46@@ -38,9 +35,8 @@
47
48 $(srcdir)/image/dfaxg42d.c: g3states.h
49
50-g3states.h: mkg3states
51- -rm -f g3states.h
52- $(AM_V_GEN) ./mkg3states -c > g3states.h_ && mv g3states.h_ g3states.h
53+g3states.h: image/mkg3states
54+ $(AM_V_GEN) ./image/mkg3states -c > g3states.h_ && mv g3states.h_ g3states.h
55
56 liblbxutil_la_LDFLAGS = -version-number 1:0:0 -no-undefined
57
diff --git a/meta-oe/recipes-graphics/xorg-lib/liblbxutil_1.1.0.bb b/meta-oe/recipes-graphics/xorg-lib/liblbxutil_1.1.0.bb
deleted file mode 100644
index ce064903b..000000000
--- a/meta-oe/recipes-graphics/xorg-lib/liblbxutil_1.1.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@
1require recipes-graphics/xorg-lib/xorg-lib-common.inc
2
3LIC_FILES_CHKSUM = "file://COPYING;md5=b0d5bdc98f7ebab3b6c3791d9bf40907"
4
5SUMMARY = "XFIXES Extension"
6DEPENDS += " xorgproto zlib"
7PE = "1"
8PR = "r11"
9
10XORG_EXT = "tar.bz2"
11
12SRC_URI += "file://mkg3states-1.1.patch \
13 file://0001-lbx_zlib-Mark-declration-with-extern.patch \
14 "
15SRC_URI[md5sum] = "273329a78c2e9ea189ac416c7fde94a1"
16SRC_URI[sha256sum] = "c6b6ff7858ec619cafa8205debca6bf78c5610a2844a782ed643c7fd017cf8ae"
17
18export CC_FOR_BUILD = "gcc"