summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/gtest
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-12-11 15:47:54 -0500
committerKhem Raj <raj.khem@gmail.com>2018-12-11 22:13:55 -0800
commit179a1b9ea86f33b5a3f4eec9fcc00c0a5e8833f0 (patch)
tree231c9ed57a0614ce17770360f95fa86354660beb /meta-oe/recipes-test/gtest
parent6356e84d6bb357a897120d5904cae2e9e7b493dc (diff)
downloadmeta-openembedded-179a1b9ea86f33b5a3f4eec9fcc00c0a5e8833f0.tar.gz
gtest: update to 1.8.1
Update to 1.8.1, which has proper pkg-config support (so Add-pkg-config-support.patch can be dropped). Also the canonical gtest seems to have moved out of the google github organization into something called abseil. Update HOMEPAGE and SRC_URI to match. Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test/gtest')
-rw-r--r--meta-oe/recipes-test/gtest/gtest/Add-pkg-config-support.patch106
-rw-r--r--meta-oe/recipes-test/gtest/gtest_1.8.1.bb (renamed from meta-oe/recipes-test/gtest/gtest_1.8.0.bb)7
2 files changed, 3 insertions, 110 deletions
diff --git a/meta-oe/recipes-test/gtest/gtest/Add-pkg-config-support.patch b/meta-oe/recipes-test/gtest/gtest/Add-pkg-config-support.patch
deleted file mode 100644
index 4c8977b49..000000000
--- a/meta-oe/recipes-test/gtest/gtest/Add-pkg-config-support.patch
+++ /dev/null
@@ -1,106 +0,0 @@
1From ec9256bb704e94f41407fc8ace6a580491430196 Mon Sep 17 00:00:00 2001
2From: Andre McCurdy <armccurdy@gmail.com>
3Date: Thu, 15 Dec 2016 04:35:41 -0800
4Subject: [PATCH] Add pkg-config support
5
6Signed-off-by: Mario Domenech Goulart <mario@ossystems.com.br>
7Signed-off-by: Rodrigo Caimi <caimi@datacom.ind.br>
8Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
9---
10 googlemock/CMakeLists.txt | 9 +++++++--
11 googlemock/gmock.pc.in | 9 +++++++++
12 googletest/CMakeLists.txt | 9 +++++++--
13 googletest/gtest.pc.in | 9 +++++++++
14 4 files changed, 32 insertions(+), 4 deletions(-)
15 create mode 100644 googlemock/gmock.pc.in
16 create mode 100644 googletest/gtest.pc.in
17
18diff --git a/googlemock/CMakeLists.txt b/googlemock/CMakeLists.txt
19index beb259a..f17e2d7 100644
20--- a/googlemock/CMakeLists.txt
21+++ b/googlemock/CMakeLists.txt
22@@ -27,6 +27,9 @@ if (COMMAND pre_project_set_up_hermetic_build)
23 pre_project_set_up_hermetic_build()
24 endif()
25
26+# pkg-config support
27+configure_file("gmock.pc.in" "gmock.pc" @ONLY)
28+
29 ########################################################################
30 #
31 # Project-wide settings
32@@ -104,9 +107,11 @@ endif()
33 #
34 # Install rules
35 install(TARGETS gmock gmock_main
36- DESTINATION lib)
37+ DESTINATION ${CMAKE_INSTALL_LIBDIR})
38 install(DIRECTORY ${gmock_SOURCE_DIR}/include/gmock
39- DESTINATION include)
40+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
41+install(FILES "${CMAKE_CURRENT_BINARY_DIR}/gmock.pc"
42+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig/")
43
44 ########################################################################
45 #
46diff --git a/googlemock/gmock.pc.in b/googlemock/gmock.pc.in
47new file mode 100644
48index 0000000..04bc0b4
49--- /dev/null
50+++ b/googlemock/gmock.pc.in
51@@ -0,0 +1,9 @@
52+Name: libgmock
53+Version: 1.8.0
54+Description: Google's framework for writing C++ tests on a variety of platforms
55+
56+prefix=@CMAKE_INSTALL_PREFIX@
57+includedir=@CMAKE_INSTALL_INCLUDEDIR@
58+libdir=@CMAKE_INSTALL_LIBDIR@
59+Cflags:-I${includedir}/gmock
60+Libs: -L${libdir} -lgmock -lgmock_main
61diff --git a/googletest/CMakeLists.txt b/googletest/CMakeLists.txt
62index 621d0f0..58aaf54 100644
63--- a/googletest/CMakeLists.txt
64+++ b/googletest/CMakeLists.txt
65@@ -34,6 +34,9 @@ if (COMMAND pre_project_set_up_hermetic_build)
66 pre_project_set_up_hermetic_build()
67 endif()
68
69+# pkg-config support
70+configure_file("gtest.pc.in" "gtest.pc" @ONLY)
71+
72 ########################################################################
73 #
74 # Project-wide settings
75@@ -103,9 +106,11 @@ endif()
76 #
77 # Install rules
78 install(TARGETS gtest gtest_main
79- DESTINATION lib)
80+ DESTINATION ${CMAKE_INSTALL_LIBDIR})
81 install(DIRECTORY ${gtest_SOURCE_DIR}/include/gtest
82- DESTINATION include)
83+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
84+install(FILES "${CMAKE_CURRENT_BINARY_DIR}/gtest.pc"
85+ DESTINATION "${CMAKE_INSTALL_LIBDIR}/pkgconfig/")
86
87 ########################################################################
88 #
89diff --git a/googletest/gtest.pc.in b/googletest/gtest.pc.in
90new file mode 100644
91index 0000000..fb95152
92--- /dev/null
93+++ b/googletest/gtest.pc.in
94@@ -0,0 +1,9 @@
95+Name: libgtest
96+Version: 1.8.0
97+Description: Google's framework for writing C++ tests on a variety of platforms
98+
99+prefix=@CMAKE_INSTALL_PREFIX@
100+includedir=@CMAKE_INSTALL_INCLUDEDIR@
101+libdir=@CMAKE_INSTALL_LIBDIR@
102+Cflags:-I${includedir}/gtest
103+Libs: -L${libdir} -lgtest -lgtest_main
104--
1051.9.1
106
diff --git a/meta-oe/recipes-test/gtest/gtest_1.8.0.bb b/meta-oe/recipes-test/gtest/gtest_1.8.1.bb
index 48cf4e04b..23862c930 100644
--- a/meta-oe/recipes-test/gtest/gtest_1.8.0.bb
+++ b/meta-oe/recipes-test/gtest/gtest_1.8.1.bb
@@ -1,5 +1,5 @@
1DESCRIPTION = "Google's framework for writing C++ tests" 1DESCRIPTION = "Google's framework for writing C++ tests"
2HOMEPAGE = "https://github.com/google/googletest" 2HOMEPAGE = "https://github.com/abseil/googletest"
3SECTION = "libs" 3SECTION = "libs"
4LICENSE = "BSD-3-Clause" 4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://googlemock/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \ 5LIC_FILES_CHKSUM = "file://googlemock/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
@@ -8,10 +8,9 @@ LIC_FILES_CHKSUM = "file://googlemock/LICENSE;md5=cbbd27594afd089daa160d3a16dd51
8PROVIDES += "gmock" 8PROVIDES += "gmock"
9 9
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11SRCREV = "ec44c6c1675c25b9827aacd08c02433cccde7780" 11SRCREV = "2fe3bd994b3189899d93f1d5a881e725e046fdc2"
12SRC_URI = "\ 12SRC_URI = "\
13 git://github.com/google/googletest.git;protocol=https; \ 13 git://github.com/abseil/googletest.git;protocol=https; \
14 file://Add-pkg-config-support.patch \
15" 14"
16 15
17inherit cmake 16inherit cmake