summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/gtest/gtest/0001-Add-install-command-for-libraries-and-headers.patch
diff options
context:
space:
mode:
authorFrederico Cadete <frederico.cadete@awtce.be>2016-06-22 17:29:35 +0200
committerArmin Kuster <akuster808@gmail.com>2016-08-16 10:29:41 -0700
commit87e83981f4c6cb0c739510e34b0db3c3471db3e5 (patch)
treec60600c199979abd62c08cc32cc0644769451aeb /meta-oe/recipes-test/gtest/gtest/0001-Add-install-command-for-libraries-and-headers.patch
parentf87dd8d51685a5a346eaa50e8bf5130d050f50f2 (diff)
downloadmeta-openembedded-87e83981f4c6cb0c739510e34b0db3c3471db3e5.tar.gz
gtest: fix installation in multilib
The installation and pkgconfig patches have to be reworked to consider the install directories from OE. Signed-off-by: Frederico Cadete <frederico.cadete@awtce.be> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 377d67aa7cb902d4a512c3489482fb876b1ec4cd) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test/gtest/gtest/0001-Add-install-command-for-libraries-and-headers.patch')
-rw-r--r--meta-oe/recipes-test/gtest/gtest/0001-Add-install-command-for-libraries-and-headers.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-test/gtest/gtest/0001-Add-install-command-for-libraries-and-headers.patch b/meta-oe/recipes-test/gtest/gtest/0001-Add-install-command-for-libraries-and-headers.patch
new file mode 100644
index 000000000..b8f5d6f30
--- /dev/null
+++ b/meta-oe/recipes-test/gtest/gtest/0001-Add-install-command-for-libraries-and-headers.patch
@@ -0,0 +1,32 @@
1From bdcbef7b8adde424ee29e7eddc3b0570cc336449 Mon Sep 17 00:00:00 2001
2From: Frederico Cadete <frederico.cadete@awtce.be>
3Date: Tue, 21 Jun 2016 10:55:38 +0200
4Subject: [PATCH 1/2] Add install command for libraries and headers
5
6Signed-off-by: Frederico Cadete <frederico.cadete@awtce.be>
7---
8 CMakeLists.txt | 8 ++++++++
9 1 file changed, 8 insertions(+)
10
11diff --git a/CMakeLists.txt b/CMakeLists.txt
12index 57470c8..e969648 100644
13--- a/CMakeLists.txt
14+++ b/CMakeLists.txt
15@@ -73,6 +73,14 @@ target_link_libraries(gtest_main gtest)
16
17 ########################################################################
18 #
19+# Install rules
20+install(TARGETS gtest gtest_main
21+ DESTINATION ${CMAKE_INSTALL_LIBDIR})
22+install(DIRECTORY ${gtest_SOURCE_DIR}/include/gtest
23+ DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
24+
25+########################################################################
26+#
27 # Samples on how to link user tests with gtest or gtest_main.
28 #
29 # They are not built by default. To build them, set the
30--
312.5.0
32