diff options
author | Ross Burton <ross@burtonini.com> | 2021-04-14 15:07:20 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-04-15 09:28:43 -0700 |
commit | b7b0bcb4fed0477ee22066b387c0f49eaa5dc262 (patch) | |
tree | 565e294791fabdf0519283b20f17ae2f5d0df0ab /meta-oe/recipes-test/fwts | |
parent | df625750c681365b8ed1fbd746cbe054437395cb (diff) | |
download | meta-openembedded-b7b0bcb4fed0477ee22066b387c0f49eaa5dc262.tar.gz |
fwts: upgrade to 21.03.00
Rebase the musl patches.
Drop json-c dependency as this is no longer used.
Drop FILES_${PN}-dbg packaging as this happens magically now.
Drop -Wno-error CFLAGS as we patch out -Werror entirely.
Add dtc RDEPENDS as this is needed at runtime.
Signed-off-by: Ross Burton <ross.burton@arm.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test/fwts')
-rw-r--r-- | meta-oe/recipes-test/fwts/fwts/0001-Add-correct-printf-qualifier-for-off_t.patch | 20 | ||||
-rw-r--r-- | meta-oe/recipes-test/fwts/fwts/0002-Include-poll.h-instead-of-deprecated-sys-poll.h.patch (renamed from meta-oe/recipes-test/fwts/fwts/0001-Include-poll.h-instead-of-deprecated-sys-poll.h.patch) | 12 | ||||
-rw-r--r-- | meta-oe/recipes-test/fwts/fwts/0003-Remove-Werror-from-build.patch (renamed from meta-oe/recipes-test/fwts/fwts/0001-Remove-Werror-from-build.patch) | 18 | ||||
-rw-r--r-- | meta-oe/recipes-test/fwts/fwts/0004-Define-__SWORD_TYPE-if-not-defined-by-libc.patch (renamed from meta-oe/recipes-test/fwts/fwts/0002-Define-__SWORD_TYPE-if-not-defined-by-libc.patch) | 12 | ||||
-rw-r--r-- | meta-oe/recipes-test/fwts/fwts/0005-Undefine-PAGE_SIZE.patch (renamed from meta-oe/recipes-test/fwts/fwts/0003-Undefine-PAGE_SIZE.patch) | 10 | ||||
-rw-r--r-- | meta-oe/recipes-test/fwts/fwts/0006-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch (renamed from meta-oe/recipes-test/fwts/fwts/0003-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch) | 37 | ||||
-rw-r--r-- | meta-oe/recipes-test/fwts/fwts_21.03.00.bb (renamed from meta-oe/recipes-test/fwts/fwts_20.07.00.bb) | 18 |
7 files changed, 69 insertions, 58 deletions
diff --git a/meta-oe/recipes-test/fwts/fwts/0001-Add-correct-printf-qualifier-for-off_t.patch b/meta-oe/recipes-test/fwts/fwts/0001-Add-correct-printf-qualifier-for-off_t.patch index c2d679aab..0d73d7310 100644 --- a/meta-oe/recipes-test/fwts/fwts/0001-Add-correct-printf-qualifier-for-off_t.patch +++ b/meta-oe/recipes-test/fwts/fwts/0001-Add-correct-printf-qualifier-for-off_t.patch | |||
@@ -1,16 +1,15 @@ | |||
1 | From 613e5cfe7751068062cc92f83870e436669fc0a8 Mon Sep 17 00:00:00 2001 | 1 | From ee787b53d734cd952c170c9303d213d3dd18a86f Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Thu, 8 Jun 2017 16:49:50 -0700 | 3 | Date: Thu, 8 Jun 2017 16:49:50 -0700 |
4 | Subject: [PATCH] Add correct printf qualifier for off_t | 4 | Subject: [PATCH 1/6] Add correct printf qualifier for off_t |
5 | 5 | ||
6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 6 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
7 | |||
8 | --- | 7 | --- |
9 | src/bios/ebda_region/ebda_region.c | 8 ++++---- | 8 | src/bios/ebda_region/ebda_region.c | 10 +++++----- |
10 | 1 file changed, 4 insertions(+), 4 deletions(-) | 9 | 1 file changed, 5 insertions(+), 5 deletions(-) |
11 | 10 | ||
12 | diff --git a/src/bios/ebda_region/ebda_region.c b/src/bios/ebda_region/ebda_region.c | 11 | diff --git a/src/bios/ebda_region/ebda_region.c b/src/bios/ebda_region/ebda_region.c |
13 | index 16c39357..ad6d635c 100644 | 12 | index b70ced10..947a24bd 100644 |
14 | --- a/src/bios/ebda_region/ebda_region.c | 13 | --- a/src/bios/ebda_region/ebda_region.c |
15 | +++ b/src/bios/ebda_region/ebda_region.c | 14 | +++ b/src/bios/ebda_region/ebda_region.c |
16 | @@ -83,9 +83,9 @@ static int ebda_test1(fwts_framework *fw) | 15 | @@ -83,9 +83,9 @@ static int ebda_test1(fwts_framework *fw) |
@@ -25,14 +24,19 @@ index 16c39357..ad6d635c 100644 | |||
25 | (entry->end_address - entry->start_address) / 1024, | 24 | (entry->end_address - entry->start_address) / 1024, |
26 | memory_map_name, | 25 | memory_map_name, |
27 | entry->start_address, | 26 | entry->start_address, |
28 | @@ -93,8 +93,8 @@ static int ebda_test1(fwts_framework *fw) | 27 | @@ -93,9 +93,9 @@ static int ebda_test1(fwts_framework *fw) |
29 | } else | 28 | } else |
30 | fwts_failed(fw, LOG_LEVEL_MEDIUM, | 29 | fwts_failed(fw, LOG_LEVEL_MEDIUM, |
31 | "EBDAMappedNotReserved", | 30 | "EBDAMappedNotReserved", |
32 | - "EBDA region mapped at 0x%lx but not reserved in the %s table.", | 31 | - "EBDA region mapped at 0x%lx but not reserved in the %s table.", |
33 | - ebda_addr, memory_map_name); | 32 | - ebda_addr, memory_map_name); |
33 | - | ||
34 | + "EBDA region mapped at 0x%jdx but not reserved in the %s table.", | 34 | + "EBDA region mapped at 0x%jdx but not reserved in the %s table.", |
35 | + (intmax_t)ebda_addr, memory_map_name); | 35 | + (intmax_t)ebda_addr, memory_map_name); |
36 | 36 | + | |
37 | return FWTS_OK; | 37 | return FWTS_OK; |
38 | } | 38 | } |
39 | |||
40 | -- | ||
41 | 2.25.1 | ||
42 | |||
diff --git a/meta-oe/recipes-test/fwts/fwts/0001-Include-poll.h-instead-of-deprecated-sys-poll.h.patch b/meta-oe/recipes-test/fwts/fwts/0002-Include-poll.h-instead-of-deprecated-sys-poll.h.patch index 4baefe4a4..82379331e 100644 --- a/meta-oe/recipes-test/fwts/fwts/0001-Include-poll.h-instead-of-deprecated-sys-poll.h.patch +++ b/meta-oe/recipes-test/fwts/fwts/0002-Include-poll.h-instead-of-deprecated-sys-poll.h.patch | |||
@@ -1,19 +1,18 @@ | |||
1 | From ed988c27efde5355c3ba9d0de8a14a4a40f798cc Mon Sep 17 00:00:00 2001 | 1 | From 1575b5ce3ecb8709806908061f689315553b40c7 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Tue, 6 Jun 2017 07:25:09 -0700 | 3 | Date: Tue, 6 Jun 2017 07:25:09 -0700 |
4 | Subject: [PATCH] Include poll.h instead of deprecated sys/poll.h | 4 | Subject: [PATCH 2/6] Include poll.h instead of deprecated sys/poll.h |
5 | 5 | ||
6 | Upstream-Status: Pending | 6 | Upstream-Status: Pending |
7 | 7 | ||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
9 | |||
10 | --- | 9 | --- |
11 | src/lib/src/fwts_ipmi.c | 3 ++- | 10 | src/lib/src/fwts_ipmi.c | 3 ++- |
12 | src/lib/src/fwts_pipeio.c | 2 +- | 11 | src/lib/src/fwts_pipeio.c | 2 +- |
13 | 2 files changed, 3 insertions(+), 2 deletions(-) | 12 | 2 files changed, 3 insertions(+), 2 deletions(-) |
14 | 13 | ||
15 | diff --git a/src/lib/src/fwts_ipmi.c b/src/lib/src/fwts_ipmi.c | 14 | diff --git a/src/lib/src/fwts_ipmi.c b/src/lib/src/fwts_ipmi.c |
16 | index a4c8a511..e298969e 100644 | 15 | index ca7c55bb..0b16bec3 100644 |
17 | --- a/src/lib/src/fwts_ipmi.c | 16 | --- a/src/lib/src/fwts_ipmi.c |
18 | +++ b/src/lib/src/fwts_ipmi.c | 17 | +++ b/src/lib/src/fwts_ipmi.c |
19 | @@ -18,10 +18,11 @@ | 18 | @@ -18,10 +18,11 @@ |
@@ -30,7 +29,7 @@ index a4c8a511..e298969e 100644 | |||
30 | #include <linux/ipmi.h> | 29 | #include <linux/ipmi.h> |
31 | 30 | ||
32 | diff --git a/src/lib/src/fwts_pipeio.c b/src/lib/src/fwts_pipeio.c | 31 | diff --git a/src/lib/src/fwts_pipeio.c b/src/lib/src/fwts_pipeio.c |
33 | index 3b3cfaff..289564d1 100644 | 32 | index 716297c4..37752297 100644 |
34 | --- a/src/lib/src/fwts_pipeio.c | 33 | --- a/src/lib/src/fwts_pipeio.c |
35 | +++ b/src/lib/src/fwts_pipeio.c | 34 | +++ b/src/lib/src/fwts_pipeio.c |
36 | @@ -30,9 +30,9 @@ | 35 | @@ -30,9 +30,9 @@ |
@@ -44,3 +43,6 @@ index 3b3cfaff..289564d1 100644 | |||
44 | #include <sys/types.h> | 43 | #include <sys/types.h> |
45 | #include <sys/wait.h> | 44 | #include <sys/wait.h> |
46 | #include <errno.h> | 45 | #include <errno.h> |
46 | -- | ||
47 | 2.25.1 | ||
48 | |||
diff --git a/meta-oe/recipes-test/fwts/fwts/0001-Remove-Werror-from-build.patch b/meta-oe/recipes-test/fwts/fwts/0003-Remove-Werror-from-build.patch index 93a42213b..906ec99a9 100644 --- a/meta-oe/recipes-test/fwts/fwts/0001-Remove-Werror-from-build.patch +++ b/meta-oe/recipes-test/fwts/fwts/0003-Remove-Werror-from-build.patch | |||
@@ -1,16 +1,17 @@ | |||
1 | From 475979cf5c1af978f4e8409666365ec75b3320ea Mon Sep 17 00:00:00 2001 | 1 | From 7317aba872f2bcf052a7db9fa3c7a7ce3c55dc6b Mon Sep 17 00:00:00 2001 |
2 | From: Benjamin Berg <bberg@redhat.com> | 2 | From: Benjamin Berg <bberg@redhat.com> |
3 | Date: Mon, 21 Aug 2017 10:34:40 +0200 | 3 | Date: Mon, 21 Aug 2017 10:34:40 +0200 |
4 | Subject: [PATCH] Remove -Werror from build | 4 | Subject: [PATCH 3/6] Remove -Werror from build |
5 | 5 | ||
6 | Upstream-Status: Pending | 6 | Upstream-Status: Pending |
7 | |||
8 | --- | 7 | --- |
9 | src/Makefile.am | 2 +- | 8 | src/Makefile.am | 2 +- |
10 | src/lib/src/Makefile.am | 2 +- | 9 | src/lib/src/Makefile.am | 2 +- |
11 | src/utilities/Makefile.am | 2 +- | 10 | src/utilities/Makefile.am | 2 +- |
12 | 3 files changed, 3 insertions(+), 3 deletions(-) | 11 | 3 files changed, 3 insertions(+), 3 deletions(-) |
13 | 12 | ||
13 | diff --git a/src/Makefile.am b/src/Makefile.am | ||
14 | index a26a197b..70a28174 100644 | ||
14 | --- a/src/Makefile.am | 15 | --- a/src/Makefile.am |
15 | +++ b/src/Makefile.am | 16 | +++ b/src/Makefile.am |
16 | @@ -14,7 +14,7 @@ AM_CPPFLAGS = \ | 17 | @@ -14,7 +14,7 @@ AM_CPPFLAGS = \ |
@@ -22,6 +23,8 @@ Upstream-Status: Pending | |||
22 | -Wno-address-of-packed-member \ | 23 | -Wno-address-of-packed-member \ |
23 | -Wfloat-equal -Wmissing-declarations \ | 24 | -Wfloat-equal -Wmissing-declarations \ |
24 | -Wno-long-long -Wredundant-decls -Wshadow \ | 25 | -Wno-long-long -Wredundant-decls -Wshadow \ |
26 | diff --git a/src/lib/src/Makefile.am b/src/lib/src/Makefile.am | ||
27 | index 55c52b41..b85d0101 100644 | ||
25 | --- a/src/lib/src/Makefile.am | 28 | --- a/src/lib/src/Makefile.am |
26 | +++ b/src/lib/src/Makefile.am | 29 | +++ b/src/lib/src/Makefile.am |
27 | @@ -25,7 +25,7 @@ AM_CPPFLAGS = \ | 30 | @@ -25,7 +25,7 @@ AM_CPPFLAGS = \ |
@@ -33,6 +36,8 @@ Upstream-Status: Pending | |||
33 | -Wno-address-of-packed-member | 36 | -Wno-address-of-packed-member |
34 | 37 | ||
35 | pkglib_LTLIBRARIES = libfwts.la | 38 | pkglib_LTLIBRARIES = libfwts.la |
39 | diff --git a/src/utilities/Makefile.am b/src/utilities/Makefile.am | ||
40 | index ecc25f0a..129c1036 100644 | ||
36 | --- a/src/utilities/Makefile.am | 41 | --- a/src/utilities/Makefile.am |
37 | +++ b/src/utilities/Makefile.am | 42 | +++ b/src/utilities/Makefile.am |
38 | @@ -16,7 +16,7 @@ | 43 | @@ -16,7 +16,7 @@ |
@@ -42,5 +47,8 @@ Upstream-Status: Pending | |||
42 | -AM_CPPFLAGS = -Wall -Werror -Wextra -DDATAROOTDIR=\"$(datarootdir)\" \ | 47 | -AM_CPPFLAGS = -Wall -Werror -Wextra -DDATAROOTDIR=\"$(datarootdir)\" \ |
43 | +AM_CPPFLAGS = -Wall -Wextra -DDATAROOTDIR=\"$(datarootdir)\" \ | 48 | +AM_CPPFLAGS = -Wall -Wextra -DDATAROOTDIR=\"$(datarootdir)\" \ |
44 | `pkg-config --silence-errors --cflags json` \ | 49 | `pkg-config --silence-errors --cflags json` \ |
45 | `pkg-config --silence-errors --cflags json-c` | 50 | `pkg-config --silence-errors --cflags json-c` \ |
46 | 51 | -I../lib/include | |
52 | -- | ||
53 | 2.25.1 | ||
54 | |||
diff --git a/meta-oe/recipes-test/fwts/fwts/0002-Define-__SWORD_TYPE-if-not-defined-by-libc.patch b/meta-oe/recipes-test/fwts/fwts/0004-Define-__SWORD_TYPE-if-not-defined-by-libc.patch index b45e46a3d..83d1cbbfe 100644 --- a/meta-oe/recipes-test/fwts/fwts/0002-Define-__SWORD_TYPE-if-not-defined-by-libc.patch +++ b/meta-oe/recipes-test/fwts/fwts/0004-Define-__SWORD_TYPE-if-not-defined-by-libc.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 1112e51d240a206bdcf253878ef1f4963b92da8a Mon Sep 17 00:00:00 2001 | 1 | From 9456f2f779d3ed4a134d55571d8bec78ad3b28c1 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Tue, 6 Jun 2017 07:37:20 -0700 | 3 | Date: Tue, 6 Jun 2017 07:37:20 -0700 |
4 | Subject: [PATCH] Define __SWORD_TYPE if not defined by libc | 4 | Subject: [PATCH 4/6] Define __SWORD_TYPE if not defined by libc |
5 | 5 | ||
6 | __SWORD_TYPE is internal to glibc, therefore | 6 | __SWORD_TYPE is internal to glibc, therefore |
7 | check and define it if needed e.g. on musl | 7 | check and define it if needed e.g. on musl |
@@ -9,16 +9,15 @@ check and define it if needed e.g. on musl | |||
9 | Upstream-Status: Pending | 9 | Upstream-Status: Pending |
10 | 10 | ||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
12 | |||
13 | --- | 12 | --- |
14 | src/lib/src/fwts_uefi.c | 4 ++++ | 13 | src/lib/src/fwts_uefi.c | 4 ++++ |
15 | 1 file changed, 4 insertions(+) | 14 | 1 file changed, 4 insertions(+) |
16 | 15 | ||
17 | diff --git a/src/lib/src/fwts_uefi.c b/src/lib/src/fwts_uefi.c | 16 | diff --git a/src/lib/src/fwts_uefi.c b/src/lib/src/fwts_uefi.c |
18 | index 544145fa..460b0b77 100644 | 17 | index 138f1164..13d9e36c 100644 |
19 | --- a/src/lib/src/fwts_uefi.c | 18 | --- a/src/lib/src/fwts_uefi.c |
20 | +++ b/src/lib/src/fwts_uefi.c | 19 | +++ b/src/lib/src/fwts_uefi.c |
21 | @@ -59,6 +59,10 @@ typedef struct { | 20 | @@ -63,6 +63,10 @@ typedef struct { |
22 | #define UEFI_IFACE_SYSFS (2) /* sysfs */ | 21 | #define UEFI_IFACE_SYSFS (2) /* sysfs */ |
23 | #define UEFI_IFACE_EFIVARS (3) /* efivar fs */ | 22 | #define UEFI_IFACE_EFIVARS (3) /* efivar fs */ |
24 | 23 | ||
@@ -29,3 +28,6 @@ index 544145fa..460b0b77 100644 | |||
29 | /* File system magic numbers */ | 28 | /* File system magic numbers */ |
30 | #define PSTOREFS_MAGIC ((__SWORD_TYPE)0x6165676C) | 29 | #define PSTOREFS_MAGIC ((__SWORD_TYPE)0x6165676C) |
31 | #define EFIVARFS_MAGIC ((__SWORD_TYPE)0xde5e81e4) | 30 | #define EFIVARFS_MAGIC ((__SWORD_TYPE)0xde5e81e4) |
31 | -- | ||
32 | 2.25.1 | ||
33 | |||
diff --git a/meta-oe/recipes-test/fwts/fwts/0003-Undefine-PAGE_SIZE.patch b/meta-oe/recipes-test/fwts/fwts/0005-Undefine-PAGE_SIZE.patch index 1d8c620ef..319e0855c 100644 --- a/meta-oe/recipes-test/fwts/fwts/0003-Undefine-PAGE_SIZE.patch +++ b/meta-oe/recipes-test/fwts/fwts/0005-Undefine-PAGE_SIZE.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 244e9551ab9bbc1dfa91d19cd472ef254a94ae41 Mon Sep 17 00:00:00 2001 | 1 | From 53b9f97fb7faed043134f2ab738347b20379d32f Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Tue, 6 Jun 2017 07:39:28 -0700 | 3 | Date: Tue, 6 Jun 2017 07:39:28 -0700 |
4 | Subject: [PATCH] Undefine PAGE_SIZE | 4 | Subject: [PATCH 5/6] Undefine PAGE_SIZE |
5 | 5 | ||
6 | musl defines PAGE_SIZE and build complains | 6 | musl defines PAGE_SIZE and build complains |
7 | of multiple definitions | 7 | of multiple definitions |
@@ -9,13 +9,12 @@ of multiple definitions | |||
9 | Upstream-Status: Pending | 9 | Upstream-Status: Pending |
10 | 10 | ||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
12 | |||
13 | --- | 12 | --- |
14 | src/lib/src/fwts_acpi_tables.c | 1 + | 13 | src/lib/src/fwts_acpi_tables.c | 1 + |
15 | 1 file changed, 1 insertion(+) | 14 | 1 file changed, 1 insertion(+) |
16 | 15 | ||
17 | diff --git a/src/lib/src/fwts_acpi_tables.c b/src/lib/src/fwts_acpi_tables.c | 16 | diff --git a/src/lib/src/fwts_acpi_tables.c b/src/lib/src/fwts_acpi_tables.c |
18 | index bdd224aa..58e982a6 100644 | 17 | index dc42a8bd..4fa1246a 100644 |
19 | --- a/src/lib/src/fwts_acpi_tables.c | 18 | --- a/src/lib/src/fwts_acpi_tables.c |
20 | +++ b/src/lib/src/fwts_acpi_tables.c | 19 | +++ b/src/lib/src/fwts_acpi_tables.c |
21 | @@ -42,6 +42,7 @@ | 20 | @@ -42,6 +42,7 @@ |
@@ -26,3 +25,6 @@ index bdd224aa..58e982a6 100644 | |||
26 | #define PAGE_SIZE (4096) | 25 | #define PAGE_SIZE (4096) |
27 | 26 | ||
28 | static fwts_acpi_table_info tables[ACPI_MAX_TABLES]; | 27 | static fwts_acpi_table_info tables[ACPI_MAX_TABLES]; |
28 | -- | ||
29 | 2.25.1 | ||
30 | |||
diff --git a/meta-oe/recipes-test/fwts/fwts/0003-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch b/meta-oe/recipes-test/fwts/fwts/0006-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch index bebbfa4ad..eb8b0b78e 100644 --- a/meta-oe/recipes-test/fwts/fwts/0003-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch +++ b/meta-oe/recipes-test/fwts/fwts/0006-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch | |||
@@ -1,25 +1,24 @@ | |||
1 | From 1848b8f8b9be500046ca5d632789a068d6151815 Mon Sep 17 00:00:00 2001 | 1 | From f723458eb649a9ad1d5d0e3dd6e801b284680fa7 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Thu, 8 Jun 2017 16:50:59 -0700 | 3 | Date: Thu, 8 Jun 2017 16:50:59 -0700 |
4 | Subject: [PATCH] use intptr_t to fix pointer-to-int-cast issues | 4 | Subject: [PATCH 6/6] use intptr_t to fix pointer-to-int-cast issues |
5 | 5 | ||
6 | uintptr_t is guaranteed to be wide enough that | 6 | uintptr_t is guaranteed to be wide enough that |
7 | converting a void* to uintptr_t and back again | 7 | converting a void* to uintptr_t and back again |
8 | will yield the original pointer value | 8 | will yield the original pointer value |
9 | 9 | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
11 | |||
12 | --- | 11 | --- |
13 | src/lib/src/fwts_acpi_tables.c | 4 ++-- | 12 | src/lib/src/fwts_acpi_tables.c | 4 ++-- |
14 | src/lib/src/fwts_mmap.c | 2 +- | 13 | src/lib/src/fwts_mmap.c | 2 +- |
15 | src/lib/src/fwts_smbios.c | 4 ++-- | 14 | src/lib/src/fwts_smbios.c | 2 +- |
16 | 3 files changed, 5 insertions(+), 5 deletions(-) | 15 | 3 files changed, 4 insertions(+), 4 deletions(-) |
17 | 16 | ||
18 | diff --git a/src/lib/src/fwts_acpi_tables.c b/src/lib/src/fwts_acpi_tables.c | 17 | diff --git a/src/lib/src/fwts_acpi_tables.c b/src/lib/src/fwts_acpi_tables.c |
19 | index 58e982a6..6522032f 100644 | 18 | index 4fa1246a..7ef197cd 100644 |
20 | --- a/src/lib/src/fwts_acpi_tables.c | 19 | --- a/src/lib/src/fwts_acpi_tables.c |
21 | +++ b/src/lib/src/fwts_acpi_tables.c | 20 | +++ b/src/lib/src/fwts_acpi_tables.c |
22 | @@ -156,7 +156,7 @@ static fwts_acpi_table_rsdp *fwts_acpi_get_rsdp(fwts_framework *fw, void *addr, | 21 | @@ -173,7 +173,7 @@ static fwts_acpi_table_rsdp *fwts_acpi_get_rsdp(fwts_framework *fw, void *addr, |
23 | return NULL; | 22 | return NULL; |
24 | } | 23 | } |
25 | 24 | ||
@@ -28,7 +27,7 @@ index 58e982a6..6522032f 100644 | |||
28 | return NULL; | 27 | return NULL; |
29 | 28 | ||
30 | if (fwts_safe_memcpy(rsdp, mem, sizeof(fwts_acpi_table_rsdp)) != FWTS_OK) { | 29 | if (fwts_safe_memcpy(rsdp, mem, sizeof(fwts_acpi_table_rsdp)) != FWTS_OK) { |
31 | @@ -455,7 +455,7 @@ static int fwts_acpi_load_tables_from_firmware(fwts_framework *fw) | 30 | @@ -486,7 +486,7 @@ static int fwts_acpi_load_tables_from_firmware(fwts_framework *fw) |
32 | if ((rsdp = fwts_acpi_get_rsdp(fw, rsdp_addr, &rsdp_len)) == NULL) | 31 | if ((rsdp = fwts_acpi_get_rsdp(fw, rsdp_addr, &rsdp_len)) == NULL) |
33 | return FWTS_ERROR; | 32 | return FWTS_ERROR; |
34 | 33 | ||
@@ -38,10 +37,10 @@ index 58e982a6..6522032f 100644 | |||
38 | /* Load any tables from XSDT if it's valid */ | 37 | /* Load any tables from XSDT if it's valid */ |
39 | if (rsdp->xsdt_address) { | 38 | if (rsdp->xsdt_address) { |
40 | diff --git a/src/lib/src/fwts_mmap.c b/src/lib/src/fwts_mmap.c | 39 | diff --git a/src/lib/src/fwts_mmap.c b/src/lib/src/fwts_mmap.c |
41 | index e28abf87..2180b2cc 100644 | 40 | index 2f2514f1..fbd946f4 100644 |
42 | --- a/src/lib/src/fwts_mmap.c | 41 | --- a/src/lib/src/fwts_mmap.c |
43 | +++ b/src/lib/src/fwts_mmap.c | 42 | +++ b/src/lib/src/fwts_mmap.c |
44 | @@ -81,7 +81,7 @@ int fwts_munmap(void *mem, const size_t size) | 43 | @@ -82,7 +82,7 @@ int fwts_munmap(void *mem, const size_t size) |
45 | off_t offset; | 44 | off_t offset; |
46 | 45 | ||
47 | page_size = fwts_page_size(); | 46 | page_size = fwts_page_size(); |
@@ -51,24 +50,18 @@ index e28abf87..2180b2cc 100644 | |||
51 | if (munmap((void *)((uint8_t *)mem - offset), size + offset) < 0) | 50 | if (munmap((void *)((uint8_t *)mem - offset), size + offset) < 0) |
52 | return FWTS_ERROR; | 51 | return FWTS_ERROR; |
53 | diff --git a/src/lib/src/fwts_smbios.c b/src/lib/src/fwts_smbios.c | 52 | diff --git a/src/lib/src/fwts_smbios.c b/src/lib/src/fwts_smbios.c |
54 | index e5b3c774..c8134926 100644 | 53 | index 8da572e9..04315bd3 100644 |
55 | --- a/src/lib/src/fwts_smbios.c | 54 | --- a/src/lib/src/fwts_smbios.c |
56 | +++ b/src/lib/src/fwts_smbios.c | 55 | +++ b/src/lib/src/fwts_smbios.c |
57 | @@ -55,7 +55,7 @@ static void *fwts_smbios_find_entry_uefi(fwts_framework *fw, fwts_smbios_entry * | 56 | @@ -78,7 +78,7 @@ static void *fwts_smbios_find_entry_uefi( |
57 | if ((addr = fwts_scan_efi_systab(smbios)) != NULL) { | ||
58 | fwts_smbios_entry *mapped_entry; | 58 | fwts_smbios_entry *mapped_entry; |
59 | const size_t size = sizeof(fwts_smbios_entry); | ||
60 | 59 | ||
61 | - if ((mapped_entry = fwts_mmap((off_t)addr, size)) != FWTS_MAP_FAILED) { | 60 | - if ((mapped_entry = fwts_mmap((off_t)addr, size)) != FWTS_MAP_FAILED) { |
62 | + if ((mapped_entry = fwts_mmap((uintptr_t)addr, size)) != FWTS_MAP_FAILED) { | 61 | + if ((mapped_entry = fwts_mmap((uintptr_t)addr, size)) != FWTS_MAP_FAILED) { |
63 | if (fwts_safe_memcpy(entry, mapped_entry, size) == FWTS_OK) { | 62 | if (fwts_safe_memcpy(entry, mapped_entry, size) == FWTS_OK) { |
64 | (void)fwts_munmap(mapped_entry, size); | 63 | (void)fwts_munmap(mapped_entry, size); |
65 | *type = FWTS_SMBIOS; | 64 | *type = FWTS_SMBIOS; |
66 | @@ -91,7 +91,7 @@ static void *fwts_smbios30_find_entry_uefi(fwts_framework *fw, fwts_smbios30_ent | 65 | -- |
67 | fwts_smbios30_entry *mapped_entry; | 66 | 2.25.1 |
68 | const size_t size = sizeof(fwts_smbios30_entry); | 67 | |
69 | |||
70 | - if ((mapped_entry = fwts_mmap((off_t)addr, size)) != FWTS_MAP_FAILED) { | ||
71 | + if ((mapped_entry = fwts_mmap((uintptr_t)addr, size)) != FWTS_MAP_FAILED) { | ||
72 | if (fwts_safe_memread(mapped_entry, size) == FWTS_OK) { | ||
73 | *entry = *mapped_entry; | ||
74 | (void)fwts_munmap(mapped_entry, size); | ||
diff --git a/meta-oe/recipes-test/fwts/fwts_20.07.00.bb b/meta-oe/recipes-test/fwts/fwts_21.03.00.bb index 28565eb8c..aa7d422f7 100644 --- a/meta-oe/recipes-test/fwts/fwts_20.07.00.bb +++ b/meta-oe/recipes-test/fwts/fwts_21.03.00.bb | |||
@@ -6,27 +6,27 @@ LICENSE = "GPLv2+" | |||
6 | LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=31da590f3e9f3bd34dcdb9e4db568519" | 6 | LIC_FILES_CHKSUM = "file://src/main.c;beginline=1;endline=16;md5=31da590f3e9f3bd34dcdb9e4db568519" |
7 | 7 | ||
8 | SRC_URI = "http://fwts.ubuntu.com/release/fwts-V${PV}.tar.gz;subdir=${BP} \ | 8 | SRC_URI = "http://fwts.ubuntu.com/release/fwts-V${PV}.tar.gz;subdir=${BP} \ |
9 | file://0001-Include-poll.h-instead-of-deprecated-sys-poll.h.patch \ | ||
10 | file://0002-Define-__SWORD_TYPE-if-not-defined-by-libc.patch \ | ||
11 | file://0003-Undefine-PAGE_SIZE.patch \ | ||
12 | file://0001-Add-correct-printf-qualifier-for-off_t.patch \ | 9 | file://0001-Add-correct-printf-qualifier-for-off_t.patch \ |
13 | file://0003-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch \ | 10 | file://0002-Include-poll.h-instead-of-deprecated-sys-poll.h.patch \ |
14 | file://0001-Remove-Werror-from-build.patch \ | 11 | file://0003-Remove-Werror-from-build.patch \ |
12 | file://0004-Define-__SWORD_TYPE-if-not-defined-by-libc.patch \ | ||
13 | file://0005-Undefine-PAGE_SIZE.patch \ | ||
14 | file://0006-use-intptr_t-to-fix-pointer-to-int-cast-issues.patch \ | ||
15 | " | 15 | " |
16 | SRC_URI[sha256sum] = "4a8e0211b388efbcfcb6530297e9a924d0afa2d6db58e9db2f031129eda6d66f" | 16 | SRC_URI[sha256sum] = "c22dcba2572e4237bf2fe9ab579e195cf051d3a99b2c07ab58f757cae02d24fb" |
17 | 17 | ||
18 | COMPATIBLE_HOST = "(i.86|x86_64|aarch64|powerpc64).*-linux" | 18 | COMPATIBLE_HOST = "(i.86|x86_64|aarch64|powerpc64).*-linux" |
19 | 19 | ||
20 | DEPENDS = "libpcre json-c glib-2.0 dtc bison-native libbsd" | 20 | DEPENDS = "libpcre glib-2.0 dtc bison-native libbsd" |
21 | DEPENDS_append_libc-musl = " libexecinfo" | 21 | DEPENDS_append_libc-musl = " libexecinfo" |
22 | 22 | ||
23 | # Use brokensep for now (https://github.com/ColinIanKing/fwts/issues/2) | ||
23 | inherit autotools-brokensep bash-completion pkgconfig | 24 | inherit autotools-brokensep bash-completion pkgconfig |
24 | 25 | ||
25 | CFLAGS += "-I${STAGING_INCDIR}/json-c -Wno-error=unknown-pragmas" | ||
26 | LDFLAGS_append_libc-musl = " -lexecinfo" | 26 | LDFLAGS_append_libc-musl = " -lexecinfo" |
27 | 27 | ||
28 | FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}" | 28 | FILES_${PN} += "${libdir}/fwts/lib*${SOLIBS}" |
29 | FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la" | 29 | FILES_${PN}-dev += "${libdir}/fwts/lib*${SOLIBSDEV} ${libdir}/fwts/lib*.la" |
30 | FILES_${PN}-staticdev += "${libdir}/fwts/lib*a" | 30 | FILES_${PN}-staticdev += "${libdir}/fwts/lib*a" |
31 | FILES_${PN}-dbg += "${libdir}/fwts/.debug" | ||
32 | 31 | ||
32 | RDEPENDS_${PN} += "dtc" | ||