diff options
author | Peter Kjellerstedt <peter.kjellerstedt@axis.com> | 2019-02-12 22:25:12 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-02-12 15:47:12 -0800 |
commit | f372c8a480ca40b5dfef41eb0b38f83938e66eb1 (patch) | |
tree | 8fee16f672b5426bde3dfd2fb68b24f6f5af82fe /meta-oe/recipes-support | |
parent | c0a71bc2631988dbf7ed72ddf30c67440713ee47 (diff) | |
download | meta-openembedded-f372c8a480ca40b5dfef41eb0b38f83938e66eb1.tar.gz |
atop: Update to 2.4
* Replace remove-bashisms.patch with
0001-atop.daily-atop.init-atop-pm.sh-Avoid-using-bash.patch to avoid
a bashism in atop.init in addition to those already fixed.
* Remove 0001-add-sys-sysmacros.h-for-major-minor-macros.patch as it
is no longer needed.
* Update the remaining patches to avoid fuzz.
Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/atop/atop/0001-add-sys-sysmacros.h-for-major-minor-macros.patch | 26 | ||||
-rw-r--r-- | meta-oe/recipes-support/atop/atop/0001-atop.daily-atop.init-atop-pm.sh-Avoid-using-bash.patch | 67 | ||||
-rw-r--r-- | meta-oe/recipes-support/atop/atop/fix-permissions.patch | 29 | ||||
-rw-r--r-- | meta-oe/recipes-support/atop/atop/remove-bashisms.patch | 33 | ||||
-rw-r--r-- | meta-oe/recipes-support/atop/atop/sysvinit-implement-status.patch | 11 | ||||
-rw-r--r-- | meta-oe/recipes-support/atop/atop_2.4.0.bb (renamed from meta-oe/recipes-support/atop/atop_2.3.0.bb) | 9 |
6 files changed, 98 insertions, 77 deletions
diff --git a/meta-oe/recipes-support/atop/atop/0001-add-sys-sysmacros.h-for-major-minor-macros.patch b/meta-oe/recipes-support/atop/atop/0001-add-sys-sysmacros.h-for-major-minor-macros.patch deleted file mode 100644 index 564606197..000000000 --- a/meta-oe/recipes-support/atop/atop/0001-add-sys-sysmacros.h-for-major-minor-macros.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From 13f3771655f859d5e0332dd65b9c43f572f6359d Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 11 Aug 2018 16:02:06 -0700 | ||
4 | Subject: [PATCH] add sys/sysmacros.h for major/minor macros | ||
5 | |||
6 | photosyst.c:1465:19: error: called object 'major' is not a function or function pointer | ||
7 | dmp->major = major(statbuf.st_rdev); | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | photosyst.c | 1 + | ||
13 | 1 file changed, 1 insertion(+) | ||
14 | |||
15 | diff --git a/photosyst.c b/photosyst.c | ||
16 | index 38828ec..caed352 100644 | ||
17 | --- a/photosyst.c | ||
18 | +++ b/photosyst.c | ||
19 | @@ -152,6 +152,7 @@ | ||
20 | static const char rcsid[] = "$Id: photosyst.c,v 1.38 2010/11/19 07:40:40 gerlof Exp $"; | ||
21 | |||
22 | #include <sys/types.h> | ||
23 | +#include <sys/sysmacros.h> | ||
24 | #include <stdio.h> | ||
25 | #include <string.h> | ||
26 | #include <unistd.h> | ||
diff --git a/meta-oe/recipes-support/atop/atop/0001-atop.daily-atop.init-atop-pm.sh-Avoid-using-bash.patch b/meta-oe/recipes-support/atop/atop/0001-atop.daily-atop.init-atop-pm.sh-Avoid-using-bash.patch new file mode 100644 index 000000000..facb257be --- /dev/null +++ b/meta-oe/recipes-support/atop/atop/0001-atop.daily-atop.init-atop-pm.sh-Avoid-using-bash.patch | |||
@@ -0,0 +1,67 @@ | |||
1 | From ffc8ba8d324243a923abe48e9758adecb03d24a4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Peter Kjellerstedt <pkj@axis.com> | ||
3 | Date: Tue, 12 Feb 2019 21:25:23 +0100 | ||
4 | Subject: [PATCH] atop.daily, atop.init, atop-pm.sh: Avoid using bash | ||
5 | |||
6 | Avoid using bash and bashisms when not necesary. On some systems, | ||
7 | e.g., embedded products, bash may not be available by default. | ||
8 | |||
9 | Upstream-Status: Submitted [https://github.com/Atoptool/atop/pull/50] | ||
10 | Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> | ||
11 | --- | ||
12 | atop-pm.sh | 2 +- | ||
13 | atop.daily | 4 ++-- | ||
14 | atop.init | 4 ++-- | ||
15 | 3 files changed, 5 insertions(+), 5 deletions(-) | ||
16 | |||
17 | diff --git a/atop-pm.sh b/atop-pm.sh | ||
18 | index 7f41a86..3ff4ab5 100755 | ||
19 | --- a/atop-pm.sh | ||
20 | +++ b/atop-pm.sh | ||
21 | @@ -1,4 +1,4 @@ | ||
22 | -#!/bin/bash | ||
23 | +#!/bin/sh | ||
24 | |||
25 | case "$1" in | ||
26 | pre) /usr/bin/systemctl stop atop | ||
27 | diff --git a/atop.daily b/atop.daily | ||
28 | index 57a9507..fe5a11b 100755 | ||
29 | --- a/atop.daily | ||
30 | +++ b/atop.daily | ||
31 | @@ -1,4 +1,4 @@ | ||
32 | -#!/bin/bash | ||
33 | +#!/bin/sh | ||
34 | |||
35 | LOGOPTS="-R" # default options | ||
36 | LOGINTERVAL=600 # default interval in seconds | ||
37 | @@ -38,7 +38,7 @@ then | ||
38 | |||
39 | while ps -p `cat "$PIDFILE"` > /dev/null | ||
40 | do | ||
41 | - let CNT+=1 | ||
42 | + CNT=$((CNT + 1)) | ||
43 | |||
44 | if [ $CNT -gt 5 ] | ||
45 | then | ||
46 | diff --git a/atop.init b/atop.init | ||
47 | index e6e11dc..03c3f02 100755 | ||
48 | --- a/atop.init | ||
49 | +++ b/atop.init | ||
50 | @@ -1,4 +1,4 @@ | ||
51 | -#!/bin/bash | ||
52 | +#!/bin/sh | ||
53 | # | ||
54 | # atop Startup script for the Atop process logging in background | ||
55 | # | ||
56 | @@ -47,7 +47,7 @@ case "$1" in | ||
57 | |||
58 | while ps -p `cat $PIDFILE` > /dev/null | ||
59 | do | ||
60 | - let CNT+=1 | ||
61 | + CNT=$((CNT + 1)) | ||
62 | |||
63 | if [ $CNT -gt 5 ] | ||
64 | then | ||
65 | -- | ||
66 | 2.12.0 | ||
67 | |||
diff --git a/meta-oe/recipes-support/atop/atop/fix-permissions.patch b/meta-oe/recipes-support/atop/atop/fix-permissions.patch index ee7419993..8488b3800 100644 --- a/meta-oe/recipes-support/atop/atop/fix-permissions.patch +++ b/meta-oe/recipes-support/atop/atop/fix-permissions.patch | |||
@@ -1,15 +1,22 @@ | |||
1 | Update permissions of executable files that remove setuid bit and make everyone | 1 | From d9498d10d0e8241749835dbc9fa229465d4fdfd7 Mon Sep 17 00:00:00 2001 |
2 | could read. | 2 | From: Kai Kang <kai.kang@windriver.com> |
3 | Date: Wed, 6 Feb 2019 13:58:04 +0000 | ||
4 | Subject: [PATCH] Fix permissions | ||
3 | 5 | ||
4 | Upstream-Status: Inappropriate [embedded specific] | 6 | Update permissions of executable files that remove setuid bit and make |
7 | everyone could read. | ||
5 | 8 | ||
9 | Upstream-Status: Inappropriate [embedded specific] | ||
6 | Signed-off-by: Kai Kang <kai.kang@windriver.com> | 10 | Signed-off-by: Kai Kang <kai.kang@windriver.com> |
7 | --- | 11 | --- |
12 | Makefile | 10 +++++----- | ||
13 | 1 file changed, 5 insertions(+), 5 deletions(-) | ||
14 | |||
8 | diff --git a/Makefile b/Makefile | 15 | diff --git a/Makefile b/Makefile |
9 | index a65b9b6..21d9828 100644 | 16 | index 3bf5929..1221ee4 100644 |
10 | --- a/Makefile | 17 | --- a/Makefile |
11 | +++ b/Makefile | 18 | +++ b/Makefile |
12 | @@ -66,7 +66,7 @@ systemdinstall: genericinstall | 19 | @@ -72,7 +72,7 @@ systemdinstall: genericinstall |
13 | chmod 0644 $(DESTDIR)$(SYSDPATH)/atopacct.service | 20 | chmod 0644 $(DESTDIR)$(SYSDPATH)/atopacct.service |
14 | cp atop.cronsystemd $(DESTDIR)$(CRNPATH)/atop | 21 | cp atop.cronsystemd $(DESTDIR)$(CRNPATH)/atop |
15 | cp atop-pm.sh $(DESTDIR)$(PMPATHD) | 22 | cp atop-pm.sh $(DESTDIR)$(PMPATHD) |
@@ -18,7 +25,7 @@ index a65b9b6..21d9828 100644 | |||
18 | # | 25 | # |
19 | # only when making on target system: | 26 | # only when making on target system: |
20 | # | 27 | # |
21 | @@ -91,11 +91,11 @@ sysvinstall: genericinstall | 28 | @@ -97,11 +97,11 @@ sysvinstall: genericinstall |
22 | # | 29 | # |
23 | if [ -d $(DESTDIR)$(PMPATH1) ]; \ | 30 | if [ -d $(DESTDIR)$(PMPATH1) ]; \ |
24 | then cp 45atoppm $(DESTDIR)$(PMPATH1); \ | 31 | then cp 45atoppm $(DESTDIR)$(PMPATH1); \ |
@@ -32,7 +39,7 @@ index a65b9b6..21d9828 100644 | |||
32 | fi | 39 | fi |
33 | # | 40 | # |
34 | # | 41 | # |
35 | @@ -139,7 +139,7 @@ genericinstall: atop atopacctd | 42 | @@ -145,7 +145,7 @@ genericinstall: atop atopacctd atopconvert |
36 | # | 43 | # |
37 | cp atop $(DESTDIR)$(BINPATH)/atop | 44 | cp atop $(DESTDIR)$(BINPATH)/atop |
38 | chown root $(DESTDIR)$(BINPATH)/atop | 45 | chown root $(DESTDIR)$(BINPATH)/atop |
@@ -41,12 +48,12 @@ index a65b9b6..21d9828 100644 | |||
41 | ln -sf atop $(DESTDIR)$(BINPATH)/atopsar | 48 | ln -sf atop $(DESTDIR)$(BINPATH)/atopsar |
42 | cp atopacctd $(DESTDIR)$(SBINPATH)/atopacctd | 49 | cp atopacctd $(DESTDIR)$(SBINPATH)/atopacctd |
43 | chown root $(DESTDIR)$(SBINPATH)/atopacctd | 50 | chown root $(DESTDIR)$(SBINPATH)/atopacctd |
44 | @@ -147,7 +147,7 @@ genericinstall: atop atopacctd | 51 | @@ -159,7 +159,7 @@ genericinstall: atop atopacctd atopconvert |
45 | cp atop $(DESTDIR)$(BINPATH)/atop-$(VERS) | 52 | chown root $(DESTDIR)$(BINPATH)/atopconvert |
46 | ln -sf atop-$(VERS) $(DESTDIR)$(BINPATH)/atopsar-$(VERS) | 53 | chmod 0711 $(DESTDIR)$(BINPATH)/atopconvert |
47 | cp atop.daily $(DESTDIR)$(SCRPATH) | 54 | cp atop.daily $(DESTDIR)$(SCRPATH) |
48 | - chmod 0711 $(DESTDIR)$(SCRPATH)/atop.daily | 55 | - chmod 0711 $(DESTDIR)$(SCRPATH)/atop.daily |
49 | + chmod 0755 $(DESTDIR)$(SCRPATH)/atop.daily | 56 | + chmod 0755 $(DESTDIR)$(SCRPATH)/atop.daily |
50 | cp man/atop.1 $(DESTDIR)$(MAN1PATH) | 57 | cp man/atop.1 $(DESTDIR)$(MAN1PATH) |
51 | cp man/atopsar.1 $(DESTDIR)$(MAN1PATH) | 58 | cp man/atopsar.1 $(DESTDIR)$(MAN1PATH) |
52 | cp man/atoprc.5 $(DESTDIR)$(MAN5PATH) | 59 | cp man/atopconvert.1 $(DESTDIR)$(MAN1PATH) |
diff --git a/meta-oe/recipes-support/atop/atop/remove-bashisms.patch b/meta-oe/recipes-support/atop/atop/remove-bashisms.patch deleted file mode 100644 index f1fcbfed7..000000000 --- a/meta-oe/recipes-support/atop/atop/remove-bashisms.patch +++ /dev/null | |||
@@ -1,33 +0,0 @@ | |||
1 | Upstream-Status: Inappropriate [embedded specific] | ||
2 | |||
3 | Signed-off-by: Kai Kang <kai.kang@windriver.com> | ||
4 | --- | ||
5 | diff --git a/atop-pm.sh b/atop-pm.sh | ||
6 | index 7f41a86..3ff4ab5 100755 | ||
7 | --- a/atop-pm.sh | ||
8 | +++ b/atop-pm.sh | ||
9 | @@ -1,4 +1,4 @@ | ||
10 | -#!/bin/bash | ||
11 | +#!/bin/sh | ||
12 | |||
13 | case "$1" in | ||
14 | pre) /usr/bin/systemctl stop atop | ||
15 | diff --git a/atop.daily b/atop.daily | ||
16 | index 24d33bd..f29bd94 100755 | ||
17 | --- a/atop.daily | ||
18 | +++ b/atop.daily | ||
19 | @@ -1,4 +1,4 @@ | ||
20 | -#!/bin/bash | ||
21 | +#!/bin/sh | ||
22 | |||
23 | CURDAY=`date +%Y%m%d` | ||
24 | LOGPATH=/var/log/atop | ||
25 | @@ -16,7 +16,7 @@ then | ||
26 | |||
27 | while ps -p `cat $PIDFILE` > /dev/null | ||
28 | do | ||
29 | - let CNT+=1 | ||
30 | + CNT=$((CNT+1)) | ||
31 | |||
32 | if [ $CNT -gt 5 ] | ||
33 | then | ||
diff --git a/meta-oe/recipes-support/atop/atop/sysvinit-implement-status.patch b/meta-oe/recipes-support/atop/atop/sysvinit-implement-status.patch index 5994d3e08..1145a2493 100644 --- a/meta-oe/recipes-support/atop/atop/sysvinit-implement-status.patch +++ b/meta-oe/recipes-support/atop/atop/sysvinit-implement-status.patch | |||
@@ -1,11 +1,18 @@ | |||
1 | From bdd068873ed0979027c21773939bdb18046a8756 Mon Sep 17 00:00:00 2001 | ||
2 | From: Kai Kang <kai.kang@windriver.com> | ||
3 | Date: Wed, 6 Feb 2019 13:58:04 +0000 | ||
4 | Subject: [PATCH] sysvinit: Implement status | ||
5 | |||
1 | Implement the sub-command status. | 6 | Implement the sub-command status. |
2 | 7 | ||
3 | Upstream-Status: Pending | 8 | Upstream-Status: Pending |
4 | |||
5 | Signed-off-by: Kai Kang <kai.kang@windriver.com> | 9 | Signed-off-by: Kai Kang <kai.kang@windriver.com> |
6 | --- | 10 | --- |
11 | atop.init | 3 +++ | ||
12 | 1 file changed, 3 insertions(+) | ||
13 | |||
7 | diff --git a/atop.init b/atop.init | 14 | diff --git a/atop.init b/atop.init |
8 | index 108bdc5..9f89fad 100755 | 15 | index e6e11dc..e7b226d 100755 |
9 | --- a/atop.init | 16 | --- a/atop.init |
10 | +++ b/atop.init | 17 | +++ b/atop.init |
11 | @@ -18,6 +18,8 @@ | 18 | @@ -18,6 +18,8 @@ |
diff --git a/meta-oe/recipes-support/atop/atop_2.3.0.bb b/meta-oe/recipes-support/atop/atop_2.4.0.bb index 302813c2e..5bde96519 100644 --- a/meta-oe/recipes-support/atop/atop_2.3.0.bb +++ b/meta-oe/recipes-support/atop/atop_2.4.0.bb | |||
@@ -17,13 +17,12 @@ DEPENDS = "ncurses zlib" | |||
17 | 17 | ||
18 | SRC_URI = "http://www.atoptool.nl/download/${BP}.tar.gz \ | 18 | SRC_URI = "http://www.atoptool.nl/download/${BP}.tar.gz \ |
19 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'file://volatiles.atop.conf', 'file://volatiles.99_atop', d)} \ | 19 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'file://volatiles.atop.conf', 'file://volatiles.99_atop', d)} \ |
20 | file://remove-bashisms.patch \ | ||
21 | file://fix-permissions.patch \ | 20 | file://fix-permissions.patch \ |
22 | file://sysvinit-implement-status.patch \ | 21 | file://sysvinit-implement-status.patch \ |
23 | file://0001-add-sys-sysmacros.h-for-major-minor-macros.patch \ | 22 | file://0001-atop.daily-atop.init-atop-pm.sh-Avoid-using-bash.patch \ |
24 | " | 23 | " |
25 | SRC_URI[md5sum] = "48e1dbef8c7d826e68829a8d5fc920fc" | 24 | SRC_URI[md5sum] = "1077da884ed94f2bc3c81ac3ab970436" |
26 | SRC_URI[sha256sum] = "73e4725de0bafac8c63b032e8479e2305e3962afbe977ec1abd45f9e104eb264" | 25 | SRC_URI[sha256sum] = "be1c010a77086b7d98376fce96514afcd73c3f20a8d1fe01520899ff69a73d69" |
27 | 26 | ||
28 | do_compile() { | 27 | do_compile() { |
29 | oe_runmake all | 28 | oe_runmake all |
@@ -49,7 +48,7 @@ do_install() { | |||
49 | 48 | ||
50 | inherit systemd | 49 | inherit systemd |
51 | 50 | ||
52 | SYSTEMD_SERVICE_${PN} = "atop.service" | 51 | SYSTEMD_SERVICE_${PN} = "atop.service atopgpu.service" |
53 | SYSTEMD_AUTO_ENABLE = "disable" | 52 | SYSTEMD_AUTO_ENABLE = "disable" |
54 | 53 | ||
55 | FILES_${PN} += "${systemd_unitdir}/system-sleep" | 54 | FILES_${PN} += "${systemd_unitdir}/system-sleep" |