diff options
author | Felipe F. Tonello <ftonello@cercacor.com> | 2013-03-01 18:25:56 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-03-13 17:21:52 +0100 |
commit | eca2937c7230440850f24816764abdcd460b6f51 (patch) | |
tree | 337f205a7f66fde2dfe9c77a9050637937b74ab3 /meta-oe/recipes-support | |
parent | a214c903e4037fad32abdee704b6f913f1f7d629 (diff) | |
download | meta-openembedded-eca2937c7230440850f24816764abdcd460b6f51.tar.gz |
gsoap: added gsoap 2.8.12 recipe
This recipe was inspired on the gsoap recipe in oe-classic.
Signed-off-by: Felipe F. Tonello <ftonello@cercacor.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/gsoap/gsoap-native_2.8.12.bb | 14 | ||||
-rw-r--r-- | meta-oe/recipes-support/gsoap/gsoap_2.8.12.bb | 17 | ||||
-rw-r--r-- | meta-oe/recipes-support/gsoap/gsoap_2.8.12.inc | 23 |
3 files changed, 54 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gsoap/gsoap-native_2.8.12.bb b/meta-oe/recipes-support/gsoap/gsoap-native_2.8.12.bb new file mode 100644 index 000000000..46fabbbb4 --- /dev/null +++ b/meta-oe/recipes-support/gsoap/gsoap-native_2.8.12.bb | |||
@@ -0,0 +1,14 @@ | |||
1 | require gsoap_${PV}.inc | ||
2 | |||
3 | DEPENDS = "" | ||
4 | EXTRA_OEMAKE = "" | ||
5 | |||
6 | inherit native | ||
7 | |||
8 | do_install() { | ||
9 | oe_runmake DESTDIR=${D} BINDIR=${D}${bindir} install | ||
10 | } | ||
11 | |||
12 | |||
13 | SRC_URI[md5sum] = "5700d26fc6fe3073d038349e19c3640d" | ||
14 | SRC_URI[sha256sum] = "51eef118544fa846f4d2dea2eedf91c84c46a1abeafc5eee3dcff783f4015a00" | ||
diff --git a/meta-oe/recipes-support/gsoap/gsoap_2.8.12.bb b/meta-oe/recipes-support/gsoap/gsoap_2.8.12.bb new file mode 100644 index 000000000..5db2e61e5 --- /dev/null +++ b/meta-oe/recipes-support/gsoap/gsoap_2.8.12.bb | |||
@@ -0,0 +1,17 @@ | |||
1 | require gsoap_${PV}.inc | ||
2 | |||
3 | DEPENDS = "gsoap-native openssl" | ||
4 | |||
5 | do_install_append() { | ||
6 | install -d ${D}${libdir} | ||
7 | for lib in libgsoapssl libgsoapssl++ libgsoap libgsoapck++ libgsoap++ libgsoapck | ||
8 | do | ||
9 | oe_libinstall -C gsoap $lib ${D}${libdir} | ||
10 | done | ||
11 | } | ||
12 | |||
13 | FILES_${PN} = "${bindir}/wsdl2h ${bindir}/soapcpp2" | ||
14 | FILES_${PN} += "${datadir}" | ||
15 | |||
16 | SRC_URI[md5sum] = "5700d26fc6fe3073d038349e19c3640d" | ||
17 | SRC_URI[sha256sum] = "51eef118544fa846f4d2dea2eedf91c84c46a1abeafc5eee3dcff783f4015a00" | ||
diff --git a/meta-oe/recipes-support/gsoap/gsoap_2.8.12.inc b/meta-oe/recipes-support/gsoap/gsoap_2.8.12.inc new file mode 100644 index 000000000..30cf9a6d4 --- /dev/null +++ b/meta-oe/recipes-support/gsoap/gsoap_2.8.12.inc | |||
@@ -0,0 +1,23 @@ | |||
1 | DESCRIPTION = "The gSOAP toolkit provides a unique SOAP-to-C/C++ language binding \ | ||
2 | for the development of SOAP Web Services and clients." | ||
3 | SECTION = "devel" | ||
4 | LICENSE = "GPLv2" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b338b08b1b61e028e0f399a4de25e58f" | ||
6 | |||
7 | SRC_URI = "${SOURCEFORGE_MIRROR}/gsoap2/gsoap_${PV}.zip \ | ||
8 | " | ||
9 | |||
10 | inherit autotools | ||
11 | |||
12 | PR = "r1" | ||
13 | |||
14 | S = "${WORKDIR}/gsoap-2.8" | ||
15 | |||
16 | FILES_${PN}-dev = "${includedir}" | ||
17 | RRECOMMENDS_${PN}-dev = "${PN}-staticdev" | ||
18 | |||
19 | FILES_${PN}-staticdev = "${libdir}" | ||
20 | |||
21 | PARALLEL_MAKE = "" | ||
22 | |||
23 | EXTRA_OEMAKE = "SOAP=${STAGING_BINDIR_NATIVE}/soapcpp2" | ||