summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-09-01 16:06:40 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-05 22:49:34 -0700
commite5b867e1a899f797f9b92ff19824dd4436e4559d (patch)
treee656957d3bbbb15ab728de796f7560d0c58dfbc8 /meta-oe/recipes-support
parent2922f01139ff47c8f4f2096f1def69f55cc79c32 (diff)
downloadmeta-openembedded-e5b867e1a899f797f9b92ff19824dd4436e4559d.tar.gz
raptor2: Match reutrn type from RAPTOR_ASSERT_OBJECT_POINTER_RETURN_VALUE
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/raptor2/files/0001-Match-reutrn-type-from-RAPTOR_ASSERT_OBJECT_POINTER_.patch47
-rw-r--r--meta-oe/recipes-support/raptor2/raptor2_2.0.15.bb1
2 files changed, 48 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/raptor2/files/0001-Match-reutrn-type-from-RAPTOR_ASSERT_OBJECT_POINTER_.patch b/meta-oe/recipes-support/raptor2/files/0001-Match-reutrn-type-from-RAPTOR_ASSERT_OBJECT_POINTER_.patch
new file mode 100644
index 000000000..4c1afb46e
--- /dev/null
+++ b/meta-oe/recipes-support/raptor2/files/0001-Match-reutrn-type-from-RAPTOR_ASSERT_OBJECT_POINTER_.patch
@@ -0,0 +1,47 @@
1From 97b5dcaa6b221eb403cc92e953225d38aee18f70 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 1 Sep 2022 14:48:39 -0700
4Subject: [PATCH] Match reutrn type from
5 RAPTOR_ASSERT_OBJECT_POINTER_RETURN_VALUE
6
7This ensures that integer type 0 is returned and not NULL
8Fixes
9raptor_serialize.c:243:66: error: incompatible pointer to integer conversion returning 'void *' from a function with result type 'int' [-Wint-conversion]
10 RAPTOR_ASSERT_OBJECT_POINTER_RETURN_VALUE(world, raptor_world, NULL);
11 ^~~~
12Upstream-Status: Pending
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 src/raptor_parse.c | 2 +-
16 src/raptor_serialize.c | 2 +-
17 2 files changed, 2 insertions(+), 2 deletions(-)
18
19diff --git a/src/raptor_parse.c b/src/raptor_parse.c
20index 26911f4..0091e1e 100644
21--- a/src/raptor_parse.c
22+++ b/src/raptor_parse.c
23@@ -257,7 +257,7 @@ raptor_world_get_parser_factory(raptor_world *world, const char *name)
24 int
25 raptor_world_get_parsers_count(raptor_world* world)
26 {
27- RAPTOR_ASSERT_OBJECT_POINTER_RETURN_VALUE(world, raptor_world, NULL);
28+ RAPTOR_ASSERT_OBJECT_POINTER_RETURN_VALUE(world, raptor_world, 0);
29
30 raptor_world_open(world);
31
32diff --git a/src/raptor_serialize.c b/src/raptor_serialize.c
33index a1f29d7..2bf4ab2 100644
34--- a/src/raptor_serialize.c
35+++ b/src/raptor_serialize.c
36@@ -240,7 +240,7 @@ raptor_get_serializer_factory(raptor_world* world, const char *name)
37 int
38 raptor_world_get_serializers_count(raptor_world* world)
39 {
40- RAPTOR_ASSERT_OBJECT_POINTER_RETURN_VALUE(world, raptor_world, NULL);
41+ RAPTOR_ASSERT_OBJECT_POINTER_RETURN_VALUE(world, raptor_world, 0);
42
43 raptor_world_open(world);
44
45--
462.37.3
47
diff --git a/meta-oe/recipes-support/raptor2/raptor2_2.0.15.bb b/meta-oe/recipes-support/raptor2/raptor2_2.0.15.bb
index 577c6ee00..22306a5c1 100644
--- a/meta-oe/recipes-support/raptor2/raptor2_2.0.15.bb
+++ b/meta-oe/recipes-support/raptor2/raptor2_2.0.15.bb
@@ -12,6 +12,7 @@ DEPENDS = "libxml2 libxslt curl yajl"
12SRC_URI = " \ 12SRC_URI = " \
13 http://download.librdf.org/source/${BPN}-${PV}.tar.gz \ 13 http://download.librdf.org/source/${BPN}-${PV}.tar.gz \
14 file://0001-configure.ac-do-additional-checks-on-libxml2-also-wh.patch \ 14 file://0001-configure.ac-do-additional-checks-on-libxml2-also-wh.patch \
15 file://0001-Match-reutrn-type-from-RAPTOR_ASSERT_OBJECT_POINTER_.patch \
15" 16"
16SRC_URI[md5sum] = "a39f6c07ddb20d7dd2ff1f95fa21e2cd" 17SRC_URI[md5sum] = "a39f6c07ddb20d7dd2ff1f95fa21e2cd"
17SRC_URI[sha256sum] = "ada7f0ba54787b33485d090d3d2680533520cd4426d2f7fb4782dd4a6a1480ed" 18SRC_URI[sha256sum] = "ada7f0ba54787b33485d090d3d2680533520cd4426d2f7fb4782dd4a6a1480ed"