diff options
author | Khem Raj <raj.khem@gmail.com> | 2011-07-02 00:36:11 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-07-01 19:35:53 +0200 |
commit | e4aef8aaae26d52530ca95394c395c6eca84168d (patch) | |
tree | c31a29620da0111eded40adbd1dbeceb4024434c /meta-oe/recipes-support | |
parent | 7e3451f4e7352cc2c48711170e6a1be7c15e973e (diff) | |
download | meta-openembedded-e4aef8aaae26d52530ca95394c395c6eca84168d.tar.gz |
cpufrequtils: Fix compilation on uclibc
We make nls optional
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/cpufrequtils/cpufrequtils-008/cpufrequtils-nls.patch | 81 | ||||
-rw-r--r-- | meta-oe/recipes-support/cpufrequtils/cpufrequtils_008.bb | 6 |
2 files changed, 86 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/cpufrequtils/cpufrequtils-008/cpufrequtils-nls.patch b/meta-oe/recipes-support/cpufrequtils/cpufrequtils-008/cpufrequtils-nls.patch new file mode 100644 index 000000000..cbc87194d --- /dev/null +++ b/meta-oe/recipes-support/cpufrequtils/cpufrequtils-008/cpufrequtils-nls.patch | |||
@@ -0,0 +1,81 @@ | |||
1 | make nls/gettext support optional | ||
2 | |||
3 | patch by Jos van der Ende <seraph@xs4all.nl> | ||
4 | |||
5 | http://bugs.gentoo.org/205576 | ||
6 | |||
7 | Index: git/Makefile | ||
8 | =================================================================== | ||
9 | --- git.orig/Makefile 2011-06-30 17:50:23.000000000 -0700 | ||
10 | +++ git/Makefile 2011-07-01 07:06:58.300033928 -0700 | ||
11 | @@ -121,6 +121,7 @@ | ||
12 | ifeq ($(strip $(NLS)),true) | ||
13 | INSTALL_NLS += install-gmo | ||
14 | COMPILE_NLS += update-gmo | ||
15 | + CFLAGDEF += -DNLS | ||
16 | endif | ||
17 | |||
18 | ifeq ($(strip $(CPUFRQ_BENCH)),true) | ||
19 | Index: git/utils/info.c | ||
20 | =================================================================== | ||
21 | --- git.orig/utils/info.c 2011-06-30 17:50:23.000000000 -0700 | ||
22 | +++ git/utils/info.c 2011-07-01 07:06:58.300033928 -0700 | ||
23 | @@ -10,7 +10,6 @@ | ||
24 | #include <errno.h> | ||
25 | #include <stdlib.h> | ||
26 | #include <string.h> | ||
27 | -#include <libintl.h> | ||
28 | #include <locale.h> | ||
29 | |||
30 | #include <getopt.h> | ||
31 | @@ -18,9 +17,18 @@ | ||
32 | #include "cpufreq.h" | ||
33 | |||
34 | |||
35 | +#ifdef NLS | ||
36 | +#include <libintl.h> | ||
37 | #define _(String) gettext (String) | ||
38 | #define gettext_noop(String) String | ||
39 | #define N_(String) gettext_noop (String) | ||
40 | +#else | ||
41 | +#define gettext_noop(String) String | ||
42 | +#define _(String) gettext_noop (String) | ||
43 | +#define gettext(String) gettext_noop (String) | ||
44 | +#define N_(String) gettext_noop (String) | ||
45 | +#define textdomain(String) | ||
46 | +#endif | ||
47 | |||
48 | #define LINE_LEN 10 | ||
49 | |||
50 | Index: git/utils/set.c | ||
51 | =================================================================== | ||
52 | --- git.orig/utils/set.c 2011-06-30 17:50:23.000000000 -0700 | ||
53 | +++ git/utils/set.c 2011-07-01 07:07:56.980119994 -0700 | ||
54 | @@ -12,16 +12,23 @@ | ||
55 | #include <limits.h> | ||
56 | #include <string.h> | ||
57 | #include <ctype.h> | ||
58 | -#include <libintl.h> | ||
59 | #include <locale.h> | ||
60 | |||
61 | #include <getopt.h> | ||
62 | |||
63 | #include "cpufreq.h" | ||
64 | - | ||
65 | -#define _(String) gettext(String) | ||
66 | +#ifdef NLS | ||
67 | +#include <libintl.h> | ||
68 | +#define _(String) gettext (String) | ||
69 | +#define gettext_noop(String) String | ||
70 | +#define N_(String) gettext_noop (String) | ||
71 | +#else | ||
72 | #define gettext_noop(String) String | ||
73 | -#define N_(String) gettext_noop(String) | ||
74 | +#define _(String) gettext_noop (String) | ||
75 | +#define gettext(String) gettext_noop (String) | ||
76 | +#define N_(String) gettext_noop (String) | ||
77 | +#define textdomain(String) | ||
78 | +#endif | ||
79 | |||
80 | #define NORM_FREQ_LEN 32 | ||
81 | |||
diff --git a/meta-oe/recipes-support/cpufrequtils/cpufrequtils_008.bb b/meta-oe/recipes-support/cpufrequtils/cpufrequtils_008.bb index a28ab831b..d795e54d7 100644 --- a/meta-oe/recipes-support/cpufrequtils/cpufrequtils_008.bb +++ b/meta-oe/recipes-support/cpufrequtils/cpufrequtils_008.bb | |||
@@ -6,7 +6,11 @@ LICENSE = "GPLv2" | |||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
7 | 7 | ||
8 | SRCREV = "adb7e044755aa06b12212d05c4acbcccb023d2cd" | 8 | SRCREV = "adb7e044755aa06b12212d05c4acbcccb023d2cd" |
9 | SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/cpufreq/cpufrequtils.git" | 9 | SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/cpufreq/cpufrequtils.git \ |
10 | file://cpufrequtils-nls.patch \ | ||
11 | " | ||
12 | |||
13 | PR = "r1" | ||
10 | 14 | ||
11 | S = "${WORKDIR}/git" | 15 | S = "${WORKDIR}/git" |
12 | 16 | ||