diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-06-23 20:58:21 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-07-15 14:53:55 +0200 |
commit | d04099e94be6611ac1aca1cbeee14c4546a920bb (patch) | |
tree | 957aa43122d51438e1211f41c52ea9b81793bc0d /meta-oe/recipes-support | |
parent | 4bcd1d6b962212871d5ec8716848d5331e3641f6 (diff) | |
download | meta-openembedded-d04099e94be6611ac1aca1cbeee14c4546a920bb.tar.gz |
recipes: Add missing pkgconfig dependencies
These recipes were all missing pkgconfig dependencies.
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/ccid/ccid_1.4.8.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/cryptsetup/cryptsetup_1.6.2.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/liboauth/liboauth_1.0.3.bb | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/lvm2/lvm2.inc | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.6.bb | 2 |
5 files changed, 5 insertions, 5 deletions
diff --git a/meta-oe/recipes-support/ccid/ccid_1.4.8.bb b/meta-oe/recipes-support/ccid/ccid_1.4.8.bb index efaf72d26..14f88755f 100644 --- a/meta-oe/recipes-support/ccid/ccid_1.4.8.bb +++ b/meta-oe/recipes-support/ccid/ccid_1.4.8.bb | |||
@@ -10,7 +10,7 @@ SRC_URI = "https://alioth.debian.org/frs/download.php/file/3768/ccid-${PV}.tar.b | |||
10 | SRC_URI[md5sum] = "b6c37110f50b059a8ba94f118cfd679a" | 10 | SRC_URI[md5sum] = "b6c37110f50b059a8ba94f118cfd679a" |
11 | SRC_URI[sha256sum] = "7aca09fa4b9099e423402fd5df424adbafa502888710d1fda6015b6c1ff637ef" | 11 | SRC_URI[sha256sum] = "7aca09fa4b9099e423402fd5df424adbafa502888710d1fda6015b6c1ff637ef" |
12 | 12 | ||
13 | inherit autotools | 13 | inherit autotools pkgconfig |
14 | 14 | ||
15 | FILES_${PN} += "${libdir}/pcsc/" | 15 | FILES_${PN} += "${libdir}/pcsc/" |
16 | FILES_${PN}-dbg += "${libdir}/pcsc/drivers/*/*/*/.debug" | 16 | FILES_${PN}-dbg += "${libdir}/pcsc/drivers/*/*/*/.debug" |
diff --git a/meta-oe/recipes-support/cryptsetup/cryptsetup_1.6.2.bb b/meta-oe/recipes-support/cryptsetup/cryptsetup_1.6.2.bb index 6c3418a0c..500dc572c 100644 --- a/meta-oe/recipes-support/cryptsetup/cryptsetup_1.6.2.bb +++ b/meta-oe/recipes-support/cryptsetup/cryptsetup_1.6.2.bb | |||
@@ -15,7 +15,7 @@ SRC_URI = "http://cryptsetup.googlecode.com/files/cryptsetup-${PV}.tar.bz2" | |||
15 | SRC_URI[md5sum] = "cd834da49fbe92dd66df02cc5c61280f" | 15 | SRC_URI[md5sum] = "cd834da49fbe92dd66df02cc5c61280f" |
16 | SRC_URI[sha256sum] = "15723f0198303d4bcb99d480b7a773918e2d319f0348457988c063bdd03e109a" | 16 | SRC_URI[sha256sum] = "15723f0198303d4bcb99d480b7a773918e2d319f0348457988c063bdd03e109a" |
17 | 17 | ||
18 | inherit autotools gettext | 18 | inherit autotools gettext pkgconfig |
19 | 19 | ||
20 | # Use openssl because libgcrypt drops root privileges | 20 | # Use openssl because libgcrypt drops root privileges |
21 | # if libgcrypt is linked with libcap support | 21 | # if libgcrypt is linked with libcap support |
diff --git a/meta-oe/recipes-support/liboauth/liboauth_1.0.3.bb b/meta-oe/recipes-support/liboauth/liboauth_1.0.3.bb index 3aa574691..2535b8eb0 100644 --- a/meta-oe/recipes-support/liboauth/liboauth_1.0.3.bb +++ b/meta-oe/recipes-support/liboauth/liboauth_1.0.3.bb | |||
@@ -13,4 +13,4 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BP}.tar.gz" | |||
13 | SRC_URI[md5sum] = "689b46c2b3ab1a39735ac33f714c4f7f" | 13 | SRC_URI[md5sum] = "689b46c2b3ab1a39735ac33f714c4f7f" |
14 | SRC_URI[sha256sum] = "0df60157b052f0e774ade8a8bac59d6e8d4b464058cc55f9208d72e41156811f" | 14 | SRC_URI[sha256sum] = "0df60157b052f0e774ade8a8bac59d6e8d4b464058cc55f9208d72e41156811f" |
15 | 15 | ||
16 | inherit autotools | 16 | inherit autotools pkgconfig |
diff --git a/meta-oe/recipes-support/lvm2/lvm2.inc b/meta-oe/recipes-support/lvm2/lvm2.inc index 5f77fe627..1bbb158d8 100644 --- a/meta-oe/recipes-support/lvm2/lvm2.inc +++ b/meta-oe/recipes-support/lvm2/lvm2.inc | |||
@@ -35,7 +35,7 @@ PACKAGECONFIG += "${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', | |||
35 | 35 | ||
36 | PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux," | 36 | PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux," |
37 | 37 | ||
38 | inherit autotools | 38 | inherit autotools pkgconfig |
39 | 39 | ||
40 | do_install_append() { | 40 | do_install_append() { |
41 | # Install machine specific configuration file | 41 | # Install machine specific configuration file |
diff --git a/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.6.bb b/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.6.bb index 00a9635c3..5a58389ab 100644 --- a/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.6.bb +++ b/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.6.bb | |||
@@ -10,7 +10,7 @@ SRC_URI[sha256sum] = "1e44049168d1ce55fd56c175f61206955254df0f385455f2a20ec7e8a0 | |||
10 | 10 | ||
11 | PR = "r3" | 11 | PR = "r3" |
12 | 12 | ||
13 | inherit autotools systemd | 13 | inherit autotools systemd pkgconfig |
14 | 14 | ||
15 | EXTRA_OECONF = " \ | 15 | EXTRA_OECONF = " \ |
16 | --disable-libusb \ | 16 | --disable-libusb \ |