diff options
author | Samuel Stirtzel <s.stirtzel@googlemail.com> | 2013-04-04 08:18:47 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-04-09 21:34:15 +0200 |
commit | caeba74096bf72d9b0f41ddaa1d92cfb8ecfc1bd (patch) | |
tree | 7ca2e7f4e0803d3faa3ff2b9caf39df5d49cb930 /meta-oe/recipes-support | |
parent | c35842efb2bd9b6df13f58afea9f1a7c04d8d769 (diff) | |
download | meta-openembedded-caeba74096bf72d9b0f41ddaa1d92cfb8ecfc1bd.tar.gz |
maliit-framework: enable autostart
maliit-server will start via xdg autostart
Signed-off-by: Samuel Stirtzel <s.stirtzel@googlemail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/maliit/maliit-framework/maliit-server.desktop | 6 | ||||
-rw-r--r-- | meta-oe/recipes-support/maliit/maliit-framework_git.bb | 8 |
2 files changed, 13 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/maliit/maliit-framework/maliit-server.desktop b/meta-oe/recipes-support/maliit/maliit-framework/maliit-server.desktop new file mode 100644 index 000000000..24bdf9b52 --- /dev/null +++ b/meta-oe/recipes-support/maliit/maliit-framework/maliit-server.desktop | |||
@@ -0,0 +1,6 @@ | |||
1 | [Desktop Entry] | ||
2 | Name=Maliit server | ||
3 | Exec=/usr/bin/maliit-server | ||
4 | Icon= | ||
5 | Type=Application | ||
6 | Categories=Utility; | ||
diff --git a/meta-oe/recipes-support/maliit/maliit-framework_git.bb b/meta-oe/recipes-support/maliit/maliit-framework_git.bb index e61cca028..2c4b0f8e8 100644 --- a/meta-oe/recipes-support/maliit/maliit-framework_git.bb +++ b/meta-oe/recipes-support/maliit/maliit-framework_git.bb | |||
@@ -11,6 +11,7 @@ SRC_URI = "git://gitorious.org/maliit/maliit-framework.git;branch=master \ | |||
11 | file://0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch \ | 11 | file://0001-Fix-MALIIT_INSTALL_PRF-to-allow-the-build-with-opene.patch \ |
12 | file://0001-Fix-QT_IM_PLUGIN_PATH-to-allow-openembedded-to-build.patch \ | 12 | file://0001-Fix-QT_IM_PLUGIN_PATH-to-allow-openembedded-to-build.patch \ |
13 | file://0001-Link-to-libmaliit-1-0-in-inputcontext-plugin.patch \ | 13 | file://0001-Link-to-libmaliit-1-0-in-inputcontext-plugin.patch \ |
14 | file://maliit-server.desktop \ | ||
14 | " | 15 | " |
15 | 16 | ||
16 | SRCREV = "750842dec74a9b17dca91ef779c4fc5a43c4d9dc" | 17 | SRCREV = "750842dec74a9b17dca91ef779c4fc5a43c4d9dc" |
@@ -28,6 +29,7 @@ RRECOMMENDS_${PN} = "maliit-plugins" | |||
28 | FILES_${PN} += "\ | 29 | FILES_${PN} += "\ |
29 | ${libdir}/maliit/plugins-*/factories/libmaliit-plugins-quick-factory-*.so \ | 30 | ${libdir}/maliit/plugins-*/factories/libmaliit-plugins-quick-factory-*.so \ |
30 | ${libdir}/qt4/plugins/inputmethods/*.so \ | 31 | ${libdir}/qt4/plugins/inputmethods/*.so \ |
32 | ${datadir}/applications/maliit-server.desktop \ | ||
31 | " | 33 | " |
32 | 34 | ||
33 | FILES_${PN}-dbg += "\ | 35 | FILES_${PN}-dbg += "\ |
@@ -64,6 +66,9 @@ do_install_append() { | |||
64 | #Fix absolute paths | 66 | #Fix absolute paths |
65 | sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${datadir}/qt4/mkspecs/features/maliit-framework.prf | 67 | sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${datadir}/qt4/mkspecs/features/maliit-framework.prf |
66 | sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${datadir}/qt4/mkspecs/features/maliit-plugins.prf | 68 | sed -i -e "s|/usr|${STAGING_DIR_TARGET}${prefix}|" ${D}/${datadir}/qt4/mkspecs/features/maliit-plugins.prf |
69 | |||
70 | install -d ${D}${datadir}/applications | ||
71 | install -m 644 ${WORKDIR}/maliit-server.desktop ${D}${datadir}/applications | ||
67 | } | 72 | } |
68 | 73 | ||
69 | pkg_postinst_${PN} () { | 74 | pkg_postinst_${PN} () { |
@@ -73,6 +78,7 @@ if [ "x$D" != "x" ]; then | |||
73 | exit 1 | 78 | exit 1 |
74 | fi | 79 | fi |
75 | echo "export QT_IM_MODULE=Maliit" >> /etc/xprofile | 80 | echo "export QT_IM_MODULE=Maliit" >> /etc/xprofile |
81 | ln -s /usr/share/applications/maliit-server.desktop /etc/xdg/autostart/maliit-server.desktop | ||
76 | } | 82 | } |
77 | 83 | ||
78 | pkg_postrm_${PN} () { | 84 | pkg_postrm_${PN} () { |
@@ -84,7 +90,7 @@ fi | |||
84 | if [ -e "/etc/xprofile" ]; then | 90 | if [ -e "/etc/xprofile" ]; then |
85 | sed -i -e "g|export QT_IM_MODULE=Maliit|d" /etc/xprofile | 91 | sed -i -e "g|export QT_IM_MODULE=Maliit|d" /etc/xprofile |
86 | fi | 92 | fi |
87 | 93 | rm -f /etc/xdg/autostart/maliit-server.desktop | |
88 | } | 94 | } |
89 | 95 | ||
90 | S = "${WORKDIR}/git" | 96 | S = "${WORKDIR}/git" |