summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-08-14 15:28:50 -0700
committerKhem Raj <raj.khem@gmail.com>2024-08-15 10:28:11 -0700
commitb35cd00fe151408557f3e2f52a36946fd268db9c (patch)
treeba337c1c67646ea88a4a42c1e488d5d53da2294f /meta-oe/recipes-support
parent2dcf9b377244125535d3c74d695f88c99ebc4ebe (diff)
downloadmeta-openembedded-b35cd00fe151408557f3e2f52a36946fd268db9c.tar.gz
sharutils: Let POSIX_SHELL be overridable from environment
This helps fix WARNING: sharutils-4.15.2-r0 do_package_qa: QA Issue: File /usr/bin/shar in package sharutils contains reference to TMPDIR Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/sharutils/sharutils/0001-libopts.m4-accept-POSIX_SHELL-from-the-environment-d.patch47
-rw-r--r--meta-oe/recipes-support/sharutils/sharutils_4.15.2.bb3
2 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/sharutils/sharutils/0001-libopts.m4-accept-POSIX_SHELL-from-the-environment-d.patch b/meta-oe/recipes-support/sharutils/sharutils/0001-libopts.m4-accept-POSIX_SHELL-from-the-environment-d.patch
new file mode 100644
index 000000000..6d8a5e212
--- /dev/null
+++ b/meta-oe/recipes-support/sharutils/sharutils/0001-libopts.m4-accept-POSIX_SHELL-from-the-environment-d.patch
@@ -0,0 +1,47 @@
1From fb8bf1c1b1d0bf8e9bc637c0e67219fab1a9eb03 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 14 Aug 2024 15:24:57 -0700
4Subject: [PATCH] libopts.m4: accept POSIX_SHELL from the environment during
5 the configure step
6
7This lets us set it to the canonical path /bin/bash, even on systems
8where both /bin/bash and /usr/bin/bash are available, and therefore
9which(1) might return /usr/bin/bash (depending on PATH order).
10
11Both copies of libopts.m4 are marked as generated files, but the files
12from which they were generated do not seem to be present in the sharutils
13package. This change is equivalent to part of a 2016 autogen commit
14<https://git.savannah.gnu.org/cgit/autogen.git/commit/?id=db064b9a>.
15
16Upstream-Status: Backport [https://git.savannah.gnu.org/cgit/autogen.git/commit/?id=db064b9a]
17
18Signed-off-by: Khem Raj <raj.khem@gmail.com>
19---
20 libopts/m4/libopts.m4 | 1 +
21 m4/libopts.m4 | 1 +
22 2 files changed, 2 insertions(+)
23
24diff --git a/libopts/m4/libopts.m4 b/libopts/m4/libopts.m4
25index 1a896d9..3b88426 100644
26--- a/libopts/m4/libopts.m4
27+++ b/libopts/m4/libopts.m4
28@@ -114,6 +114,7 @@ AC_DEFUN([INVOKE_LIBOPTS_MACROS_FIRST],[
29 AC_PROG_SED
30 [while :
31 do
32+ test -x "$POSIX_SHELL" && break
33 POSIX_SHELL=`which bash`
34 test -x "$POSIX_SHELL" && break
35 POSIX_SHELL=`which dash`
36diff --git a/m4/libopts.m4 b/m4/libopts.m4
37index c7ba4f3..a1127e1 100644
38--- a/m4/libopts.m4
39+++ b/m4/libopts.m4
40@@ -114,6 +114,7 @@ AC_DEFUN([INVOKE_LIBOPTS_MACROS_FIRST],[
41 AC_PROG_SED
42 [while :
43 do
44+ test -x "$POSIX_SHELL" && break
45 POSIX_SHELL=`which bash`
46 test -x "$POSIX_SHELL" && break
47 POSIX_SHELL=`which dash`
diff --git a/meta-oe/recipes-support/sharutils/sharutils_4.15.2.bb b/meta-oe/recipes-support/sharutils/sharutils_4.15.2.bb
index 2a16b1828..7a506d034 100644
--- a/meta-oe/recipes-support/sharutils/sharutils_4.15.2.bb
+++ b/meta-oe/recipes-support/sharutils/sharutils_4.15.2.bb
@@ -13,10 +13,13 @@ SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
13 file://0001-Fix-building-with-GCC-10.patch \ 13 file://0001-Fix-building-with-GCC-10.patch \
14 file://0002-Do-not-include-lib-md5.c-into-src-shar.c.patch \ 14 file://0002-Do-not-include-lib-md5.c-into-src-shar.c.patch \
15 file://0001-configure.ac-Check-and-define-intmax_t-type.patch \ 15 file://0001-configure.ac-Check-and-define-intmax_t-type.patch \
16 file://0001-libopts.m4-accept-POSIX_SHELL-from-the-environment-d.patch \
16 " 17 "
17SRC_URI[md5sum] = "32a51b23e25ad5e6af4b89f228be1800" 18SRC_URI[md5sum] = "32a51b23e25ad5e6af4b89f228be1800"
18SRC_URI[sha256sum] = "ee336e68549664e7a19b117adf02edfdeac6307f22e5ba78baca457116914637" 19SRC_URI[sha256sum] = "ee336e68549664e7a19b117adf02edfdeac6307f22e5ba78baca457116914637"
19 20
21EXTRA_OECONF = "POSIX_SHELL=${base_bindir}/sh"
22
20do_install:append() { 23do_install:append() {
21 if [ -e ${D}${libdir}/charset.alias ] 24 if [ -e ${D}${libdir}/charset.alias ]
22 then 25 then