summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-09 21:26:33 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-09 21:26:33 +0200
commitaf3382bf3776af9812d68ba7d575ebd3e6a6c008 (patch)
treef3d174af7f93a4bf469adc9738c3c337bb3e40c9 /meta-oe/recipes-support
parent9d16b96d3d813f372c2383f5cb25fda6b6095ec7 (diff)
downloadmeta-openembedded-af3382bf3776af9812d68ba7d575ebd3e6a6c008.tar.gz
cpufrequtils: update to 008
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/cpufrequtils/cpufrequtils/fix-proc-stat-reading.patch59
-rw-r--r--meta-oe/recipes-support/cpufrequtils/cpufrequtils_006.bb24
-rw-r--r--meta-oe/recipes-support/cpufrequtils/cpufrequtils_008.bb24
3 files changed, 24 insertions, 83 deletions
diff --git a/meta-oe/recipes-support/cpufrequtils/cpufrequtils/fix-proc-stat-reading.patch b/meta-oe/recipes-support/cpufrequtils/cpufrequtils/fix-proc-stat-reading.patch
deleted file mode 100644
index a9e3407b3..000000000
--- a/meta-oe/recipes-support/cpufrequtils/cpufrequtils/fix-proc-stat-reading.patch
+++ /dev/null
@@ -1,59 +0,0 @@
1From 6657831200419d7509edcc04434d03b994c86adb Mon Sep 17 00:00:00 2001
2From: Anton Arapov <anton@redhat.com>
3Date: Wed, 11 Nov 2009 21:33:09 +0100
4Subject: [PATCH] cpufreq/aperf : fix the /proc/stat read routine, always fails otherwise.
5
6 the statement:
7 if (!fgets(value, LINE_LEN, fp)) {
8 always fails(==0) at the end of proc file, so we will have err_out:
9 firing all the time.
10
11 I've aligned the code to the one that other utils of cpufreq has.
12
13Signed-off-by: Anton Arapov <aarapov@redhat.com>
14Signed-off-by: Dominik Brodowski <linux@dominikbrodowski.net>
15---
16 utils/aperf.c | 18 +++++++-----------
17 1 files changed, 7 insertions(+), 11 deletions(-)
18
19diff --git a/utils/aperf.c b/utils/aperf.c
20index a37f8b1..8ecff2c 100644
21--- a/utils/aperf.c
22+++ b/utils/aperf.c
23@@ -76,14 +76,15 @@ static unsigned int count_cpus(void)
24 unsigned int cpunr = 0;
25
26 fp = fopen("/proc/stat", "r");
27- if(!fp)
28- goto err_out;
29+ if(!fp) {
30+ printf("Couldn't count the number of CPUs (%s: %s), "
31+ "assuming 1\n", "/proc/stat", strerror(errno));
32+ return 1;
33+ }
34
35 while (!feof(fp)) {
36- if (!fgets(value, LINE_LEN, fp)) {
37- fclose(fp);
38- goto err_out;
39- }
40+ if (!fgets(value, LINE_LEN, fp))
41+ continue;
42 value[LINE_LEN - 1] = '\0';
43 if (strlen(value) < (LINE_LEN - 2))
44 continue;
45@@ -98,11 +99,6 @@ static unsigned int count_cpus(void)
46
47 /* cpu count starts from 0, on error return 1 (UP) */
48 return (ret+1);
49-
50-err_out:
51- printf("Couldn't count the number of CPUs (%s: %s), "
52- "assuming 1\n", "/proc/stat", strerror(errno));
53- return 1;
54 }
55
56 static int has_mperf_aperf_support(int cpu)
57--
581.7.0
59
diff --git a/meta-oe/recipes-support/cpufrequtils/cpufrequtils_006.bb b/meta-oe/recipes-support/cpufrequtils/cpufrequtils_006.bb
deleted file mode 100644
index ccc7be7dd..000000000
--- a/meta-oe/recipes-support/cpufrequtils/cpufrequtils_006.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1DESCRIPTION = "To make access to the Linux kernel cpufreq subsystem easier for users and cpufreq userspace tools, a cpufrequtils package was created"
2
3DEPENDS = "libtool-cross"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8SRC_URI = "http://www.kernel.org/pub/linux/utils/kernel/cpufreq/cpufrequtils-${PV}.tar.bz2 \
9 file://fix-proc-stat-reading.patch \
10"
11SRC_URI[md5sum] = "124b0de8f3a4d672539a85ce13eed869"
12SRC_URI[sha256sum] = "b8e77854a1400b0cc73295f3ee5d0a0c3650438e677526a199e08f6680c15aa1"
13
14export CROSS = "${TARGET_PREFIX}"
15export LIBTOOL = "${HOST_SYS}-libtool --tag cc"
16TARGET_CC_ARCH += "${LDFLAGS}"
17
18do_compile() {
19 oe_runmake -e
20}
21do_install() {
22 oe_runmake -e install DESTDIR=${D}
23}
24
diff --git a/meta-oe/recipes-support/cpufrequtils/cpufrequtils_008.bb b/meta-oe/recipes-support/cpufrequtils/cpufrequtils_008.bb
new file mode 100644
index 000000000..a28ab831b
--- /dev/null
+++ b/meta-oe/recipes-support/cpufrequtils/cpufrequtils_008.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "To make access to the Linux kernel cpufreq subsystem easier for users and cpufreq userspace tools, a cpufrequtils package was created"
2
3DEPENDS = "libtool-cross"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8SRCREV = "adb7e044755aa06b12212d05c4acbcccb023d2cd"
9SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/cpufreq/cpufrequtils.git"
10
11S = "${WORKDIR}/git"
12
13TARGET_CC_ARCH += "${LDFLAGS}"
14
15EXTRA_OEMAKE = "V=1 CROSS=${TARGET_PREFIX} LIBTOOL='${HOST_SYS}-libtool --tag cc' STRIPCMD=echo"
16
17do_compile() {
18 oe_runmake
19}
20
21do_install() {
22 oe_runmake -e install DESTDIR=${D}
23}
24