diff options
author | Changqing Li <changqing.li@windriver.com> | 2018-07-10 11:20:27 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-07-12 07:19:43 -0700 |
commit | aa3dc427ef09dcbcde4da005c29dc537745ac96b (patch) | |
tree | 1b3eda0d9d2f633f7e09eedf4aa98c23a580a312 /meta-oe/recipes-support | |
parent | 7226544396a1c3c36a72150683fa1d8983d6b6ad (diff) | |
download | meta-openembedded-aa3dc427ef09dcbcde4da005c29dc537745ac96b.tar.gz |
satyr: upgrade 0.23 -> 0.26
Signed-off-by: Changqing Li <changqing.li@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/satyr/files/0001-do-not-support-python2.patch | 84 | ||||
-rw-r--r-- | meta-oe/recipes-support/satyr/files/0002-fix-compile-failure-against-musl-C-library.patch | 2 | ||||
-rw-r--r-- | meta-oe/recipes-support/satyr/satyr_0.26.bb (renamed from meta-oe/recipes-support/satyr/satyr_0.23.bb) | 5 |
3 files changed, 3 insertions, 88 deletions
diff --git a/meta-oe/recipes-support/satyr/files/0001-do-not-support-python2.patch b/meta-oe/recipes-support/satyr/files/0001-do-not-support-python2.patch deleted file mode 100644 index 9e95a3f9d1..0000000000 --- a/meta-oe/recipes-support/satyr/files/0001-do-not-support-python2.patch +++ /dev/null | |||
@@ -1,84 +0,0 @@ | |||
1 | From 206f334d62da17093e784094c9d9e80c853f704f Mon Sep 17 00:00:00 2001 | ||
2 | From: Hongxu Jia <hongxu.jia@windriver.com> | ||
3 | Date: Fri, 12 May 2017 03:03:46 -0400 | ||
4 | Subject: [PATCH] do not support python2 | ||
5 | |||
6 | Upstream-Status: Inappropriate [oe specific] | ||
7 | |||
8 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
9 | --- | ||
10 | configure.ac | 16 ---------------- | ||
11 | python/Makefile.am | 24 ------------------------ | ||
12 | 2 files changed, 40 deletions(-) | ||
13 | |||
14 | diff --git a/configure.ac b/configure.ac | ||
15 | index 200a7cc..8431c51 100644 | ||
16 | --- a/configure.ac | ||
17 | +++ b/configure.ac | ||
18 | @@ -22,22 +22,6 @@ AM_MISSING_PROG([AUTOM4TE], [autom4te]) | ||
19 | # Needed by tests/atlocal.in. | ||
20 | AC_SUBST([O0CFLAGS], [`echo $CFLAGS | sed 's/-O[[0-9]] *//'`]) | ||
21 | |||
22 | -AM_PATH_PYTHON | ||
23 | -AM_CONDITIONAL([HAVE_PYTHON], test -n "$PYTHON") | ||
24 | -[if test -z "$PYTHON"; then] | ||
25 | - [echo "The python interpreter was not found in the search path. The Python language bindings"] | ||
26 | - [echo "will not be built. If you want to build the Python language bindings, please ensure"] | ||
27 | - [echo "that python is installed and its directory is included in the search path."] | ||
28 | - [echo "Then run configure again before attempting to build Satyr."] | ||
29 | -[fi] | ||
30 | - | ||
31 | -# Just PKG_CHECK_MODULES([PYTHON], [python]) works only with python2.7+ | ||
32 | -# Below, if python is not found, we set up for python2.6 w/o checking: | ||
33 | -PKG_CHECK_MODULES([PYTHON], [python2],,[ | ||
34 | - PYTHON_LIBS='-L/usr/lib64 -lpython2.6' | ||
35 | - PYTHON_CFLAGS='-I/usr/include/python2.6' | ||
36 | -]) | ||
37 | - | ||
38 | AC_ARG_ENABLE([python-manpage], | ||
39 | [AS_HELP_STRING([--disable-python-manpage], | ||
40 | [Disable python bindings manpage build])], | ||
41 | diff --git a/python/Makefile.am b/python/Makefile.am | ||
42 | index 36fc2e9..0b73f66 100644 | ||
43 | --- a/python/Makefile.am | ||
44 | +++ b/python/Makefile.am | ||
45 | @@ -1,12 +1,5 @@ | ||
46 | SUBDIRS = . doc | ||
47 | |||
48 | -py2satyrdir = $(pyexecdir)/satyr | ||
49 | - | ||
50 | -py2satyr_PYTHON = \ | ||
51 | - __init__.py | ||
52 | - | ||
53 | -py2satyr_LTLIBRARIES = _satyr.la | ||
54 | - | ||
55 | PYEXTFILES = \ | ||
56 | py_cluster.h \ | ||
57 | py_cluster.c \ | ||
58 | @@ -75,23 +68,6 @@ PYEXTLDFLAGS = \ | ||
59 | -module \ | ||
60 | -avoid-version | ||
61 | |||
62 | -_satyr_la_SOURCES = $(PYEXTFILES) | ||
63 | -_satyr_la_CPPFLAGS = \ | ||
64 | - $(PYEXTCPPFLAGS) \ | ||
65 | - $(PYTHON_CFLAGS) | ||
66 | -_satyr_la_LDFLAGS = \ | ||
67 | - $(PYEXTLDFLAGS) \ | ||
68 | - -export-symbols-regex init_satyr | ||
69 | - | ||
70 | -# Depending on the configure option, we either link libsatyr.so dynamically (as | ||
71 | -# is usual), or directly include its object files (by including the | ||
72 | -# convenience library). | ||
73 | -if ENABLE_STATIC_PYTHON_MODULE | ||
74 | -_satyr_la_LIBADD = ../lib/libsatyr_conv.la | ||
75 | -else | ||
76 | -_satyr_la_LIBADD = ../lib/libsatyr.la | ||
77 | -endif | ||
78 | - | ||
79 | if WITH_PYTHON3 | ||
80 | py3satyrdir = $(py3execdir)/satyr | ||
81 | |||
82 | -- | ||
83 | 2.8.1 | ||
84 | |||
diff --git a/meta-oe/recipes-support/satyr/files/0002-fix-compile-failure-against-musl-C-library.patch b/meta-oe/recipes-support/satyr/files/0002-fix-compile-failure-against-musl-C-library.patch index 5827eb4d18..b6c32c4bd5 100644 --- a/meta-oe/recipes-support/satyr/files/0002-fix-compile-failure-against-musl-C-library.patch +++ b/meta-oe/recipes-support/satyr/files/0002-fix-compile-failure-against-musl-C-library.patch | |||
@@ -14,7 +14,7 @@ diff --git a/lib/rpm.c b/lib/rpm.c | |||
14 | index 920e145..58140bf 100644 | 14 | index 920e145..58140bf 100644 |
15 | --- a/lib/rpm.c | 15 | --- a/lib/rpm.c |
16 | +++ b/lib/rpm.c | 16 | +++ b/lib/rpm.c |
17 | @@ -188,7 +188,7 @@ sr_rpm_package_sort(struct sr_rpm_package *packages) | 17 | @@ -191,7 +191,7 @@ sr_rpm_package_sort(struct sr_rpm_package *packages) |
18 | } | 18 | } |
19 | 19 | ||
20 | /* Sort the array. */ | 20 | /* Sort the array. */ |
diff --git a/meta-oe/recipes-support/satyr/satyr_0.23.bb b/meta-oe/recipes-support/satyr/satyr_0.26.bb index f795c3717b..a09bea23d4 100644 --- a/meta-oe/recipes-support/satyr/satyr_0.23.bb +++ b/meta-oe/recipes-support/satyr/satyr_0.26.bb | |||
@@ -8,10 +8,9 @@ LICENSE = "GPLv2" | |||
8 | inherit autotools-brokensep python3native pkgconfig | 8 | inherit autotools-brokensep python3native pkgconfig |
9 | 9 | ||
10 | SRC_URI = "git://github.com/abrt/satyr.git \ | 10 | SRC_URI = "git://github.com/abrt/satyr.git \ |
11 | file://0001-do-not-support-python2.patch \ | ||
12 | file://0002-fix-compile-failure-against-musl-C-library.patch \ | 11 | file://0002-fix-compile-failure-against-musl-C-library.patch \ |
13 | " | 12 | " |
14 | SRCREV = "4742fd4857c446b96f712d52e2e4cd0b6cfe7398" | 13 | SRCREV = "4baa0c765071054314d1e7e78547ce6b7c133fbc" |
15 | S = "${WORKDIR}/git" | 14 | S = "${WORKDIR}/git" |
16 | 15 | ||
17 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" | 16 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
@@ -24,8 +23,8 @@ PACKAGES += "python3-${PN}" | |||
24 | FILES_python3-${PN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}" | 23 | FILES_python3-${PN} = "${PYTHON_SITEPACKAGES_DIR}/${BPN}" |
25 | 24 | ||
26 | PACKAGECONFIG ??= "python3 rpm" | 25 | PACKAGECONFIG ??= "python3 rpm" |
26 | PACKAGECONFIG[python2] = "--with-python2, --without-python2,,python2" | ||
27 | PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3" | 27 | PACKAGECONFIG[python3] = "--with-python3, --without-python3,,python3" |
28 | PACKAGECONFIG[pythonmanpage] = "--enable-python-manpage, --disable-python-manpage" | ||
29 | PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm" | 28 | PACKAGECONFIG[rpm] = "--with-rpm, --without-rpm, rpm" |
30 | 29 | ||
31 | do_configure_prepend() { | 30 | do_configure_prepend() { |