summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-08-31 19:04:44 -0700
committerKhem Raj <raj.khem@gmail.com>2022-09-05 22:49:34 -0700
commita3fe8e3e0378a3b85d014c092c4c6bb483ac076e (patch)
tree85c9114f3e4deeca3951ec41da119c3bdb7a39d3 /meta-oe/recipes-support
parentdcf06b291d3fb0174c9a49bcb97ac7788f80a1c2 (diff)
downloadmeta-openembedded-a3fe8e3e0378a3b85d014c092c4c6bb483ac076e.tar.gz
ckermit: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/ckermit/ckermit/0001-Fix-function-prototype-errors.patch106
-rw-r--r--meta-oe/recipes-support/ckermit/ckermit_302.bb4
2 files changed, 109 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/ckermit/ckermit/0001-Fix-function-prototype-errors.patch b/meta-oe/recipes-support/ckermit/ckermit/0001-Fix-function-prototype-errors.patch
new file mode 100644
index 000000000..306a2ee52
--- /dev/null
+++ b/meta-oe/recipes-support/ckermit/ckermit/0001-Fix-function-prototype-errors.patch
@@ -0,0 +1,106 @@
1From f73eade85b7a1b93f7b9ef6ca9ead9d2441f8f84 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 31 Aug 2022 19:01:38 -0700
4Subject: [PATCH] Fix function prototype errors
5
6Clang 15 is strict, therefore ensure that right headers are pulled in
7and also right function prototypes are used.
8
9Upstream-Status: Pending
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 ckcmai.c | 4 ++++
14 ckucmd.c | 2 +-
15 ckucmd.h | 2 --
16 ckucon.c | 2 +-
17 ckufio.c | 2 +-
18 ckuusx.c | 2 +-
19 6 files changed, 8 insertions(+), 6 deletions(-)
20
21diff --git a/ckcmai.c b/ckcmai.c
22index a5640e5..a4e322d 100644
23--- a/ckcmai.c
24+++ b/ckcmai.c
25@@ -561,6 +561,10 @@ ACKNOWLEDGMENTS:
26 #include "ckntap.h"
27 #endif /* NT */
28
29+#ifndef VMS
30+#include <time.h> /* time() */
31+#endif
32+
33 #ifndef NOSERVER
34 /* Text message definitions.. each should be 256 chars long, or less. */
35 #ifdef MINIX
36diff --git a/ckucmd.c b/ckucmd.c
37index 274dc2d..730f20d 100644
38--- a/ckucmd.c
39+++ b/ckucmd.c
40@@ -7356,7 +7356,7 @@ cmdgetc(timelimit) int timelimit; { /* Get a character from the tty. */
41 Returns 0 or greater always.
42 */
43 int
44-cmdconchk() {
45+cmdconchk(void) {
46 int x = 0, y;
47 y = pushc ? 1 : 0; /* Have command character pushed? */
48 #ifdef OS2
49diff --git a/ckucmd.h b/ckucmd.h
50index 7cd4ced..5c43cc4 100644
51--- a/ckucmd.h
52+++ b/ckucmd.h
53@@ -280,9 +280,7 @@ _PROTOTYP( int cmdsquo, (int) );
54 _PROTOTYP( int cmdgquo, (void) );
55 _PROTOTYP( char * ckcvtdate, (char *, int) );
56 _PROTOTYP( int cmdgetc, (int));
57-#ifndef NOARROWKEYS
58 _PROTOTYP( int cmdconchk, (void) );
59-#endif /* NOARROWKEYS */
60
61 #ifdef CK_RECALL
62 _PROTOTYP( char * cmgetcmd, (char *) );
63diff --git a/ckucon.c b/ckucon.c
64index 50ceb7e..954719e 100644
65--- a/ckucon.c
66+++ b/ckucon.c
67@@ -39,8 +39,8 @@ _PROTOTYP( static VOID concld, (void) );
68
69 #ifdef NEXT
70 #undef NSIG
71-#include <sys/wait.h> /* For wait() */
72 #endif /* NEXT */
73+#include <sys/wait.h> /* For wait() */
74
75 #include <signal.h> /* Signals */
76
77diff --git a/ckufio.c b/ckufio.c
78index b5bfaae..2a8d4e5 100644
79--- a/ckufio.c
80+++ b/ckufio.c
81@@ -142,8 +142,8 @@ _PROTOTYP( int parser, ( int ) );
82
83 #ifdef UNIX /* Pointer arg to wait() allowed */
84 #define CK_CHILD /* Assume this is safe in all UNIX */
85+#include <sys/wait.h> /* wait() API */
86 #endif /* UNIX */
87-
88 extern int binary, recursive, stathack;
89 #ifdef CK_CTRLZ
90 extern int eofmethod;
91diff --git a/ckuusx.c b/ckuusx.c
92index d332bed..253f992 100644
93--- a/ckuusx.c
94+++ b/ckuusx.c
95@@ -9144,7 +9144,7 @@ char *s; /* a string */
96 #ifndef CK_CURPOS
97 /* Dummies for when cursor control is not supported */
98 int
99-ck_curpos(row, col) {
100+ck_curpos(int row, int col) {
101 return(-1);
102 }
103
104--
1052.37.3
106
diff --git a/meta-oe/recipes-support/ckermit/ckermit_302.bb b/meta-oe/recipes-support/ckermit/ckermit_302.bb
index abeeeccd1..53f2b9d2c 100644
--- a/meta-oe/recipes-support/ckermit/ckermit_302.bb
+++ b/meta-oe/recipes-support/ckermit/ckermit_302.bb
@@ -8,7 +8,9 @@ SECTION = "console/network"
8LICENSE = "BSD-3-Clause" 8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://COPYING.TXT;md5=932ca542d6c6cb8a59a0bcd76ab67cc3" 9LIC_FILES_CHKSUM = "file://COPYING.TXT;md5=932ca542d6c6cb8a59a0bcd76ab67cc3"
10 10
11SRC_URI = "http://www.kermitproject.org/ftp/kermit/archives/cku${PV}.tar.gz;subdir=${BPN}-${PV}" 11SRC_URI = "http://www.kermitproject.org/ftp/kermit/archives/cku${PV}.tar.gz;subdir=${BPN}-${PV} \
12 file://0001-Fix-function-prototype-errors.patch \
13 "
12SRC_URI[md5sum] = "eac4dbf18b45775e4cdee5a7c74762b0" 14SRC_URI[md5sum] = "eac4dbf18b45775e4cdee5a7c74762b0"
13SRC_URI[sha256sum] = "0d5f2cd12bdab9401b4c836854ebbf241675051875557783c332a6a40dac0711" 15SRC_URI[sha256sum] = "0d5f2cd12bdab9401b4c836854ebbf241675051875557783c332a6a40dac0711"
14 16