summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2017-10-26 14:15:14 -0700
committerArmin Kuster <akuster808@gmail.com>2018-03-01 16:10:37 -0800
commita1c660848d8f3879ad4396b021e3dafdefeda333 (patch)
tree09c4936ef0ace6062fb433e119ad9c9d25fc5e48 /meta-oe/recipes-support
parent0df104e33d7f9aa969af56ff12756f09269e8e7a (diff)
downloadmeta-openembedded-a1c660848d8f3879ad4396b021e3dafdefeda333.tar.gz
passwdqc: move to recipes-security
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/passwdqc/passwdqc/makefile-add-ldflags.patch31
-rw-r--r--meta-oe/recipes-support/passwdqc/passwdqc_1.3.1.bb63
2 files changed, 0 insertions, 94 deletions
diff --git a/meta-oe/recipes-support/passwdqc/passwdqc/makefile-add-ldflags.patch b/meta-oe/recipes-support/passwdqc/passwdqc/makefile-add-ldflags.patch
deleted file mode 100644
index e9023492e..000000000
--- a/meta-oe/recipes-support/passwdqc/passwdqc/makefile-add-ldflags.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1Add LDFLAGS variable to Makefile so that extra linker flags can be sent via this variable.
2
3Upstream-Status: Pending
4
5Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
6
7diff --git a/Makefile b/Makefile
8index 49d622d..cd17334 100644
9--- a/Makefile
10+++ b/Makefile
11@@ -48,18 +48,17 @@ CFLAGS = -Wall -W -O2
12 CFLAGS_lib = $(CFLAGS) -fPIC
13 CFLAGS_bin = $(CFLAGS) -fomit-frame-pointer
14
15-LDFLAGS =
16 LDFLAGS_shared = --shared
17 LDFLAGS_shared_LINUX = --shared
18 LDFLAGS_shared_SUN = -G
19 LDFLAGS_shared_HP = -b
20 LDFLAGS_lib = $(LDFLAGS_shared)
21-LDFLAGS_lib_LINUX = $(LDFLAGS_shared_LINUX) \
22+LDFLAGS_lib_LINUX = $(LDFLAGS) $(LDFLAGS_shared_LINUX) \
23 -Wl,--soname,$(SHARED_LIB),--version-script,$(MAP_LIB)
24 LDFLAGS_lib_SUN = $(LDFLAGS_shared_SUN)
25 LDFLAGS_lib_HP = $(LDFLAGS_shared_HP)
26 LDFLAGS_pam = $(LDFLAGS_shared)
27-LDFLAGS_pam_LINUX = $(LDFLAGS_shared_LINUX) \
28+LDFLAGS_pam_LINUX = $(LDFLAGS) $(LDFLAGS_shared_LINUX) \
29 -Wl,--version-script,$(MAP_PAM)
30 LDFLAGS_pam_SUN = $(LDFLAGS_shared_SUN)
31 LDFLAGS_pam_HP = $(LDFLAGS_shared_HP)
diff --git a/meta-oe/recipes-support/passwdqc/passwdqc_1.3.1.bb b/meta-oe/recipes-support/passwdqc/passwdqc_1.3.1.bb
deleted file mode 100644
index 198db3ce7..000000000
--- a/meta-oe/recipes-support/passwdqc/passwdqc_1.3.1.bb
+++ /dev/null
@@ -1,63 +0,0 @@
1SUMMARY = "A password/passphrase strength checking and enforcement toolset"
2DESCRIPTION = "\
3passwdqc is a password/passphrase strength checking and policy enforcement \
4toolset, including an optional PAM module (pam_passwdqc), command-line \
5programs (pwqcheck and pwqgen), and a library (libpasswdqc). \
6pam_passwdqc is normally invoked on password changes by programs such as \
7passwd(1). It is capable of checking password or passphrase strength, \
8enforcing a policy, and offering randomly-generated passphrases, with \
9all of these features being optional and easily (re-)configurable. \
10\
11pwqcheck and pwqgen are standalone password/passphrase strength checking \
12and random passphrase generator programs, respectively, which are usable \
13from scripts. \
14\
15libpasswdqc is the underlying library, which may also be used from \
16third-party programs. \
17"
18
19HOMEPAGE = "http://www.openwall.com/passwdqc"
20SECTION = "System Environment/Base"
21
22DEPENDS += "libpam"
23
24LICENSE = "BSD"
25LIC_FILES_CHKSUM = "file://LICENSE;md5=1b4af6f3d4ee079a38107366e93b334d"
26
27SRC_URI = "http://www.openwall.com/${BPN}/${BP}.tar.gz \
28 file://makefile-add-ldflags.patch \
29 "
30SRC_URI[md5sum] = "3878b57bcd3fdbcf3d4b362dbc6228b9"
31SRC_URI[sha256sum] = "d1fedeaf759e8a0f32d28b5811ef11b5a5365154849190f4b7fab670a70ffb14"
32
33# explicitly define LINUX_PAM in case DISTRO_FEATURES no pam
34# this package's pam_passwdqc.so needs pam
35CFLAGS_append += "-Wall -fPIC -DHAVE_SHADOW -DLINUX_PAM"
36
37# -e is no longer default setting in bitbake.conf
38EXTRA_OEMAKE = "-e"
39
40do_compile() {
41 # make sure sub make use environment to override variables in Makefile
42 # Linux) $(MAKE), there is a tab between
43 sed -i -e 's/Linux) $(MAKE) CFLAGS_lib/Linux) $(MAKE) -e CFLAGS_lib/' ${S}/Makefile
44
45 # LD_lib and LD must be CC because of Makefile
46 oe_runmake LD="${CC}"
47}
48
49do_install() {
50 oe_runmake install DESTDIR=${D} SHARED_LIBDIR=${base_libdir} \
51 DEVEL_LIBDIR=${libdir} SECUREDIR=${base_libdir}/security \
52 INSTALL="install -p"
53}
54
55PROVIDES += "pam-${BPN}"
56PACKAGES =+ "lib${BPN} pam-${BPN}"
57
58FILES_lib${BPN} = "${base_libdir}/libpasswdqc.so.0"
59FILES_pam-${BPN} = "${base_libdir}/security/pam_passwdqc.so"
60FILES_${PN}-dbg += "${base_libdir}/security/.debug"
61
62RDEPENDS_${PN} = "lib${BPN} pam-${BPN}"
63RDEPENDS_pam-${BPN} = "lib${BPN}"