summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorLars Möllendorf <lars.moellendorf@plating.de>2024-05-22 13:13:47 +0200
committerKhem Raj <raj.khem@gmail.com>2024-05-23 16:17:11 -0700
commit965b0192c508d8fc3235b2b25b200cce96fd0a13 (patch)
tree4e93bcdc4d1142c337dfe80667e00843f5b643e8 /meta-oe/recipes-support
parentcda9ade9fb9662d11b6e956844db7c8202b9902b (diff)
downloadmeta-openembedded-965b0192c508d8fc3235b2b25b200cce96fd0a13.tar.gz
iniparser: upgrade 4.2 -> 4.2.1
Hompage-Upgrade: upstream iniparser moved to Gitlab Add-CMake-support.patch removed since CMake support is now provided upstream 0001-iniparser.pc-Make-libpath-a-variable.patch removed since pkg-config file is now generated by CMake Signed-off-by: Lars Möllendorf <lars.moellendorf@plating.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/iniparser/iniparser/0001-iniparser.pc-Make-libpath-a-variable.patch23
-rw-r--r--meta-oe/recipes-support/iniparser/iniparser/Add-CMake-support.patch65
-rw-r--r--meta-oe/recipes-support/iniparser/iniparser_4.2.2.bb16
-rw-r--r--meta-oe/recipes-support/iniparser/iniparser_4.2.bb27
4 files changed, 16 insertions, 115 deletions
diff --git a/meta-oe/recipes-support/iniparser/iniparser/0001-iniparser.pc-Make-libpath-a-variable.patch b/meta-oe/recipes-support/iniparser/iniparser/0001-iniparser.pc-Make-libpath-a-variable.patch
deleted file mode 100644
index 4824344f0..000000000
--- a/meta-oe/recipes-support/iniparser/iniparser/0001-iniparser.pc-Make-libpath-a-variable.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1From 1761298b73c759c07e4652ada307f68512a75ff1 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 25 Mar 2022 20:44:41 -0700
4Subject: [PATCH] iniparser.pc: Make libpath a variable
5
6Will set according to baselib that yocto exports.
7
8Upstream-Status: Inappropriate [OE-specific]
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 iniparser.pc | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14--- a/iniparser.pc
15+++ b/iniparser.pc
16@@ -1,6 +1,6 @@
17 prefix=/usr
18 exec_prefix=/usr
19-libdir=${exec_prefix}/lib
20+libdir=${exec_prefix}/@baselib@
21 includedir=${prefix}/include
22 datarootdir=${prefix}/share
23 datadir=${datarootdir}
diff --git a/meta-oe/recipes-support/iniparser/iniparser/Add-CMake-support.patch b/meta-oe/recipes-support/iniparser/iniparser/Add-CMake-support.patch
deleted file mode 100644
index 46c1b0f7a..000000000
--- a/meta-oe/recipes-support/iniparser/iniparser/Add-CMake-support.patch
+++ /dev/null
@@ -1,65 +0,0 @@
1Origin: Debian packaging
2From: Klee Dienes <klee@mit.edu>
3Date: Thu, 13 Feb 2014 07:03:26 -0500
4Subject: Add CMake support.
5
6---
7Upstream-Status: Pending
8
9 CMakeLists.txt | 44 ++++++++++++++++++++++++++++++++++++++++++++
10 1 file changed, 44 insertions(+)
11 create mode 100644 CMakeLists.txt
12
13--- /dev/null
14+++ b/CMakeLists.txt
15@@ -0,0 +1,50 @@
16+cmake_minimum_required (VERSION 2.8.8)
17+
18+project (iniparser)
19+include (GNUInstallDirs)
20+
21+include_directories (src)
22+
23+set(INIPARSER_SRCS src/dictionary.c src/iniparser.c)
24+set(INIPARSER_HDRS src/dictionary.h src/iniparser.h)
25+
26+add_library(iniparser-shared SHARED ${INIPARSER_SRCS} ${INIPARSER_HDRS})
27+add_library(iniparser-static STATIC ${INIPARSER_SRCS} ${INIPARSER_HDRS})
28+
29+set_target_properties(iniparser-shared PROPERTIES SOVERSION 1)
30+set_target_properties(iniparser-shared PROPERTIES OUTPUT_NAME iniparser)
31+set_target_properties(iniparser-static PROPERTIES OUTPUT_NAME iniparser)
32+
33+install (TARGETS iniparser-shared
34+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
35+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
36+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
37+
38+install (TARGETS iniparser-static
39+ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
40+ DESTINATION ${CMAKE_INSTALL_LIBDIR}
41+ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
42+
43+find_package(Doxygen)
44+if (NOT DOXYGEN_FOUND)
45+message(FATAL_ERROR "Doxygen is needed to build the documentation. Please install it correctly")
46+endif()
47+
48+file (WRITE ${CMAKE_CURRENT_BINARY_DIR}/iniparser.dox
49+ "@INCLUDE = ${CMAKE_CURRENT_SOURCE_DIR}/doc/iniparser.dox\n"
50+ "OUTPUT_DIRECTORY = ${CMAKE_CURRENT_BINARY_DIR}\n"
51+ )
52+
53+add_custom_target (doc ALL
54+ COMMAND ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/iniparser.dox
55+ SOURCES doc/iniparser.dox)
56+
57+enable_testing()
58+
59+add_test(NAME testsuite
60+ COMMAND make
61+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/test)
62+
63+install (FILES ${INIPARSER_HDRS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/iniparser)
64+
65+install (DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html DESTINATION ${CMAKE_INSTALL_DOCDIR})
diff --git a/meta-oe/recipes-support/iniparser/iniparser_4.2.2.bb b/meta-oe/recipes-support/iniparser/iniparser_4.2.2.bb
new file mode 100644
index 000000000..a8f7947c8
--- /dev/null
+++ b/meta-oe/recipes-support/iniparser/iniparser_4.2.2.bb
@@ -0,0 +1,16 @@
1SUMMARY = "The iniParser library is a simple C library offering INI file parsing services (both reading and writing)."
2SECTION = "libs"
3HOMEPAGE = "https://gitlab.com/iniparser/iniparser"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8474d3b745f77e203f1fc82fb0bb7678"
6SRCBRANCH = "main"
7SRCREV = "v${PV}"
8
9DEPENDS = "doxygen-native"
10
11SRC_URI = "git://gitlab.com/iniparser/iniparser.git;protocol=https;branch=${SRCBRANCH}"
12S = "${WORKDIR}/git"
13
14inherit cmake
15
16FILES_${PN}-staticdev += "${libdir}/cmake/iniparser/iniparser-staticTargets*.cmake"
diff --git a/meta-oe/recipes-support/iniparser/iniparser_4.2.bb b/meta-oe/recipes-support/iniparser/iniparser_4.2.bb
deleted file mode 100644
index d44772590..000000000
--- a/meta-oe/recipes-support/iniparser/iniparser_4.2.bb
+++ /dev/null
@@ -1,27 +0,0 @@
1SUMMARY = "The iniParser library is a simple C library offering INI file parsing services (both reading and writing)."
2SECTION = "libs"
3HOMEPAGE = "https://github.com/ndevilla/iniparser"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=8474d3b745f77e203f1fc82fb0bb7678"
6
7DEPENDS = "doxygen-native"
8
9PV .= "+git"
10
11SRC_URI = "git://github.com/ndevilla/iniparser.git;protocol=https;branch=master \
12 file://0001-iniparser.pc-Make-libpath-a-variable.patch \
13 file://Add-CMake-support.patch \
14"
15
16SRCREV = "9f5a6da1c245b44f49a46212ec0d81ffb1f821aa"
17
18S = "${WORKDIR}/git"
19
20inherit cmake
21
22do_install:append() {
23 install -Dm 0644 ${S}/iniparser.pc ${D}${libdir}/pkgconfig/iniparser.pc
24 sed -i -e 's,@baselib@,${baselib},g' ${D}${libdir}/pkgconfig/iniparser.pc
25}
26
27BBCLASSEXTEND += "native"