summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorasmitha <asmithakarun@gmail.com>2020-02-13 14:49:50 +0530
committerKhem Raj <raj.khem@gmail.com>2020-02-14 15:00:26 -0800
commit92f7fdca80517a59629ad144f5071175b9203b33 (patch)
treeebdc17ef5253160eca119aba08c3ced47f3c268e /meta-oe/recipes-support
parentfe35221dbe3bddcea0e6d745f34bf0145ee5e19d (diff)
downloadmeta-openembedded-92f7fdca80517a59629ad144f5071175b9203b33.tar.gz
libmimetic: Library to aid multi-part form data parsing
Mimetic library helps parsing the multi-part form data. This library can be used for scenarios that includes multi-part form data file uploads to the system. The patch file includes: i) The test directory is removed as there were errors (relocation errors) since the shared object files of libc++ and libc were not taken from the sysroot path but from the system's library path where the required version of the .so is not present. ii) The files 'mimetic/codec/other_codecs.h' and 'mimetic/contenttype.cxx' contains changes that resolves errors when compiling on target system aarch64-yoe-linux-musl. Signed-off-by: asmitha <asmithakarun@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/libmimetic/libmimetic/0001-libmimetic-Removing-test-directory-from-the-Makefile.patch67
-rw-r--r--meta-oe/recipes-support/libmimetic/libmimetic_0.9.8.bb21
2 files changed, 88 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libmimetic/libmimetic/0001-libmimetic-Removing-test-directory-from-the-Makefile.patch b/meta-oe/recipes-support/libmimetic/libmimetic/0001-libmimetic-Removing-test-directory-from-the-Makefile.patch
new file mode 100644
index 000000000..50cd4d427
--- /dev/null
+++ b/meta-oe/recipes-support/libmimetic/libmimetic/0001-libmimetic-Removing-test-directory-from-the-Makefile.patch
@@ -0,0 +1,67 @@
1From 64fd25af5fea3a3c9c12122a2fd0fab3cd420f72 Mon Sep 17 00:00:00 2001
2From: asmitk01-in <asmitk01@in.ibm.com>
3Date: Wed, 5 Feb 2020 00:14:42 -0600
4Subject: [PATCH] libmimetic: Removing test directory from the Makefile
5
6The test directory is removed as there were errors (relocation errors)
7since the shared object files of libc++ and libc were not taken from the
8sysroot path but from the system's library path where the required
9version of the .so is not present.
10
11The files 'mimetic/codec/other_codecs.h' and 'mimetic/contenttype.cxx'
12contains changes that resolves errors when compiling on target system
13aarch64-yoe-linux-musl.
14
15Signed-off-by: asmitk01-in <asmitk01@in.ibm.com>
16Change-Id: I1822b36ad4a1fa5e7b165d8cac3a6e96aca11c35
17---
18 Makefile.am | 2 +-
19 mimetic/codec/other_codecs.h | 4 ++++
20 mimetic/contenttype.cxx | 4 ++++
21 3 files changed, 9 insertions(+), 1 deletion(-)
22
23diff --git a/Makefile.am b/Makefile.am
24index 634bd4c..c7cbae7 100644
25--- a/Makefile.am
26+++ b/Makefile.am
27@@ -1,6 +1,6 @@
28 MAINTAINERCLEANFILES = Makefile Makefile.in config.cache
29 EXTRA_DIST=LICENSE m4
30-SUBDIRS = mimetic doc examples test win32
31+SUBDIRS = mimetic doc examples win32
32 INCLUDES=-I$(top_srcdir)
33 ACLOCAL_AMFLAGS=-I m4
34
35diff --git a/mimetic/codec/other_codecs.h b/mimetic/codec/other_codecs.h
36index c4ccf3f..0fc88fd 100644
37--- a/mimetic/codec/other_codecs.h
38+++ b/mimetic/codec/other_codecs.h
39@@ -8,6 +8,10 @@
40 #define _MIMETIC_CODEC_OTHER_CODECS_H_
41 #include <mimetic/codec/codec_base.h>
42
43+#ifndef __GLIBC__
44+ typedef unsigned int uint;
45+#endif
46+
47 namespace mimetic
48 {
49
50diff --git a/mimetic/contenttype.cxx b/mimetic/contenttype.cxx
51index 522082d..0577d44 100644
52--- a/mimetic/contenttype.cxx
53+++ b/mimetic/contenttype.cxx
54@@ -13,6 +13,10 @@
55 #include <mimetic/tokenizer.h>
56 #include <mimetic/utils.h>
57
58+#ifndef __GLIBC__
59+ typedef unsigned int uint;
60+#endif
61+
62 namespace mimetic
63 {
64 using namespace std;
65--
662.9.3
67
diff --git a/meta-oe/recipes-support/libmimetic/libmimetic_0.9.8.bb b/meta-oe/recipes-support/libmimetic/libmimetic_0.9.8.bb
new file mode 100644
index 000000000..fd65db2d3
--- /dev/null
+++ b/meta-oe/recipes-support/libmimetic/libmimetic_0.9.8.bb
@@ -0,0 +1,21 @@
1# Released under the MIT license.
2
3SUMMARY = "Mimetic Library for multi-part parsing"
4DESCRIPTION = "Email library (MIME) written in C++ designed to be easy to use and integrate but yet fast and efficient."
5AUTHOR = "Stefano Barbato <stefano@codesink.org>"
6HOMEPAGE = "http://www.codesink.org/mimetic_mime_library.html"
7BUGTRACKER = "https://github.com/LadislavSopko/mimetic/issues"
8
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=b49da7df0ca479ef01ff7f2d799eabee"
11
12SRCREV = "50486af99b4f9b35522d7b3de40b6ce107505279"
13SRC_URI += "git://github.com/LadislavSopko/mimetic/ \
14 file://0001-libmimetic-Removing-test-directory-from-the-Makefile.patch \
15 "
16
17S = "${WORKDIR}/git"
18
19CXXFLAGS += "-Wno-narrowing"
20
21inherit autotools