summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2016-07-26 05:18:07 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-07-29 11:01:00 +0200
commit8bb4a8bc5bea2b7ad175520199da6952d82c6a93 (patch)
tree6a8930535633ed3667efd6377e89a463413bee08 /meta-oe/recipes-support
parentf9f857807df2a73b7aadcfc6dcd935927a5b5213 (diff)
downloadmeta-openembedded-8bb4a8bc5bea2b7ad175520199da6952d82c6a93.tar.gz
unixodbc: Add the new recipe
unixODBC is an Open Source ODBC sub-system and an ODBC SDK for Linux, Mac OSX, and UNIX. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/unixodbc/files/do-not-use-libltdl-source-directory.patch43
-rw-r--r--meta-oe/recipes-support/unixodbc/unixodbc_2.3.4.bb27
2 files changed, 70 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/unixodbc/files/do-not-use-libltdl-source-directory.patch b/meta-oe/recipes-support/unixodbc/files/do-not-use-libltdl-source-directory.patch
new file mode 100644
index 000000000..69d26adca
--- /dev/null
+++ b/meta-oe/recipes-support/unixodbc/files/do-not-use-libltdl-source-directory.patch
@@ -0,0 +1,43 @@
1Subject: [PATCH] do not use libltdl source directory
2
3Don't use the included libltdl, use the one provided
4by our libtool instead.
5
6Upstream-Status: Inappropriate [configuration]
7
8Signed-off-by: Song.Li <Song.Li@windriver.com>
9Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
10---
11 Makefile.am | 1 -
12 configure.ac | 2 --
13 2 files changed, 3 deletions(-)
14
15diff --git a/Makefile.am b/Makefile.am
16index e881cca..1321802 100644
17--- a/Makefile.am
18+++ b/Makefile.am
19@@ -5,7 +5,6 @@ SUBDIRS = \
20 log \
21 lst \
22 ini \
23- libltdl \
24 odbcinst \
25 DriverManager \
26 exe \
27diff --git a/configure.ac b/configure.ac
28index 218502f..d50b7af 100644
29--- a/configure.ac
30+++ b/configure.ac
31@@ -136,9 +136,7 @@ dnl AC_CONFIG_MACRO_DIR([libltdl/m4])
32 dnl LT_CONFIG_LTDL_DIR([libltdl])
33 dnl LTDL_INIT
34
35-LT_CONFIG_LTDL_DIR([libltdl])
36 LT_INIT([dlopen])
37-LTDL_INIT([convenience])
38
39 dnl Substitute INCLTDL and LIBLTDL in the Makefiles
40 AC_SUBST(LTDLINCL)
41--
422.8.1
43
diff --git a/meta-oe/recipes-support/unixodbc/unixodbc_2.3.4.bb b/meta-oe/recipes-support/unixodbc/unixodbc_2.3.4.bb
new file mode 100644
index 000000000..6f57f375e
--- /dev/null
+++ b/meta-oe/recipes-support/unixodbc/unixodbc_2.3.4.bb
@@ -0,0 +1,27 @@
1SUMMARY = "An Open Source ODBC sub-system"
2DESCRIPTION = "unixODBC is an Open Source ODBC sub-system and an ODBC SDK \
3for Linux, Mac OSX, and UNIX."
4
5HOMEPAGE = "http://www.unixodbc.org/"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=d7b37bf80a3df5a65b355433ae36d206"
8
9DEPENDS = "libtool mysql5"
10
11SRC_URI = "ftp://ftp.unixodbc.org/pub/unixODBC/unixODBC-${PV}.tar.gz \
12 file://do-not-use-libltdl-source-directory.patch \
13"
14SRC_URI[md5sum] = "bd25d261ca1808c947cb687e2034be81"
15SRC_URI[sha256sum] = "2e1509a96bb18d248bf08ead0d74804957304ff7c6f8b2e5965309c632421e39"
16
17inherit autotools-brokensep
18
19S = "${WORKDIR}/unixODBC-${PV}"
20
21EXTRA_OEMAKE += "LIBS=-lltdl"
22
23do_configure_prepend() {
24 # old m4 files will cause libtool version don't match
25 rm -rf m4/*
26 rm -fr libltdl
27}