summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-06-17 12:23:37 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-06-23 15:20:05 +0200
commit80def85257e9676f6ad870f5adc2797349919f0f (patch)
tree82e3b954f52a09dbfd627bbeda4b4d2100aee816 /meta-oe/recipes-support
parent90488aa54d1abad7776f189940e38498778961cb (diff)
downloadmeta-openembedded-80def85257e9676f6ad870f5adc2797349919f0f.tar.gz
geis: add a patch to fix incorrect indentation issues and remove -Wno-error=misleading-indentation
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/canonical-multitouch/geis/fix-indentation-for-gcc6.patch14
-rw-r--r--meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb6
2 files changed, 17 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/canonical-multitouch/geis/fix-indentation-for-gcc6.patch b/meta-oe/recipes-support/canonical-multitouch/geis/fix-indentation-for-gcc6.patch
new file mode 100644
index 000000000..389e1b3fd
--- /dev/null
+++ b/meta-oe/recipes-support/canonical-multitouch/geis/fix-indentation-for-gcc6.patch
@@ -0,0 +1,14 @@
1--- geis-2.2.17/libgeis/geis_subscription.c.orig 2016-06-17 12:04:21.062938443 -0400
2+++ geis-2.2.17/libgeis/geis_subscription.c 2016-06-17 12:05:02.934939172 -0400
3@@ -237,9 +237,10 @@
4 GeisSize i;
5 for (i = 0; i < bag->sub_store_size; ++i)
6 {
7- if (bag->sub_store[i])
8+ if (bag->sub_store[i]) {
9 _subscription_unref(bag->sub_store[i]);
10 bag->sub_store[i] = NULL;
11+ }
12 }
13 }
14
diff --git a/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb b/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
index 9b087a8b2..f71d3248b 100644
--- a/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
+++ b/meta-oe/recipes-support/canonical-multitouch/geis_2.2.17.bb
@@ -19,13 +19,13 @@ REQUIRED_DISTRO_FEATURES = "x11"
19 19
20DEPENDS += "grail dbus-glib python3 virtual/libx11 libxext libxi libxcb dbus frame" 20DEPENDS += "grail dbus-glib python3 virtual/libx11 libxext libxi libxcb dbus frame"
21 21
22SRC_URI = "https://launchpad.net/${BPN}/trunk/${PV}/+download/${BPN}-${PV}.tar.xz" 22SRC_URI = "https://launchpad.net/${BPN}/trunk/${PV}/+download/${BPN}-${PV}.tar.xz\
23 file://fix-indentation-for-gcc6.patch \
24"
23SRC_URI[md5sum] = "2ff9d76a3ea5794516bb02c9d1924faf" 25SRC_URI[md5sum] = "2ff9d76a3ea5794516bb02c9d1924faf"
24SRC_URI[sha256sum] = "8a60f5683852094038904e690d23cc5a90a980fc52da67f0f28890baa25c70eb" 26SRC_URI[sha256sum] = "8a60f5683852094038904e690d23cc5a90a980fc52da67f0f28890baa25c70eb"
25 27
26EXTRA_OECONF = "--disable-integration-tests" 28EXTRA_OECONF = "--disable-integration-tests"
27TARGET_CFLAGS += "-Wno-error=misleading-indentation"
28
29 29
30FILES_${PN}-bin = "${bindir}" 30FILES_${PN}-bin = "${bindir}"
31RDEPENDS_${PN}-bin = " \ 31RDEPENDS_${PN}-bin = " \