summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2024-02-15 20:17:00 +0100
committerKhem Raj <raj.khem@gmail.com>2024-02-15 14:14:26 -0800
commit79e4539601182100b2bbeab1d02848ec3105fca4 (patch)
tree632ec385781b9af72c2402080cf528a23795fa1d /meta-oe/recipes-support
parent0b6224a322a7535151859027c1b256a8834f9469 (diff)
downloadmeta-openembedded-79e4539601182100b2bbeab1d02848ec3105fca4.tar.gz
libusbgx: uprev to the latest commit
Uprev libusbgx to ec0b01c to get following fixes: ``` ec0b01c Merge pull request #83 from mgrzeschik/uac2-controls cbf1750 uac2: add additional configuration controls 81d7c05 load libcomposite kernel module caad244 Fix: Memory leak config label 51abbfd Automake: fix distclean of tests 3cc5af7 Added printer function header to installed headers adc45af Added missing extern C closing brace ``` Refresh 0001-fix-stack-buffer-overflow-in-usbg_f_foo_attr_val-pro.patch. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/libusbgx/libusbgx/0001-fix-stack-buffer-overflow-in-usbg_f_foo_attr_val-pro.patch34
-rw-r--r--meta-oe/recipes-support/libusbgx/libusbgx_git.bb2
2 files changed, 18 insertions, 18 deletions
diff --git a/meta-oe/recipes-support/libusbgx/libusbgx/0001-fix-stack-buffer-overflow-in-usbg_f_foo_attr_val-pro.patch b/meta-oe/recipes-support/libusbgx/libusbgx/0001-fix-stack-buffer-overflow-in-usbg_f_foo_attr_val-pro.patch
index 1ab3494e1..24a2760d1 100644
--- a/meta-oe/recipes-support/libusbgx/libusbgx/0001-fix-stack-buffer-overflow-in-usbg_f_foo_attr_val-pro.patch
+++ b/meta-oe/recipes-support/libusbgx/libusbgx/0001-fix-stack-buffer-overflow-in-usbg_f_foo_attr_val-pro.patch
@@ -1,4 +1,4 @@
1From fc7855891c66599487265701294963bb0772bb80 Mon Sep 17 00:00:00 2001 1From 421b366cafdf954b7e1cd2bbb78b55e04d73c082 Mon Sep 17 00:00:00 2001
2From: Wlodzimierz Lipert <wlodzimierz.lipert@gmail.com> 2From: Wlodzimierz Lipert <wlodzimierz.lipert@gmail.com>
3Date: Mon, 28 Nov 2022 08:29:54 +0100 3Date: Mon, 28 Nov 2022 08:29:54 +0100
4Subject: [PATCH] fix: stack-buffer-overflow in usbg_f_foo_attr_val processing. 4Subject: [PATCH] fix: stack-buffer-overflow in usbg_f_foo_attr_val processing.
@@ -386,11 +386,11 @@ index b0409f1..06cee30 100644
386 386
387 #ifdef __cplusplus 387 #ifdef __cplusplus
388diff --git a/include/usbg/function/uac2.h b/include/usbg/function/uac2.h 388diff --git a/include/usbg/function/uac2.h b/include/usbg/function/uac2.h
389index c1bbb14..1ea55dc 100644 389index 6fc4d24..80918ef 100644
390--- a/include/usbg/function/uac2.h 390--- a/include/usbg/function/uac2.h
391+++ b/include/usbg/function/uac2.h 391+++ b/include/usbg/function/uac2.h
392@@ -53,9 +53,6 @@ union usbg_f_uac2_attr_val { 392@@ -110,9 +110,6 @@ union usbg_f_uac2_attr_val {
393 int p_ssize; 393 const char * function_name;
394 }; 394 };
395 395
396-#define USBG_F_UAC2_INT_TO_ATTR_VAL(WHAT) \ 396-#define USBG_F_UAC2_INT_TO_ATTR_VAL(WHAT) \
@@ -399,7 +399,7 @@ index c1bbb14..1ea55dc 100644
399 /** 399 /**
400 * @brief Cast from generic function to uac2 function 400 * @brief Cast from generic function to uac2 function
401 * @param[in] f function to be converted to uac2 funciton. 401 * @param[in] f function to be converted to uac2 funciton.
402@@ -115,7 +112,7 @@ int usbg_f_uac2_get_attr_val(usbg_f_uac2 *af, enum usbg_f_uac2_attr attr, 402@@ -172,7 +169,7 @@ int usbg_f_uac2_get_attr_val(usbg_f_uac2 *af, enum usbg_f_uac2_attr attr,
403 * @return 0 on success usbg_error if error occurred. 403 * @return 0 on success usbg_error if error occurred.
404 */ 404 */
405 int usbg_f_uac2_set_attr_val(usbg_f_uac2 *af, enum usbg_f_uac2_attr attr, 405 int usbg_f_uac2_set_attr_val(usbg_f_uac2 *af, enum usbg_f_uac2_attr attr,
@@ -408,7 +408,7 @@ index c1bbb14..1ea55dc 100644
408 408
409 /** 409 /**
410 * @brief Get the capture channel mask of UAC2 adapter 410 * @brief Get the capture channel mask of UAC2 adapter
411@@ -137,8 +134,8 @@ static inline int usbg_f_uac2_get_c_chmask(usbg_f_uac2 *af, int *c_chmask) 411@@ -194,8 +191,8 @@ static inline int usbg_f_uac2_get_c_chmask(usbg_f_uac2 *af, int *c_chmask)
412 */ 412 */
413 static inline int usbg_f_uac2_set_c_chmask(usbg_f_uac2 *af, int c_chmask) 413 static inline int usbg_f_uac2_set_c_chmask(usbg_f_uac2 *af, int c_chmask)
414 { 414 {
@@ -419,7 +419,7 @@ index c1bbb14..1ea55dc 100644
419 } 419 }
420 420
421 /** 421 /**
422@@ -161,8 +158,8 @@ static inline int usbg_f_uac2_get_c_srate(usbg_f_uac2 *af, int *c_srate) 422@@ -218,8 +215,8 @@ static inline int usbg_f_uac2_get_c_srate(usbg_f_uac2 *af, int *c_srate)
423 */ 423 */
424 static inline int usbg_f_uac2_set_c_srate(usbg_f_uac2 *af, int c_srate) 424 static inline int usbg_f_uac2_set_c_srate(usbg_f_uac2 *af, int c_srate)
425 { 425 {
@@ -430,7 +430,7 @@ index c1bbb14..1ea55dc 100644
430 } 430 }
431 431
432 /** 432 /**
433@@ -185,8 +182,8 @@ static inline int usbg_f_uac2_get_c_ssize(usbg_f_uac2 *af, int *c_ssize) 433@@ -242,8 +239,8 @@ static inline int usbg_f_uac2_get_c_ssize(usbg_f_uac2 *af, int *c_ssize)
434 */ 434 */
435 static inline int usbg_f_uac2_set_c_ssize(usbg_f_uac2 *af, int c_ssize) 435 static inline int usbg_f_uac2_set_c_ssize(usbg_f_uac2 *af, int c_ssize)
436 { 436 {
@@ -441,7 +441,7 @@ index c1bbb14..1ea55dc 100644
441 } 441 }
442 442
443 /** 443 /**
444@@ -209,8 +206,8 @@ static inline int usbg_f_uac2_get_p_chmask(usbg_f_uac2 *af, int *p_chmask) 444@@ -266,8 +263,8 @@ static inline int usbg_f_uac2_get_p_chmask(usbg_f_uac2 *af, int *p_chmask)
445 */ 445 */
446 static inline int usbg_f_uac2_set_p_chmask(usbg_f_uac2 *af, int p_chmask) 446 static inline int usbg_f_uac2_set_p_chmask(usbg_f_uac2 *af, int p_chmask)
447 { 447 {
@@ -452,7 +452,7 @@ index c1bbb14..1ea55dc 100644
452 } 452 }
453 453
454 /** 454 /**
455@@ -233,8 +230,8 @@ static inline int usbg_f_uac2_get_p_srate(usbg_f_uac2 *af, int *p_srate) 455@@ -290,8 +287,8 @@ static inline int usbg_f_uac2_get_p_srate(usbg_f_uac2 *af, int *p_srate)
456 */ 456 */
457 static inline int usbg_f_uac2_set_p_srate(usbg_f_uac2 *af, int p_srate) 457 static inline int usbg_f_uac2_set_p_srate(usbg_f_uac2 *af, int p_srate)
458 { 458 {
@@ -463,7 +463,7 @@ index c1bbb14..1ea55dc 100644
463 } 463 }
464 464
465 /** 465 /**
466@@ -257,8 +254,8 @@ static inline int usbg_f_uac2_get_p_ssize(usbg_f_uac2 *af, int *p_ssize) 466@@ -314,8 +311,8 @@ static inline int usbg_f_uac2_get_p_ssize(usbg_f_uac2 *af, int *p_ssize)
467 */ 467 */
468 static inline int usbg_f_uac2_set_p_ssize(usbg_f_uac2 *af, int p_ssize) 468 static inline int usbg_f_uac2_set_p_ssize(usbg_f_uac2 *af, int p_ssize)
469 { 469 {
@@ -536,7 +536,7 @@ index 634209f..ac97bc8 100644
536 libusbgx_la_CFLAGS = $(LIBCONFIG_CFLAGS) 536 libusbgx_la_CFLAGS = $(LIBCONFIG_CFLAGS)
537 AM_CPPFLAGS=-I$(top_srcdir)/include/ -I$(top_builddir)/include/usbg 537 AM_CPPFLAGS=-I$(top_srcdir)/include/ -I$(top_builddir)/include/usbg
538diff --git a/src/function/ether.c b/src/function/ether.c 538diff --git a/src/function/ether.c b/src/function/ether.c
539index ab91af9..d7dcd5d 100644 539index a9eaf33..a1d20f1 100644
540--- a/src/function/ether.c 540--- a/src/function/ether.c
541+++ b/src/function/ether.c 541+++ b/src/function/ether.c
542@@ -124,7 +124,7 @@ static int ether_libconfig_import(struct usbg_function *f, 542@@ -124,7 +124,7 @@ static int ether_libconfig_import(struct usbg_function *f,
@@ -702,10 +702,10 @@ index 519b012..5cdd814 100644
702 702
703 int usbg_f_ms_get_lun_file_s(usbg_f_ms *mf, int lun_id, 703 int usbg_f_ms_get_lun_file_s(usbg_f_ms *mf, int lun_id,
704diff --git a/src/function/uac2.c b/src/function/uac2.c 704diff --git a/src/function/uac2.c b/src/function/uac2.c
705index f2c1a49..38a9b0f 100644 705index 9ca8b66..fc06c1d 100644
706--- a/src/function/uac2.c 706--- a/src/function/uac2.c
707+++ b/src/function/uac2.c 707+++ b/src/function/uac2.c
708@@ -89,7 +89,7 @@ static int uac2_libconfig_import(struct usbg_function *f, 708@@ -125,7 +125,7 @@ static int uac2_libconfig_import(struct usbg_function *f,
709 if (ret < 0) 709 if (ret < 0)
710 break; 710 break;
711 711
@@ -714,7 +714,7 @@ index f2c1a49..38a9b0f 100644
714 if (ret) 714 if (ret)
715 break; 715 break;
716 } 716 }
717@@ -174,8 +174,8 @@ int usbg_f_uac2_set_attrs(usbg_f_uac2 *af, 717@@ -210,8 +210,8 @@ int usbg_f_uac2_set_attrs(usbg_f_uac2 *af,
718 718
719 for (i = USBG_F_UAC2_ATTR_MIN; i < USBG_F_UAC2_ATTR_MAX; ++i) { 719 for (i = USBG_F_UAC2_ATTR_MIN; i < USBG_F_UAC2_ATTR_MAX; ++i) {
720 ret = usbg_f_uac2_set_attr_val(af, i, 720 ret = usbg_f_uac2_set_attr_val(af, i,
@@ -725,7 +725,7 @@ index f2c1a49..38a9b0f 100644
725 + uac2_attr[i].offset)); 725 + uac2_attr[i].offset));
726 if (ret) 726 if (ret)
727 break; 727 break;
728@@ -193,8 +193,8 @@ int usbg_f_uac2_get_attr_val(usbg_f_uac2 *af, enum usbg_f_uac2_attr attr, 728@@ -229,8 +229,8 @@ int usbg_f_uac2_get_attr_val(usbg_f_uac2 *af, enum usbg_f_uac2_attr attr,
729 } 729 }
730 730
731 int usbg_f_uac2_set_attr_val(usbg_f_uac2 *af, enum usbg_f_uac2_attr attr, 731 int usbg_f_uac2_set_attr_val(usbg_f_uac2 *af, enum usbg_f_uac2_attr attr,
@@ -792,5 +792,5 @@ index 5f7f4e5..7234649 100644
792 char str_addr[USBG_MAX_STR_LENGTH]; 792 char str_addr[USBG_MAX_STR_LENGTH];
793 793
794-- 794--
7952.25.1 7952.42.0
796 796
diff --git a/meta-oe/recipes-support/libusbgx/libusbgx_git.bb b/meta-oe/recipes-support/libusbgx/libusbgx_git.bb
index 484110561..a20ff4eea 100644
--- a/meta-oe/recipes-support/libusbgx/libusbgx_git.bb
+++ b/meta-oe/recipes-support/libusbgx/libusbgx_git.bb
@@ -6,7 +6,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6inherit autotools pkgconfig systemd update-rc.d update-alternatives 6inherit autotools pkgconfig systemd update-rc.d update-alternatives
7 7
8PV = "0.2.0+git" 8PV = "0.2.0+git"
9SRCREV = "721e3a1cbd7e2b6361bb439d3959e7403e4f0092" 9SRCREV = "ec0b01c03fdc7893997b7b32ec1c12c6103f62f3"
10SRCBRANCH = "master" 10SRCBRANCH = "master"
11SRC_URI = " \ 11SRC_URI = " \
12 git://github.com/libusbgx/libusbgx.git;branch=${SRCBRANCH};protocol=https \ 12 git://github.com/libusbgx/libusbgx.git;branch=${SRCBRANCH};protocol=https \