diff options
author | Matija Tudan <tudan.matija@gmail.com> | 2023-05-08 14:35:48 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-05-09 17:37:30 -0700 |
commit | 77b6df94c1e3344b7fb461b2f348b910d5479592 (patch) | |
tree | 3885935f64c5bc59de14087bf4b1078b0020beed /meta-oe/recipes-support | |
parent | bd7cd3bc6fb7e7628229937cc867699e55eafe27 (diff) | |
download | meta-openembedded-77b6df94c1e3344b7fb461b2f348b910d5479592.tar.gz |
serial: add recipe for version 1.2.1
Serial is cross-platform library for interfacing with
RS-232 serial like ports.
Signed-off-by: Matija Tudan <tudan.matija@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/serial/serial/Findcatkin.cmake | 5 | ||||
-rw-r--r-- | meta-oe/recipes-support/serial/serial_1.2.1.bb | 28 |
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/serial/serial/Findcatkin.cmake b/meta-oe/recipes-support/serial/serial/Findcatkin.cmake new file mode 100644 index 0000000000..2f93564be3 --- /dev/null +++ b/meta-oe/recipes-support/serial/serial/Findcatkin.cmake | |||
@@ -0,0 +1,5 @@ | |||
1 | # Work-around for https://github.com/wjwwood/serial/issues/135 | ||
2 | |||
3 | function(catkin_package) | ||
4 | endfunction() | ||
5 | |||
diff --git a/meta-oe/recipes-support/serial/serial_1.2.1.bb b/meta-oe/recipes-support/serial/serial_1.2.1.bb new file mode 100644 index 0000000000..8c1fb063b3 --- /dev/null +++ b/meta-oe/recipes-support/serial/serial_1.2.1.bb | |||
@@ -0,0 +1,28 @@ | |||
1 | SUMMARY = "Cross-platform library for interfacing with rs-232 serial like ports" | ||
2 | HOMEPAGE = "http://wjwwood.io/serial/" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://README.md;beginline=53;endline=62;md5=049c68d559533f90250404746e6a1045" | ||
5 | |||
6 | SRC_URI = " \ | ||
7 | git://github.com/wjwwood/${BPN}.git;protocol=https;branch=main \ | ||
8 | file://Findcatkin.cmake \ | ||
9 | " | ||
10 | SRCREV = "10ac4e1c25c2cda1dc0a32a8e12b87fd89f3bb4f" | ||
11 | SRC_URI[sha256sum] = "c8cd235dda2ef7d977ba06dfcb35c35e42f45cfd9149ba3ad257756123d8ff96" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | inherit cmake | ||
16 | |||
17 | # Work-around for https://github.com/wjwwood/serial/issues/135 | ||
18 | EXTRA_OECMAKE = " \ | ||
19 | -DCMAKE_MODULE_PATH=${WORKDIR} \ | ||
20 | -DCATKIN_PACKAGE_LIB_DESTINATION=${libdir} \ | ||
21 | -DCATKIN_PACKAGE_BIN_DESTINATION=${bindir} \ | ||
22 | -DCATKIN_GLOBAL_INCLUDE_DESTINATION=${includedir} \ | ||
23 | -DCATKIN_ENABLE_TESTING=OFF \ | ||
24 | " | ||
25 | |||
26 | # Do not depend on the main package since it will be empty | ||
27 | RDEPENDS:${PN}-dev = "" | ||
28 | |||