diff options
author | Jiping Ma <jiping.ma2@windriver.com> | 2019-02-25 16:01:02 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-02-25 16:31:56 -0800 |
commit | 6fc1a938312d62be2a3514437e8ba52daf5dd1ae (patch) | |
tree | 54544d8a37dca6e44ee6f6cc87a7a25bb2e09055 /meta-oe/recipes-support | |
parent | 5cea5f2451f57612ec77dedb26e9a5a7a0f0e6d9 (diff) | |
download | meta-openembedded-6fc1a938312d62be2a3514437e8ba52daf5dd1ae.tar.gz |
lvm2: lvmdiskscan always print out "/dev/hdc: open failed: No medium found".
commit [57bb46c5e7f8] introduce this issue.
"/dev/hdc: open failed: No medium found" will be print out
after run lvmdiskscan. change dev_open_readonly()
to dev_open_readonly_quiet() in fuction _dev_get_size_dev().
Signed-off-by: Jiping Ma <jiping.ma2@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/lvm2/lvm2/0001-dev-hdc-open-failed-No-medium-found-will-print-out-i.patch | 32 | ||||
-rw-r--r-- | meta-oe/recipes-support/lvm2/lvm2_2.03.01.bb | 1 |
2 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/lvm2/lvm2/0001-dev-hdc-open-failed-No-medium-found-will-print-out-i.patch b/meta-oe/recipes-support/lvm2/lvm2/0001-dev-hdc-open-failed-No-medium-found-will-print-out-i.patch new file mode 100644 index 000000000..24d5b1b48 --- /dev/null +++ b/meta-oe/recipes-support/lvm2/lvm2/0001-dev-hdc-open-failed-No-medium-found-will-print-out-i.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From 93c93e3b85492e58f9451841e6079d00c497efa4 Mon Sep 17 00:00:00 2001 | ||
2 | From: Jiping Ma <jiping.ma2@windriver.com> | ||
3 | Date: Mon, 25 Feb 2019 13:29:12 +0800 | ||
4 | Subject: [PATCH] "/dev/hdc: open failed: No medium found" will print out in | ||
5 | lvmdiskscan. | ||
6 | |||
7 | commit [57bb46c5e7f8] introduce this issue. | ||
8 | "/dev/hdc: open failed: No medium found" will be print out | ||
9 | after run lvmdiskscan. change dev_open_readonly() | ||
10 | to dev_open_readonly_quiet() in fuction _dev_get_size_dev(). | ||
11 | |||
12 | Signed-off-by: Jiping Ma <jiping.ma2@windriver.com> | ||
13 | --- | ||
14 | lib/device/dev-io.c | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/lib/device/dev-io.c b/lib/device/dev-io.c | ||
18 | index dc95131..81a66b0 100644 | ||
19 | --- a/lib/device/dev-io.c | ||
20 | +++ b/lib/device/dev-io.c | ||
21 | @@ -338,7 +338,7 @@ static int _dev_get_size_dev(struct device *dev, uint64_t *size) | ||
22 | } | ||
23 | |||
24 | if (fd <= 0) { | ||
25 | - if (!dev_open_readonly(dev)) | ||
26 | + if (!dev_open_readonly_quiet(dev)) | ||
27 | return_0; | ||
28 | fd = dev_fd(dev); | ||
29 | do_close = 1; | ||
30 | -- | ||
31 | 1.9.1 | ||
32 | |||
diff --git a/meta-oe/recipes-support/lvm2/lvm2_2.03.01.bb b/meta-oe/recipes-support/lvm2/lvm2_2.03.01.bb index c38c38191..0df624b73 100644 --- a/meta-oe/recipes-support/lvm2/lvm2_2.03.01.bb +++ b/meta-oe/recipes-support/lvm2/lvm2_2.03.01.bb | |||
@@ -4,6 +4,7 @@ SRCREV = "913c28917e62577a2ef67152b2e5159237503dda" | |||
4 | 4 | ||
5 | SRC_URI += "file://0001-explicitly-do-not-install-libdm.patch \ | 5 | SRC_URI += "file://0001-explicitly-do-not-install-libdm.patch \ |
6 | file://0001-lvm2-monitoring-service-shouldn-t-refer-to-lvmetad.patch \ | 6 | file://0001-lvm2-monitoring-service-shouldn-t-refer-to-lvmetad.patch \ |
7 | file://0001-dev-hdc-open-failed-No-medium-found-will-print-out-i.patch \ | ||
7 | " | 8 | " |
8 | 9 | ||
9 | DEPENDS += "autoconf-archive-native" | 10 | DEPENDS += "autoconf-archive-native" |