summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-11-12 18:35:04 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-11-26 01:07:03 +0100
commit6e431331d18ded23a78e238ed40d03434e7719d9 (patch)
tree7f497b52ae16f6a575ffc1e19961e0eed2908fd2 /meta-oe/recipes-support
parentbc0ea5b276629dcd1169374b8217087db2ded086 (diff)
downloadmeta-openembedded-6e431331d18ded23a78e238ed40d03434e7719d9.tar.gz
ne10: Update to latest
* Patch to build with clang * license checksum changed due to Copyright year change https://github.com/kraj/Ne10/commit/fee112eb2278469e7cfe2516dffa2ecfa5ad4c9a Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/ne10/ne10/0001-CMakeLists.txt-Remove-mthumb-interwork.patch44
-rw-r--r--meta-oe/recipes-support/ne10/ne10_1.2.1.bb9
2 files changed, 50 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/ne10/ne10/0001-CMakeLists.txt-Remove-mthumb-interwork.patch b/meta-oe/recipes-support/ne10/ne10/0001-CMakeLists.txt-Remove-mthumb-interwork.patch
new file mode 100644
index 000000000..9f2faaa52
--- /dev/null
+++ b/meta-oe/recipes-support/ne10/ne10/0001-CMakeLists.txt-Remove-mthumb-interwork.patch
@@ -0,0 +1,44 @@
1From 8a0d1cbfcc0649b2696c9cf20f877366de259ce3 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 12 Nov 2016 18:15:26 +0000
4Subject: [PATCH] CMakeLists.txt: Remove -mthumb-interwork
5
6This option is meaningless with aapcs ABI
7which is the default for Linux and android
8for armv7+ architectures
9
10As an aside it helps in compiling with clang
11where this option is absent
12
13Signed-off-by: Khem Raj <raj.khem@gmail.com>
14---
15 CMakeLists.txt | 6 +++---
16 1 file changed, 3 insertions(+), 3 deletions(-)
17
18diff --git a/CMakeLists.txt b/CMakeLists.txt
19index 784a5a8..68da920 100644
20--- a/CMakeLists.txt
21+++ b/CMakeLists.txt
22@@ -117,7 +117,7 @@ if(ANDROID_PLATFORM)
23
24 # Adding cflags for armv7. Aarch64 does not need such flags.
25 if(${NE10_TARGET_ARCH} STREQUAL "armv7")
26- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mthumb-interwork -mthumb -march=armv7-a -mfloat-abi=${FLOAT_ABI} -mfpu=vfp3")
27+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mthumb -march=armv7-a -mfloat-abi=${FLOAT_ABI} -mfpu=vfp3")
28 if(NE10_ARM_HARD_FLOAT)
29 # "--no-warn-mismatch" is needed for linker to suppress linker error about not all functions use VFP register to pass argument, eg.
30 # .../arm-linux-androideabi/bin/ld: error: ..../test-float.o
31@@ -138,8 +138,8 @@ if(ANDROID_PLATFORM)
32 ${CMAKE_C_FLAGS}")
33 elseif(GNULINUX_PLATFORM)
34 if("${NE10_TARGET_ARCH}" STREQUAL "armv7")
35- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mthumb-interwork -mthumb -march=armv7-a -mfpu=vfp3 -funsafe-math-optimizations")
36- set(CMAKE_ASM_FLAGS "${CMAKE_C_FLAGS} -mthumb-interwork -mthumb -march=armv7-a -mfpu=neon")
37+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -mthumb -march=armv7-a -mfpu=vfp3 -funsafe-math-optimizations")
38+ set(CMAKE_ASM_FLAGS "${CMAKE_C_FLAGS} -mthumb -march=armv7-a -mfpu=neon")
39 # Turn on asm optimization for Linux on ARM v7.
40 set(NE10_ASM_OPTIMIZATION on)
41 endif()
42--
431.8.3.1
44
diff --git a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
index de979821c..2fb9d64f5 100644
--- a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
+++ b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
@@ -1,13 +1,16 @@
1DESCRIPTION = "Library containing NEON-optimized implementations for a common set of functions" 1DESCRIPTION = "Library containing NEON-optimized implementations for a common set of functions"
2HOMEPAGE = "http://projectne10.github.io/Ne10/" 2HOMEPAGE = "http://projectne10.github.io/Ne10/"
3LICENSE = "BSD-3-Clause" 3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=463ac0a7d64edc2b787c4206635ca2b1" 4LIC_FILES_CHKSUM = "file://LICENSE;md5=e7fe20c9be97be5579e3ab5d92d3a218"
5SECTION = "libs" 5SECTION = "libs"
6 6
7SRC_URI = "git://github.com/projectNe10/Ne10.git" 7SRC_URI = "git://github.com/projectNe10/Ne10.git \
8SRCREV = "a08b29d88e3c94d32b5b8f827e7fcf0bc2b34ac2" 8 file://0001-CMakeLists.txt-Remove-mthumb-interwork.patch \
9"
10SRCREV = "18c4c982a595dad069cd8df4932aefb1d257591f"
9 11
10S = "${WORKDIR}/git" 12S = "${WORKDIR}/git"
13PV .= "gitr+${SRCPV}"
11 14
12inherit cmake 15inherit cmake
13 16