summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorMatthieu CRAPET <Matthieu.CRAPET@ingenico.com>2014-04-01 15:14:52 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2014-04-20 14:50:46 +0200
commit6aef16015bc9ee34cee1779284e8ffc8a8fd0cbd (patch)
tree99c259ac86cb0afa8551b930c165f01c762f03ef /meta-oe/recipes-support
parentc6e9d85d948ed4676572a34241376a2156b837a2 (diff)
downloadmeta-openembedded-6aef16015bc9ee34cee1779284e8ffc8a8fd0cbd.tar.gz
open-vcdiff: add new recipe for version 0.8.3
This is Google's implementation of VCDIFF (RFC 3284) delta compression. It's more flexible than Xdelta3 (as a developer point of view). v2 patch: State of bitbake world, Failed tasks 2014-03-29 reported a do_configure error: | aclocal: error: non-option arguments are not accepted: '\'. configure.ac file is quite out of date. Submitted patch upstream: http://code.google.com/p/open-vcdiff/issues/detail?id=43 Note: autoupdate could be considered later... Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/open-vcdiff/files/aclocal-amflags-fix.patch33
-rw-r--r--meta-oe/recipes-support/open-vcdiff/open-vcdiff_0.8.3.bb19
2 files changed, 52 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/open-vcdiff/files/aclocal-amflags-fix.patch b/meta-oe/recipes-support/open-vcdiff/files/aclocal-amflags-fix.patch
new file mode 100644
index 000000000..cd1efd7b1
--- /dev/null
+++ b/meta-oe/recipes-support/open-vcdiff/files/aclocal-amflags-fix.patch
@@ -0,0 +1,33 @@
1Fix this error:
2
3| aclocal: error: non-option arguments are not accepted: '\'.
4
5Starting from commit v1.11-662-g52246cc, when given non-option arguments, aclocal rejects them, instead of silently ignoring them.
6
7Declare ACLOCAL_AMFLAGS as a single line because autoreconf can't handle multiline.
8
9Notice that ACLOCAL_AMFLAGS is deprecated.
10In configure.ac, AC_CONFIG_MACRO_DIRS should be used (instead of AC_CONFIG_MACRO_DIR) but requires automake 1.13+.
11
12Signed-off-by: Matthieu Crapet <Matthieu.Crapet@ingenico.com>
13---
14 Makefile.am | 3 +--
15 1 file changed, 1 insertion(+), 2 deletions(-)
16
17diff --git a/Makefile.am b/Makefile.am
18index 5c765c7..f4295a6 100644
19--- a/Makefile.am
20+++ b/Makefile.am
21@@ -1,8 +1,7 @@
22 ## Process this file with automake to produce Makefile.in
23
24 # Make sure that when we re-make ./configure, we get the macros we need
25-ACLOCAL_AMFLAGS = -I m4 \
26- -I gflags/m4
27+ACLOCAL_AMFLAGS = -I m4 -I gflags/m4
28
29 # This is so we can #include <google/vcencoder.h> or <gtest/gtest.h>
30 AM_CPPFLAGS = -I$(top_srcdir)/src \
31--
321.8.5.4
33
diff --git a/meta-oe/recipes-support/open-vcdiff/open-vcdiff_0.8.3.bb b/meta-oe/recipes-support/open-vcdiff/open-vcdiff_0.8.3.bb
new file mode 100644
index 000000000..c6af25d48
--- /dev/null
+++ b/meta-oe/recipes-support/open-vcdiff/open-vcdiff_0.8.3.bb
@@ -0,0 +1,19 @@
1SUMMARY = "An encoder/decoder for the VCDIFF (RFC3284) format"
2DESCRIPTION = "A library with a simple API is included, as well as a \
3 command-line executable that can apply the encoder and \
4 decoder to source, target, and delta files. \
5 A slight variation from the draft standard is defined \
6 to allow chunk-by-chunk decoding when only a partial \
7 delta file window is available."
8HOMEPAGE = "http://code.google.com/p/open-vcdiff/"
9SECTION = "console/utils"
10
11LICENSE = "Apache-2.0"
12LIC_FILES_CHKSUM = "file://COPYING;md5=b2c8309843bc5297cfb4dc84f43f3ccc"
13
14SRC_URI = "http://open-vcdiff.googlecode.com/files/${BPN}-${PV}.tar.gz \
15 file://aclocal-amflags-fix.patch"
16SRC_URI[md5sum] = "5f848e4916b407879f55e0ca74c3f6af"
17SRC_URI[sha256sum] = "b7e47db78866082e9e8b5782f5491092c8414f0acc0440aea03b14c7d1d3c371"
18
19inherit autotools