summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorGianfranco Costamagna <costamagna.gianfranco@gmail.com>2020-02-27 15:37:25 +0100
committerKhem Raj <raj.khem@gmail.com>2020-02-27 08:25:49 -0800
commit40d3b71630acb985eed715142bcd17f4de287cad (patch)
tree90bcf01d4f16526b2fa250150ddcbdf3880ef64b /meta-oe/recipes-support
parentd4874942d8d1a40fd84bbdb9528a58fd6289ca95 (diff)
downloadmeta-openembedded-40d3b71630acb985eed715142bcd17f4de287cad.tar.gz
cpprest: update to 2.10.15 and refresh patches
Signed-off-by: Gianfranco Costamagna <costamagnagianfranco@yahoo.it> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch43
-rw-r--r--meta-oe/recipes-support/cpprest/cpprest_2.10.15.bb (renamed from meta-oe/recipes-support/cpprest/cpprest_2.10.14.bb)4
2 files changed, 8 insertions, 39 deletions
diff --git a/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch b/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch
index 5232e2a1d..e108e0279 100644
--- a/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch
+++ b/meta-oe/recipes-support/cpprest/cpprest/disable-outside-tests.patch
@@ -54,7 +54,7 @@ Index: cpprest/Release/tests/functional/websockets/client/authentication_tests.c
54=================================================================== 54===================================================================
55--- cpprest.orig/Release/tests/functional/websockets/client/authentication_tests.cpp 55--- cpprest.orig/Release/tests/functional/websockets/client/authentication_tests.cpp
56+++ cpprest/Release/tests/functional/websockets/client/authentication_tests.cpp 56+++ cpprest/Release/tests/functional/websockets/client/authentication_tests.cpp
57@@ -93,6 +93,7 @@ 57@@ -93,6 +93,7 @@ SUITE(authentication_tests)
58 return false; 58 return false;
59 } 59 }
60 60
@@ -62,46 +62,15 @@ Index: cpprest/Release/tests/functional/websockets/client/authentication_tests.c
62 TEST(ssl_test) 62 TEST(ssl_test)
63 { 63 {
64 websocket_client client; 64 websocket_client client;
65@@ -127,6 +128,7 @@ 65@@ -127,6 +128,7 @@ SUITE(authentication_tests)
66 throw; 66 throw;
67 } 67 }
68 } 68 }
69+ */ 69+ */
70 70
71 // These tests are specific to our websocketpp based implementation.
72 #if !defined(__cplusplus_winrt)
73@@ -159,12 +161,14 @@
74 }
75 }
76
77+ /*
78 // Test specifically for server SignalR team hit interesting cases with.
79 TEST(sni_with_older_server_test)
80 {
81 websocket_client client;
82 sni_test_impl(client);
83 }
84+ */
85
86 // WinRT doesn't expose option for disabling.
87 // No stable server is available to reliably test this.
88@@ -194,6 +198,7 @@
89 }
90 }
91
92+ /*
93 // Winrt doesn't allow explicitly setting server host for SNI.
94 TEST(sni_explicit_hostname)
95 {
96@@ -204,6 +209,7 @@
97 websocket_client client(config);
98 sni_test_impl(client);
99 }
100+ */
101
102 void handshake_error_test_impl(const ::utility::string_t& host) 71 void handshake_error_test_impl(const ::utility::string_t& host)
103 { 72 {
104@@ -225,11 +231,11 @@ 73@@ -148,11 +150,11 @@ SUITE(authentication_tests)
105 } 74 }
106 } 75 }
107 76
@@ -114,13 +83,13 @@ Index: cpprest/Release/tests/functional/websockets/client/authentication_tests.c
114- TEST(cert_expired) { handshake_error_test_impl(U("wss://expired.badssl.com/")); } 83- TEST(cert_expired) { handshake_error_test_impl(U("wss://expired.badssl.com/")); }
115+ //TEST(cert_expired) { handshake_error_test_impl(U("wss://expired.badssl.com/")); } 84+ //TEST(cert_expired) { handshake_error_test_impl(U("wss://expired.badssl.com/")); }
116 85
117 #endif 86 } // SUITE(authentication_tests)
118 87
119Index: cpprest/Release/tests/functional/http/client/connections_and_errors.cpp 88Index: cpprest/Release/tests/functional/http/client/connections_and_errors.cpp
120=================================================================== 89===================================================================
121--- cpprest.orig/Release/tests/functional/http/client/connections_and_errors.cpp 90--- cpprest.orig/Release/tests/functional/http/client/connections_and_errors.cpp
122+++ cpprest/Release/tests/functional/http/client/connections_and_errors.cpp 91+++ cpprest/Release/tests/functional/http/client/connections_and_errors.cpp
123@@ -406,6 +406,7 @@ 92@@ -408,6 +408,7 @@
124 } 93 }
125 #endif 94 #endif
126 95
@@ -128,7 +97,7 @@ Index: cpprest/Release/tests/functional/http/client/connections_and_errors.cpp
128 // Try to connect to a server on a closed port and cancel the operation. 97 // Try to connect to a server on a closed port and cancel the operation.
129 TEST_FIXTURE(uri_address, cancel_bad_port) 98 TEST_FIXTURE(uri_address, cancel_bad_port)
130 { 99 {
131@@ -437,6 +438,7 @@ 100@@ -439,6 +440,7 @@
132 101
133 VERIFY_THROWS_HTTP_ERROR_CODE(t.get(), std::errc::operation_canceled); 102 VERIFY_THROWS_HTTP_ERROR_CODE(t.get(), std::errc::operation_canceled);
134 } 103 }
diff --git a/meta-oe/recipes-support/cpprest/cpprest_2.10.14.bb b/meta-oe/recipes-support/cpprest/cpprest_2.10.15.bb
index 11c8eab55..dee5ae256 100644
--- a/meta-oe/recipes-support/cpprest/cpprest_2.10.14.bb
+++ b/meta-oe/recipes-support/cpprest/cpprest_2.10.15.bb
@@ -11,8 +11,8 @@ SRC_URI = "git://github.com/Microsoft/cpprestsdk.git;protocol=https;branch=maste
11 file://disable-float-tests.patch \ 11 file://disable-float-tests.patch \
12 file://disable-outside-tests.patch " 12 file://disable-outside-tests.patch "
13 13
14# tag 2.10.14 14# tag 2.10.15
15SRCREV= "6f602bee67b088a299d7901534af3bce6334ab38" 15SRCREV= "b94bc32ff84e815ba44c567f6fe4af5f5f6b3048"
16 16
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18 18