diff options
author | Mingli Yu <mingli.yu@windriver.com> | 2023-09-19 14:15:29 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-09-20 15:34:02 -0700 |
commit | 34da641add0387fbf88b4f0a6299b2039518c048 (patch) | |
tree | ef051db4212302f892f69d252549511eecae55ad /meta-oe/recipes-support | |
parent | 68af2b34bc7c4ce6b9e930bbcde0bd6872e56abb (diff) | |
download | meta-openembedded-34da641add0387fbf88b4f0a6299b2039518c048.tar.gz |
hdf5: Upgrade to 1.14.2
License Update: link update
from http://support.hdfgroup.org/ftp/HDF5/releases/COPYING_LBNL_HDF5 to
https://raw.githubusercontent.com/hdfgroup/hdf5/develop/COPYING_LBNL_HDF5.
Rework the patch 0001-cmake-remove-build-flags.patch to fix the build path
issue.
Add zlib depends to fix the below failure:
/build/tmp/work/core2-64-poky-linux/hdf5/1.14.2/recipe-sysroot-native/usr/bin/x86_64-poky-linux/../../libexec/x86_64-poky-linux/gcc/x86_64-poky-linux/13.2.0/ld: bin/libhdf5.so.310.2.0: undefined reference to `inflateEnd'
/build/tmp/work/core2-64-poky-linux/hdf5/1.14.2/recipe-sysroot-native/usr/bin/x86_64-poky-linux/../../libexec/x86_64-poky-linux/gcc/x86_64-poky-linux/13.2.0/ld: bin/libhdf5.so.310.2.0: undefined reference to `inflate'
/build/tmp/work/core2-64-poky-linux/hdf5/1.14.2/recipe-sysroot-native/usr/bin/x86_64-poky-linux/../../libexec/x86_64-poky-linux/gcc/x86_64-poky-linux/13.2.0/ld: bin/libhdf5.so.310.2.0: undefined reference to `compress2'
/build/tmp/work/core2-64-poky-linux/hdf5/1.14.2/recipe-sysroot-native/usr/bin/x86_64-poky-linux/../../libexec/x86_64-poky-linux/gcc/x86_64-poky-linux/13.2.0/ld: bin/libhdf5.so.310.2.0: undefined reference to `inflateInit_'
collect2: error: ld returned 1 exit status
Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r-- | meta-oe/recipes-support/hdf5/files/0001-cmake-remove-build-flags.patch | 98 | ||||
-rw-r--r-- | meta-oe/recipes-support/hdf5/hdf5_1.14.2.bb (renamed from meta-oe/recipes-support/hdf5/hdf5_1.14.0.bb) | 11 |
2 files changed, 76 insertions, 33 deletions
diff --git a/meta-oe/recipes-support/hdf5/files/0001-cmake-remove-build-flags.patch b/meta-oe/recipes-support/hdf5/files/0001-cmake-remove-build-flags.patch index a8050cc55..68d9c3a3c 100644 --- a/meta-oe/recipes-support/hdf5/files/0001-cmake-remove-build-flags.patch +++ b/meta-oe/recipes-support/hdf5/files/0001-cmake-remove-build-flags.patch | |||
@@ -1,58 +1,96 @@ | |||
1 | From 39572baac462f16b39dc385751d5c642646718d3 Mon Sep 17 00:00:00 2001 | 1 | From 4fa437782261c0da785d4574ad3a03700f624e66 Mon Sep 17 00:00:00 2001 |
2 | From: Mingli Yu <mingli.yu@windriver.com> | 2 | From: Mingli Yu <mingli.yu@windriver.com> |
3 | Date: Wed, 4 Aug 2021 17:05:10 +0800 | 3 | Date: Tue, 19 Sep 2023 02:56:09 +0000 |
4 | Subject: [PATCH] cmake: remove build flags | 4 | Subject: [PATCH] cmake: remove build flags |
5 | 5 | ||
6 | Remove the build flags to improve reproducibility. | 6 | Don't generate the build host related info and reemove the build flags |
7 | to improve reproducibility. | ||
7 | 8 | ||
8 | Upstream-Status: Inappropriate [oe specific] | 9 | Upstream-Status: Inappropriate [oe specific] |
9 | 10 | ||
10 | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> | 11 | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> |
11 | --- | 12 | --- |
12 | config/cmake/libh5cc.in | 2 +- | 13 | config/cmake/libhdf5.settings.cmake.in | 18 +++++++++--------- |
13 | config/cmake/libhdf5.settings.cmake.in | 12 ++++++------ | 14 | src/H5make_libsettings.c | 17 ----------------- |
14 | 2 files changed, 7 insertions(+), 7 deletions(-) | 15 | 2 files changed, 9 insertions(+), 26 deletions(-) |
15 | 16 | ||
16 | --- a/config/cmake/libh5cc.in | 17 | diff --git a/config/cmake/libhdf5.settings.cmake.in b/config/cmake/libhdf5.settings.cmake.in |
17 | +++ b/config/cmake/libh5cc.in | 18 | index f60f0de..f4433c0 100644 |
18 | @@ -44,7 +44,7 @@ for arg in $@ ; do | ||
19 | exit $status | ||
20 | ;; | ||
21 | *) | ||
22 | - @_PKG_CONFIG_COMPILER@ $@ `pkg-config --define-variable=prefix=$dir --cflags --libs @_PKG_CONFIG_LIBNAME@` | ||
23 | + `pkg-config --define-variable=prefix=$dir --cflags --libs @_PKG_CONFIG_LIBNAME@-@_PKG_CONFIG_VERSION@` $@ | ||
24 | status=$? | ||
25 | exit $status | ||
26 | ;; | ||
27 | --- a/config/cmake/libhdf5.settings.cmake.in | 19 | --- a/config/cmake/libhdf5.settings.cmake.in |
28 | +++ b/config/cmake/libhdf5.settings.cmake.in | 20 | +++ b/config/cmake/libhdf5.settings.cmake.in |
29 | @@ -27,14 +27,14 @@ Linking Options: | 21 | @@ -23,23 +23,23 @@ Linking Options: |
22 | ---------------- | ||
23 | Libraries: @BUILD_NAME_EXT@ | ||
24 | Statically Linked Executables: @BUILD_STATIC_EXECS@ | ||
25 | - LDFLAGS: @CMAKE_SHARED_LINKER_FLAGS@ | ||
26 | + LDFLAGS: | ||
30 | H5_LDFLAGS: @H5_LDFLAGS@ | 27 | H5_LDFLAGS: @H5_LDFLAGS@ |
31 | AM_LDFLAGS: @AM_LDFLAGS@ | 28 | AM_LDFLAGS: @AM_LDFLAGS@ |
32 | Extra libraries: @LINK_LIBS@ | 29 | Extra libraries: @LINK_LIBS@ |
33 | - Archiver: @CMAKE_AR@ | 30 | - Archiver: @CMAKE_AR@ |
31 | - AR_FLAGS: | ||
34 | - Ranlib: @CMAKE_RANLIB@ | 32 | - Ranlib: @CMAKE_RANLIB@ |
35 | + Archiver: | 33 | + Archiver: |
34 | + AR_FLAGS: | ||
36 | + Ranlib: | 35 | + Ranlib: |
37 | 36 | ||
38 | Languages: | 37 | Languages: |
39 | ---------- | 38 | ---------- |
40 | C: YES | 39 | C: YES |
41 | - C Compiler: @CMAKE_C_COMPILER@ @CMAKE_C_COMPILER_VERSION@ | 40 | - C Compiler: @CMAKE_C_COMPILER@ @CMAKE_C_COMPILER_VERSION@ |
42 | - CPPFLAGS: @CPPFLAGS@ | ||
43 | + C Compiler: | 41 | + C Compiler: |
44 | + CPPFLAGS: | 42 | CPPFLAGS: @CPPFLAGS@ |
45 | H5_CPPFLAGS: @H5_CPPFLAGS@ | 43 | H5_CPPFLAGS: @H5_CPPFLAGS@ |
46 | AM_CPPFLAGS: @AM_CPPFLAGS@ | 44 | AM_CPPFLAGS: @AM_CPPFLAGS@ |
47 | CFLAGS: @CMAKE_C_FLAGS@ | 45 | - CFLAGS: @CMAKE_C_FLAGS@ |
48 | @@ -53,8 +53,8 @@ Languages: | 46 | - H5_CFLAGS: @HDF5_CMAKE_C_FLAGS@ |
49 | @BUILD_FORTRAN_CONDITIONAL_TRUE@ Module Directory: @CMAKE_Fortran_MODULE_DIRECTORY@ | 47 | + CFLAGS: |
48 | + H5_CFLAGS: | ||
49 | AM_CFLAGS: @AM_CFLAGS@ | ||
50 | Shared C Library: @H5_ENABLE_SHARED_LIB@ | ||
51 | Static C Library: @H5_ENABLE_STATIC_LIB@ | ||
52 | @@ -51,11 +51,11 @@ Languages: | ||
53 | AM Fortran Flags: @AM_FCFLAGS@ | ||
54 | Shared Fortran Library: @H5_ENABLE_SHARED_LIB@ | ||
55 | Static Fortran Library: @H5_ENABLE_STATIC_LIB@ | ||
56 | - Module Directory: @CMAKE_Fortran_MODULE_DIRECTORY@ | ||
57 | + Module Directory: | ||
50 | 58 | ||
51 | C++: @HDF5_BUILD_CPP_LIB@ | 59 | C++: @HDF5_BUILD_CPP_LIB@ |
52 | -@BUILD_CXX_CONDITIONAL_TRUE@ C++ Compiler: @CMAKE_CXX_COMPILER@ @CMAKE_CXX_COMPILER_VERSION@ | 60 | C++ Compiler: @CMAKE_CXX_COMPILER@ @CMAKE_CXX_COMPILER_VERSION@ |
53 | -@BUILD_CXX_CONDITIONAL_TRUE@ C++ Flags: @CMAKE_CXX_FLAGS@ | 61 | - C++ Flags: @CMAKE_CXX_FLAGS@ |
54 | +@BUILD_CXX_CONDITIONAL_TRUE@ C++ Compiler: | 62 | + C++ Flags: |
55 | +@BUILD_CXX_CONDITIONAL_TRUE@ C++ Flags: | 63 | H5 C++ Flags: @HDF5_CMAKE_CXX_FLAGS@ |
56 | @BUILD_CXX_CONDITIONAL_TRUE@ H5 C++ Flags: @HDF5_CMAKE_CXX_FLAGS@ | 64 | AM C++ Flags: @AM_CXXFLAGS@ |
57 | @BUILD_CXX_CONDITIONAL_TRUE@ AM C++ Flags: @AM_CXXFLAGS@ | 65 | Shared C++ Library: @H5_ENABLE_SHARED_LIB@ |
58 | @BUILD_CXX_CONDITIONAL_TRUE@ Shared C++ Library: @H5_ENABLE_SHARED_LIB@ | 66 | diff --git a/src/H5make_libsettings.c b/src/H5make_libsettings.c |
67 | index 2661288..7c0f84f 100644 | ||
68 | --- a/src/H5make_libsettings.c | ||
69 | +++ b/src/H5make_libsettings.c | ||
70 | @@ -205,23 +205,6 @@ information about the library build configuration\n"; | ||
71 | fprintf(rawoutstream, "/* Generated automatically by H5make_libsettings -- do not edit */\n\n\n"); | ||
72 | fputs(FileHeader, rawoutstream); /*the copyright notice--see top of this file */ | ||
73 | |||
74 | - fprintf(rawoutstream, " *\n * Created:\t\t%s %2d, %4d\n", month_name[tm->tm_mon], tm->tm_mday, | ||
75 | - 1900 + tm->tm_year); | ||
76 | - if (pwd || real_name[0] || host_name[0]) { | ||
77 | - fprintf(rawoutstream, " *\t\t\t"); | ||
78 | - if (real_name[0]) | ||
79 | - fprintf(rawoutstream, "%s <", real_name); | ||
80 | -#ifdef H5_HAVE_GETPWUID | ||
81 | - if (pwd) | ||
82 | - fputs(pwd->pw_name, rawoutstream); | ||
83 | -#endif | ||
84 | - if (host_name[0]) | ||
85 | - fprintf(rawoutstream, "@%s", host_name); | ||
86 | - if (real_name[0]) | ||
87 | - fprintf(rawoutstream, ">"); | ||
88 | - fputc('\n', rawoutstream); | ||
89 | - } | ||
90 | - | ||
91 | fprintf(rawoutstream, " *\n * Purpose:\t\t"); | ||
92 | |||
93 | for (s = purpose; *s; s++) { | ||
94 | -- | ||
95 | 2.35.5 | ||
96 | |||
diff --git a/meta-oe/recipes-support/hdf5/hdf5_1.14.0.bb b/meta-oe/recipes-support/hdf5/hdf5_1.14.2.bb index d0ff2ef48..68b91c0b0 100644 --- a/meta-oe/recipes-support/hdf5/hdf5_1.14.0.bb +++ b/meta-oe/recipes-support/hdf5/hdf5_1.14.2.bb | |||
@@ -5,18 +5,18 @@ HOMEPAGE = "https://www.hdfgroup.org/" | |||
5 | SECTION = "libs" | 5 | SECTION = "libs" |
6 | 6 | ||
7 | LICENSE = "HDF5" | 7 | LICENSE = "HDF5" |
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=ac1039f6bf7c9ab2b3693836f46d0735" | 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=9ba0f3d878ab6c2403c86e9b0362d998" |
9 | 9 | ||
10 | inherit cmake siteinfo qemu multilib_header | 10 | inherit cmake siteinfo qemu multilib_header |
11 | 11 | ||
12 | DEPENDS += "qemu-native" | 12 | DEPENDS += "qemu-native zlib" |
13 | 13 | ||
14 | SRC_URI = " \ | 14 | SRC_URI = " \ |
15 | https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.14/hdf5-${PV}/src/${BPN}-${PV}.tar.bz2 \ | 15 | https://support.hdfgroup.org/ftp/HDF5/releases/hdf5-1.14/hdf5-${PV}/src/${BPN}-${PV}.tar.bz2 \ |
16 | file://0002-Remove-suffix-shared-from-shared-library-name.patch \ | 16 | file://0002-Remove-suffix-shared-from-shared-library-name.patch \ |
17 | file://0001-cmake-remove-build-flags.patch \ | 17 | file://0001-cmake-remove-build-flags.patch \ |
18 | " | 18 | " |
19 | SRC_URI[sha256sum] = "e4e79433450edae2865a4c6328188bb45391b29d74f8c538ee699f0b116c2ba0" | 19 | SRC_URI[sha256sum] = "ea3c5e257ef322af5e77fc1e52ead3ad6bf3bb4ac06480dd17ee3900d7a24cfb" |
20 | 20 | ||
21 | FILES:${PN} += "${libdir}/libhdf5.settings ${datadir}/*" | 21 | FILES:${PN} += "${libdir}/libhdf5.settings ${datadir}/*" |
22 | 22 | ||
@@ -45,6 +45,11 @@ do_install:append() { | |||
45 | install -m 755 ${B}/bin/H5detect ${D}${bindir} | 45 | install -m 755 ${B}/bin/H5detect ${D}${bindir} |
46 | install -m 755 ${B}/bin/H5make_libsettings ${D}${bindir} | 46 | install -m 755 ${B}/bin/H5make_libsettings ${D}${bindir} |
47 | oe_multilib_header H5pubconf.h | 47 | oe_multilib_header H5pubconf.h |
48 | # remove the buildpath | ||
49 | sed -i -e 's|${RECIPE_SYSROOT}||g' ${D}${libdir}/pkgconfig/hdf5.pc | ||
50 | sed -i -e 's|${RECIPE_SYSROOT}||g' ${D}${libdir}/cmake/hdf5-targets.cmake | ||
51 | sed -i -e 's|${RECIPE_SYSROOT_NATIVE}||g' ${D}${bindir}/h5hlcc | ||
52 | sed -i -e 's|${RECIPE_SYSROOT_NATIVE}||g' ${D}${bindir}/h5cc | ||
48 | } | 53 | } |
49 | 54 | ||
50 | BBCLASSEXTEND = "native" | 55 | BBCLASSEXTEND = "native" |