summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorVyacheslav Yurkov <uvv.mail@gmail.com>2018-10-08 11:17:49 +0200
committerKhem Raj <raj.khem@gmail.com>2018-10-08 09:52:04 -0700
commit2d842ee7a3d0f38ca9735246b694c5093e8130d7 (patch)
tree4c4236de75668e38718ef278fdf23865f3c01f43 /meta-oe/recipes-support
parent463fd3dff33457ba8fc519a2716f3270e054d533 (diff)
downloadmeta-openembedded-2d842ee7a3d0f38ca9735246b694c5093e8130d7.tar.gz
glog: upgrade 0.3.4 -> 0.3.5
Upgraded glog recipe to a new stable version in favor of cmake configuration Old configure.ac patch is removed. Another cmake patch is added. When UNWIND_LIBRARY is used directly as a public dependency then absolute path is stored in cmake config file. This is an issue when glog is used as part of generated SDK, which was built on another machine. When SDK is installed on developer's machine, cmake config contains a full path to non-existent location. The solution is to find libunwind during configure stage and store target name as a dependency, not a full path Signed-off-by: Vyacheslav Yurkov <uvv.mail@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/glog/glog/0001-configure.ac-Allow-user-to-disable-gflags.patch35
-rw-r--r--meta-oe/recipes-support/glog/glog/0001-find-libunwind-during-configure.patch30
-rw-r--r--meta-oe/recipes-support/glog/glog_0.3.5.bb (renamed from meta-oe/recipes-support/glog/glog_0.3.4.bb)13
3 files changed, 37 insertions, 41 deletions
diff --git a/meta-oe/recipes-support/glog/glog/0001-configure.ac-Allow-user-to-disable-gflags.patch b/meta-oe/recipes-support/glog/glog/0001-configure.ac-Allow-user-to-disable-gflags.patch
deleted file mode 100644
index 596281ff68..0000000000
--- a/meta-oe/recipes-support/glog/glog/0001-configure.ac-Allow-user-to-disable-gflags.patch
+++ /dev/null
@@ -1,35 +0,0 @@
1From 0fabde0515e180c53961c27346dd7a79cffa4c1f Mon Sep 17 00:00:00 2001
2From: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com>
3Date: Thu, 11 Aug 2016 11:49:36 +0200
4Subject: [PATCH] configure.ac: Allow user to disable gflags
5
6Under some circumstances like cross-compilation, the user might not want
7to enable support for gflags.
8
9This patch allows support for --without-gflags
10
11Signed-off-by: Ricardo Ribalda Delgado <ricardo.ribalda@gmail.com>
12---
13 configure.ac | 6 +++++-
14 1 file changed, 5 insertions(+), 1 deletion(-)
15
16diff --git a/configure.ac b/configure.ac
17index 7b4d21e7ae8a..eba5e5cda1ea 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -136,7 +136,11 @@ AC_ARG_WITH(gflags, AS_HELP_STRING[--with-gflags=GFLAGS_DIR],
21 CFLAGS="$CFLAGS $GFLAGS_CFLAGS"
22 LIBS="$LIBS $GFLAGS_LIBS"
23 )
24-AC_CHECK_LIB(gflags, main, ac_cv_have_libgflags=1, ac_cv_have_libgflags=0)
25+if test x"$with_gflags" = x"no"; then
26+ ac_cv_have_libgflags=0
27+else
28+ AC_CHECK_LIB(gflags, main, ac_cv_have_libgflags=1, ac_cv_have_libgflags=0)
29+fi
30 if test x"$ac_cv_have_libgflags" = x"1"; then
31 AC_DEFINE(HAVE_LIB_GFLAGS, 1, [define if you have google gflags library])
32 if test x"$GFLAGS_LIBS" = x""; then
33--
342.8.1
35
diff --git a/meta-oe/recipes-support/glog/glog/0001-find-libunwind-during-configure.patch b/meta-oe/recipes-support/glog/glog/0001-find-libunwind-during-configure.patch
new file mode 100644
index 0000000000..33dc9d38a2
--- /dev/null
+++ b/meta-oe/recipes-support/glog/glog/0001-find-libunwind-during-configure.patch
@@ -0,0 +1,30 @@
1diff -ur git/CMakeLists.txt ../0.3.5-r0.unwind/git/CMakeLists.txt
2--- git/CMakeLists.txt 2018-10-08 08:54:15.118989400 +0200
3+++ ../0.3.5-r0.unwind/git/CMakeLists.txt 2018-10-05 16:26:59.745922318 +0200
4@@ -384,7 +384,9 @@
5 set_target_properties (glog PROPERTIES POSITION_INDEPENDENT_CODE ON)
6
7 if (UNWIND_LIBRARY)
8- target_link_libraries (glog PUBLIC ${UNWIND_LIBRARY})
9+ add_library(unwind SHARED IMPORTED)
10+ set_target_properties(unwind PROPERTIES IMPORTED_LOCATION ${UNWIND_LIBRARY})
11+ target_link_libraries (glog PUBLIC unwind)
12 endif (UNWIND_LIBRARY)
13
14 if (HAVE_PTHREAD)
15diff -ur git/glog-config.cmake.in ../0.3.5-r0.unwind/git/glog-config.cmake.in
16--- git/glog-config.cmake.in 2018-10-08 08:54:15.122989699 +0200
17+++ ../0.3.5-r0.unwind/git/glog-config.cmake.in 2018-10-08 08:14:48.550745810 +0200
18@@ -4,4 +4,12 @@
19
20 @gflags_DEPENDENCY@
21
22+find_library (UNWIND_LIBRARY NAMES unwind DOC "unwind library")
23+mark_as_advanced (UNWIND_LIBRARY)
24+
25+if (UNWIND_LIBRARY)
26+ add_library(unwind SHARED IMPORTED)
27+ set_target_properties(unwind PROPERTIES IMPORTED_LOCATION ${UNWIND_LIBRARY})
28+endif (UNWIND_LIBRARY)
29+
30 include ("${CMAKE_CURRENT_LIST_DIR}/glog-targets.cmake")
diff --git a/meta-oe/recipes-support/glog/glog_0.3.4.bb b/meta-oe/recipes-support/glog/glog_0.3.5.bb
index d7c1974c68..bf7df53f3f 100644
--- a/meta-oe/recipes-support/glog/glog_0.3.4.bb
+++ b/meta-oe/recipes-support/glog/glog_0.3.5.bb
@@ -9,15 +9,16 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=dc9db360e0bbd4e46672f3fd91dd6c4b"
9DEPENDS = "libunwind" 9DEPENDS = "libunwind"
10 10
11SRC_URI = " \ 11SRC_URI = " \
12 git://github.com/google/glog.git \ 12 git://github.com/google/glog.git;branch=v035 \
13 file://0001-configure.ac-Allow-user-to-disable-gflags.patch \ 13 file://0001-find-libunwind-during-configure.patch \
14" 14"
15 15
16SRCREV = "d8cb47f77d1c31779f3ff890e1a5748483778d6a" 16SRCREV = "a6a166db069520dbbd653c97c2e5b12e08a8bb26"
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19 19
20PACKAGECONFIG ??= "" 20inherit cmake
21PACKAGECONFIG[gflags] = ",--without-gflags,gflags,"
22 21
23inherit autotools pkgconfig 22RDEPENDS_${PN}-dev = ""
23RRECOMMENDS_${PN}-dev = "${PN}-staticdev"
24RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})"