summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2018-03-18 20:08:33 +0100
committerArmin Kuster <akuster808@gmail.com>2018-03-29 16:45:05 -0700
commit2a8a5b5cd0258657e145f65f54c3145e42116f7c (patch)
treed90faf0a51bc39f728afb29145ada94b2334591d /meta-oe/recipes-support
parent2a3bc6d719068bd71b7c6daae200fce2c0958ead (diff)
downloadmeta-openembedded-2a8a5b5cd0258657e145f65f54c3145e42116f7c.tar.gz
poppler: update 0.57.0 -> 0.62.0
* poppler moved from autotools to cmake * qt4 backend was removed * build tested with all and none in packageconfig Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/poppler/poppler/0001-Do-not-overwrite-all-our-build-flags.patch36
-rw-r--r--meta-oe/recipes-support/poppler/poppler/0001-add-manadatory-options-to-find-qt4-qt5-moc.patch91
-rw-r--r--meta-oe/recipes-support/poppler/poppler/0002-fix-gcc-6-math-ambiguous-errors.patch11
-rw-r--r--meta-oe/recipes-support/poppler/poppler_0.57.0.bb55
-rw-r--r--meta-oe/recipes-support/poppler/poppler_0.62.0.bb55
5 files changed, 91 insertions, 157 deletions
diff --git a/meta-oe/recipes-support/poppler/poppler/0001-Do-not-overwrite-all-our-build-flags.patch b/meta-oe/recipes-support/poppler/poppler/0001-Do-not-overwrite-all-our-build-flags.patch
new file mode 100644
index 000000000..5b66a8a9c
--- /dev/null
+++ b/meta-oe/recipes-support/poppler/poppler/0001-Do-not-overwrite-all-our-build-flags.patch
@@ -0,0 +1,36 @@
1From b6fc6c36d359a50503138cd87d7147faf6dff893 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@gmail.com>
3Date: Sat, 17 Mar 2018 20:52:10 +0100
4Subject: [PATCH] Do not overwrite all our build flags
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstream-Status: Inappropriate [embedded specific]
10
11Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
12---
13 cmake/modules/PopplerMacros.cmake | 2 ++
14 1 file changed, 2 insertions(+)
15
16diff --git a/cmake/modules/PopplerMacros.cmake b/cmake/modules/PopplerMacros.cmake
17index ccb2790..f29481e 100644
18--- a/cmake/modules/PopplerMacros.cmake
19+++ b/cmake/modules/PopplerMacros.cmake
20@@ -98,6 +98,7 @@ if(NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CONFIGURATION_TYPES)
21 set(CMAKE_BUILD_TYPE RelWithDebInfo)
22 endif(NOT CMAKE_BUILD_TYPE AND NOT CMAKE_CONFIGURATION_TYPES)
23
24+if(false)
25 if(CMAKE_COMPILER_IS_GNUCXX)
26 # set the default compile warnings
27 set(_warn "-Wall -Wextra -Wpedantic")
28@@ -159,4 +160,5 @@ if(CMAKE_C_COMPILER MATCHES "icc")
29 set(CMAKE_C_FLAGS_DEBUG "-O2 -g -Ob0 -noalign ${_save_cflags}")
30 set(CMAKE_C_FLAGS_DEBUGFULL "-g -Ob0 -noalign ${_save_cflags}")
31 endif(CMAKE_C_COMPILER MATCHES "icc")
32+endif(false)
33
34--
352.14.3
36
diff --git a/meta-oe/recipes-support/poppler/poppler/0001-add-manadatory-options-to-find-qt4-qt5-moc.patch b/meta-oe/recipes-support/poppler/poppler/0001-add-manadatory-options-to-find-qt4-qt5-moc.patch
deleted file mode 100644
index 4e80d240f..000000000
--- a/meta-oe/recipes-support/poppler/poppler/0001-add-manadatory-options-to-find-qt4-qt5-moc.patch
+++ /dev/null
@@ -1,91 +0,0 @@
1From 91b6275f0e91c25beb040b4ef9484053ae305d86 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Tue, 26 May 2015 12:45:47 +0200
4Subject: [PATCH] add manadatory options to find qt4/qt5 moc
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Upstream-Status: Inappropriate [OE specific]
10
11Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
12---
13 configure.ac | 55 ++++++++-----------------------------------------------
14 1 file changed, 8 insertions(+), 47 deletions(-)
15
16diff --git a/configure.ac b/configure.ac
17index c4cfc2c..8e961c7 100644
18--- a/configure.ac
19+++ b/configure.ac
20@@ -712,25 +712,10 @@ AC_SUBST(POPPLER_QT4_LIBS)
21 AC_SUBST(POPPLER_QT4_TEST_LIBS)
22
23 if test x$enable_poppler_qt4 = xyes; then
24- AC_CHECK_TOOL(MOCQT4, moc)
25- AC_MSG_CHECKING([for Qt4 moc])
26- mocversion=`$MOCQT4 -v 2>&1`
27- mocversiongrep=`echo $mocversion | grep "Qt 4"`
28- if test x"$mocversiongrep" != x"$mocversion"; then
29- AC_MSG_RESULT([no])
30- # moc was not the qt4 one, try with moc-qt4
31- AC_CHECK_TOOL(MOCQT42, moc-qt4)
32- AC_MSG_CHECKING([for Qt4 moc-qt4])
33- mocversion=`$MOCQT42 -v 2>&1`
34- mocversiongrep=`echo $mocversion | grep "Qt 4"`
35- if test x"$mocversiongrep" != x"$mocversion"; then
36- # no valid moc found
37- enable_poppler_qt4=no;
38- MOCQT4="not found"
39- else
40- MOCQT4=$MOCQT42
41- fi
42- fi
43+ AC_ARG_WITH([moc-qt4],
44+ AS_HELP_STRING([--with-moc-qt4], [Set location of qt4 moc]),
45+ [MOCQT4=$withval]
46+ )
47 AC_SUBST(MOCQT4)
48 AC_MSG_RESULT([$MOCQT4])
49 fi
50@@ -769,34 +754,10 @@ AC_SUBST(POPPLER_QT5_LIBS)
51 AC_SUBST(POPPLER_QT5_TEST_LIBS)
52
53 if test x$enable_poppler_qt5 = xyes; then
54- AC_CHECK_TOOL(MOCQT5, moc)
55- AC_MSG_CHECKING([for Qt5 moc])
56- mocversion=`$MOCQT5 -v 2>&1`
57- mocversiongrep=`echo $mocversion | grep -E "Qt 5|moc 5"`
58- if test x"$mocversiongrep" != x"$mocversion"; then
59- AC_MSG_RESULT([no])
60- # moc was not the qt5 one, try with moc-qt5
61- AC_CHECK_TOOL(MOCQT52, moc-qt5)
62- AC_MSG_CHECKING([for Qt5 moc-qt5])
63- mocversion=`$MOCQT52 -v 2>&1`
64- mocversiongrep=`echo $mocversion | grep -E "Qt 5|moc-qt5 5|moc 5"`
65- if test x"$mocversiongrep" != x"$mocversion"; then
66- AC_CHECK_TOOL(QTCHOOSER, qtchooser)
67- AC_MSG_CHECKING([for qtchooser])
68- qt5tooldir=`QT_SELECT=qt5 qtchooser -print-env | grep QTTOOLDIR | cut -d '=' -f 2 | cut -d \" -f 2`
69- mocversion=`$qt5tooldir/moc -v 2>&1`
70- mocversiongrep=`echo $mocversion | grep -E "Qt 5|moc 5"`
71- if test x"$mocversiongrep" != x"$mocversion"; then
72- # no valid moc found
73- enable_poppler_qt5=no;
74- MOCQT5="not found"
75- else
76- MOCQT5=$qt5tooldir/moc
77- fi
78- else
79- MOCQT5=$MOCQT52
80- fi
81- fi
82+ AC_ARG_WITH([moc-qt5],
83+ AS_HELP_STRING([--with-moc-qt5], [Set location of qt5 moc]),
84+ [MOCQT5=$withval]
85+ )
86 AC_SUBST(MOCQT5)
87 AC_MSG_RESULT([$MOCQT5])
88 fi
89--
902.5.5
91
diff --git a/meta-oe/recipes-support/poppler/poppler/0002-fix-gcc-6-math-ambiguous-errors.patch b/meta-oe/recipes-support/poppler/poppler/0002-fix-gcc-6-math-ambiguous-errors.patch
deleted file mode 100644
index 406009f4f..000000000
--- a/meta-oe/recipes-support/poppler/poppler/0002-fix-gcc-6-math-ambiguous-errors.patch
+++ /dev/null
@@ -1,11 +0,0 @@
1--- poppler-0.45.0/poppler/CairoOutputDev.cc.orig 2016-06-17 14:23:35.399083929 -0400
2+++ poppler-0.45.0/poppler/CairoOutputDev.cc 2016-06-17 14:36:53.351097825 -0400
3@@ -42,7 +42,7 @@
4 #endif
5
6 #include <string.h>
7-#include <math.h>
8+#include <cmath>
9 #include <assert.h>
10 #include <cairo.h>
11
diff --git a/meta-oe/recipes-support/poppler/poppler_0.57.0.bb b/meta-oe/recipes-support/poppler/poppler_0.57.0.bb
deleted file mode 100644
index 63b77aafe..000000000
--- a/meta-oe/recipes-support/poppler/poppler_0.57.0.bb
+++ /dev/null
@@ -1,55 +0,0 @@
1SUMMARY = "Poppler is a PDF rendering library based on the xpdf-3.0 code base"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4
5SRC_URI = " \
6 http://poppler.freedesktop.org/${BP}.tar.xz \
7 file://0001-add-manadatory-options-to-find-qt4-qt5-moc.patch \
8 file://0002-fix-gcc-6-math-ambiguous-errors.patch \
9"
10SRC_URI[md5sum] = "bc5a191741604552c90d484103229374"
11SRC_URI[sha256sum] = "0ea37de71b7db78212ebc79df59f99b66409a29c2eac4d882dae9f2397fe44d8"
12
13DEPENDS = "fontconfig zlib cairo lcms"
14
15inherit autotools pkgconfig gtk-doc gobject-introspection
16
17PACKAGECONFIG ??= "jpeg openjpeg png tiff nss ${@bb.utils.contains('BBFILE_COLLECTIONS', 'qt5-layer', 'qt5', '', d)}"
18PACKAGECONFIG[jpeg] = "--enable-dctdecoder=libjpeg,--enable-dctdecoder=none,jpeg"
19PACKAGECONFIG[png] = "--enable-libpng,--disable-libpng,libpng"
20PACKAGECONFIG[tiff] = "--enable-libtiff,--disable-libtiff,tiff"
21PACKAGECONFIG[curl] = "--enable-libcurl,--disable-libcurl,curl"
22PACKAGECONFIG[openjpeg] = "--enable-libopenjpeg=openjpeg2,--disable-libopenjpeg,openjpeg"
23PACKAGECONFIG[qt5] = "--enable-poppler-qt5 --with-moc-qt5=${STAGING_BINDIR_NATIVE}/qt5/moc,--disable-poppler-qt5,qtbase qttools-native"
24PACKAGECONFIG[qt4e] = "--enable-poppler-qt4 --with-moc-qt4=${STAGING_BINDIR_NATIVE}/moc4,--disable-poppler-qt4,qt4-embedded"
25PACKAGECONFIG[nss] = "--enable-libnss,--disable-libnss,nss"
26
27SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
28
29EXTRA_OECONF = "\
30 --enable-xpdf-headers \
31 --disable-gtk-test \
32 --enable-zlib \
33"
34
35do_compile_prepend() {
36 export GIR_EXTRA_LIBS_PATH="${B}/poppler/.libs"
37}
38
39# Adjust library names when building for QT4e
40QT4E_PATCHES = "${@bb.utils.contains('PACKAGECONFIG', 'qt4e', 'file://fix-qt4e-library-dependencies.patch', '', d)}"
41SRC_URI_append = "${QT4E_PATCHES}"
42
43# check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
44def get_poppler_fpu_setting(bb, d):
45 if d.getVar('TARGET_FPU') in [ 'soft' ]:
46 return "--enable-fixedpoint"
47 return ""
48
49EXTRA_OECONF += "${@get_poppler_fpu_setting(bb, d)}"
50
51PACKAGES =+ "libpoppler libpoppler-glib"
52FILES_libpoppler = "${libdir}/libpoppler.so.*"
53FILES_libpoppler-glib = "${libdir}/libpoppler-glib.so.*"
54
55RDEPENDS_libpoppler = "poppler-data"
diff --git a/meta-oe/recipes-support/poppler/poppler_0.62.0.bb b/meta-oe/recipes-support/poppler/poppler_0.62.0.bb
new file mode 100644
index 000000000..696621938
--- /dev/null
+++ b/meta-oe/recipes-support/poppler/poppler_0.62.0.bb
@@ -0,0 +1,55 @@
1SUMMARY = "Poppler is a PDF rendering library based on the xpdf-3.0 code base"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
4
5SRC_URI = " \
6 http://poppler.freedesktop.org/${BP}.tar.xz \
7 file://0001-Do-not-overwrite-all-our-build-flags.patch \
8"
9SRC_URI[md5sum] = "42b801f2defaccb6b6cf1bf783ee1552"
10SRC_URI[sha256sum] = "5b9a73dfd4d6f61d165ada1e4f0abd2d420494bf9d0b1c15d0db3f7b83a729c6"
11
12DEPENDS = "fontconfig zlib cairo lcms"
13
14inherit cmake pkgconfig gobject-introspection
15
16PACKAGECONFIG ??= "jpeg openjpeg png tiff nss ${@bb.utils.contains('BBFILE_COLLECTIONS', 'qt5-layer', 'qt5', '', d)}"
17PACKAGECONFIG[jpeg] = "-DWITH_JPEG=ON -DENABLE_DCTDECODER=libjpeg,-DWITH_JPEG=OFF -DENABLE_DCTDECODER=none,jpeg"
18PACKAGECONFIG[png] = "-DWITH_PNG=ON,-DWITH_PNG=OFF,libpng"
19PACKAGECONFIG[tiff] = "-DWITH_TIFF=ON,-DWITH_TIFF=OFF,tiff"
20PACKAGECONFIG[curl] = "-DENABLE_LIBCURL=ON,-DENABLE_LIBCURL=OFF,curl"
21PACKAGECONFIG[openjpeg] = "-DENABLE_LIBOPENJPEG=openjpeg2,-DENABLE_LIBOPENJPEG=none,openjpeg"
22PACKAGECONFIG[qt5] = "-DENABLE_QT5=ON,-DENABLE_QT5=OFF,qtbase qttools-native"
23PACKAGECONFIG[nss] = "-DWITH_NSS3=ON,-DWITH_NSS3=OFF,nss"
24
25# surprise - did not expect this to work :)
26inherit ${@bb.utils.contains('PACKAGECONFIG', 'qt5', 'cmake_qt5', '', d)}
27
28SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
29
30EXTRA_OECMAKE += " \
31 -DENABLE_XPDF_HEADERS=ON \
32 -DBUILD_GTK_TESTS=OFF \
33 -DENABLE_ZLIB=ON \
34"
35
36do_configure_append() {
37 # poppler macro uses pkg-config to check for g-ir runtimes. Something
38 # makes them point to /usr/bin. Align them to sysroot - that's where the
39 # git-wrappers are:
40 sed -i 's: ${bindir}/g-ir: ${STAGING_BINDIR}/g-ir:' ${B}/build.ninja
41}
42
43# check for TARGET_FPU=soft and inform configure of the result so it can disable some floating points
44def get_poppler_fpu_setting(bb, d):
45 if d.getVar('TARGET_FPU') in [ 'soft' ]:
46 return "-DUSE_FIXEDPOINT=ON"
47 return ""
48
49EXTRA_OECMAKE += "${@get_poppler_fpu_setting(bb, d)}"
50
51PACKAGES =+ "libpoppler libpoppler-glib"
52FILES_libpoppler = "${libdir}/libpoppler.so.*"
53FILES_libpoppler-glib = "${libdir}/libpoppler-glib.so.*"
54
55RDEPENDS_libpoppler = "poppler-data"