summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-22 20:48:49 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-28 10:38:38 +0200
commit21f10c11f39020f9502d741c774a12d1aeb39499 (patch)
treefdc66c039950da89d82b6b7405ebfc50cbba693a /meta-oe/recipes-support
parent723b55f5c1f7df21dbcfa7cb2dcaecb10d886041 (diff)
downloadmeta-openembedded-21f10c11f39020f9502d741c774a12d1aeb39499.tar.gz
meta-oe: use bb.utils.contains() instead of base_contains()
base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support')
-rw-r--r--meta-oe/recipes-support/emacs/emacs.inc4
-rw-r--r--meta-oe/recipes-support/espeak/espeak_1.37.bb2
-rw-r--r--meta-oe/recipes-support/fftw/fftwf_3.3.4.bb2
-rw-r--r--meta-oe/recipes-support/gradm/gradm_3.1.bb4
-rw-r--r--meta-oe/recipes-support/libcanberra/libcanberra_0.30.bb6
-rw-r--r--meta-oe/recipes-support/libee/libee.inc2
-rw-r--r--meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.34.bb2
-rw-r--r--meta-oe/recipes-support/lm_sensors/lmsensors_3.4.0.bb2
-rw-r--r--meta-oe/recipes-support/lvm2/lvm2.inc4
-rw-r--r--meta-oe/recipes-support/openct/openct_0.6.20.bb4
-rw-r--r--meta-oe/recipes-support/openwbem/openwbem_3.2.3.bb4
-rw-r--r--meta-oe/recipes-support/postgresql/postgresql.inc2
-rw-r--r--meta-oe/recipes-support/syslog-ng/syslog-ng.inc6
-rw-r--r--meta-oe/recipes-support/udisks/udisks2_2.1.5.bb2
-rw-r--r--meta-oe/recipes-support/udisks/udisks_1.0.5.bb2
-rw-r--r--meta-oe/recipes-support/vim/vim_7.4.769.bb4
16 files changed, 26 insertions, 26 deletions
diff --git a/meta-oe/recipes-support/emacs/emacs.inc b/meta-oe/recipes-support/emacs/emacs.inc
index e706b18c9..ffb5c50c7 100644
--- a/meta-oe/recipes-support/emacs/emacs.inc
+++ b/meta-oe/recipes-support/emacs/emacs.inc
@@ -18,7 +18,7 @@ X11DEPENDS = " \
18 18
19EXTRA_OECONF = "--without-sound --with-crt-dir=${STAGING_LIBDIR} " 19EXTRA_OECONF = "--without-sound --with-crt-dir=${STAGING_LIBDIR} "
20 20
21PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" 21PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
22PACKAGECONFIG[x11] = "--with-x-toolkit=gtk,--without-x --without-dbus,${X11DEPENDS}" 22PACKAGECONFIG[x11] = "--with-x-toolkit=gtk,--without-x --without-dbus,${X11DEPENDS}"
23 23
24 24
@@ -86,7 +86,7 @@ do_compile_prepend() {
86 ${STAGING_DIR_TARGET}/${base_libdir}/libgcc_s.so.* \ 86 ${STAGING_DIR_TARGET}/${base_libdir}/libgcc_s.so.* \
87 ${STAGING_DIR_TARGET}/${base_libdir}/libpthread* $treedir/${base_libdir}/ 87 ${STAGING_DIR_TARGET}/${base_libdir}/libpthread* $treedir/${base_libdir}/
88 88
89 if [ ! -z "${@base_contains('PACKAGECONFIG', 'x11', 'x11', '', d)}" ] ; then 89 if [ ! -z "${@bb.utils.contains('PACKAGECONFIG', 'x11', 'x11', '', d)}" ] ; then
90 echo "X11 build enabled" 90 echo "X11 build enabled"
91 # copy only as much stuff as we need 91 # copy only as much stuff as we need
92 # before: 5.5G ../../qemu-treedir/ 92 # before: 5.5G ../../qemu-treedir/
diff --git a/meta-oe/recipes-support/espeak/espeak_1.37.bb b/meta-oe/recipes-support/espeak/espeak_1.37.bb
index cf05d2645..273fe340e 100644
--- a/meta-oe/recipes-support/espeak/espeak_1.37.bb
+++ b/meta-oe/recipes-support/espeak/espeak_1.37.bb
@@ -1,7 +1,7 @@
1require espeak.inc 1require espeak.inc
2inherit siteinfo 2inherit siteinfo
3 3
4EXTRA_PHONEMES = '${@base_contains("SITEINFO_ENDIANNESS", "be", "espeak-data (= ${PV})", "", d)}' 4EXTRA_PHONEMES = '${@bb.utils.contains("SITEINFO_ENDIANNESS", "be", "espeak-data (= ${PV})", "", d)}'
5RDEPENDS_${PN} = "portaudio-v19 ${EXTRA_PHONEMES}" 5RDEPENDS_${PN} = "portaudio-v19 ${EXTRA_PHONEMES}"
6 6
7SRC_URI[md5sum] = "5c7b292d0537232868b4ac1317d76c02" 7SRC_URI[md5sum] = "5c7b292d0537232868b4ac1317d76c02"
diff --git a/meta-oe/recipes-support/fftw/fftwf_3.3.4.bb b/meta-oe/recipes-support/fftw/fftwf_3.3.4.bb
index 7a4fbac8c..4a659867d 100644
--- a/meta-oe/recipes-support/fftw/fftwf_3.3.4.bb
+++ b/meta-oe/recipes-support/fftw/fftwf_3.3.4.bb
@@ -4,7 +4,7 @@ require fftw.inc
4EXCLUDE_FROM_WORLD = "1" 4EXCLUDE_FROM_WORLD = "1"
5 5
6EXTRA_OECONF += "--enable-single \ 6EXTRA_OECONF += "--enable-single \
7 ${@base_contains('TUNE_FEATURES', 'neon', '--enable-neon', '', d)} \ 7 ${@bb.utils.contains('TUNE_FEATURES', 'neon', '--enable-neon', '', d)} \
8" 8"
9 9
10SRC_URI[md5sum] = "2edab8c06b24feeb3b82bbb3ebf3e7b3" 10SRC_URI[md5sum] = "2edab8c06b24feeb3b82bbb3ebf3e7b3"
diff --git a/meta-oe/recipes-support/gradm/gradm_3.1.bb b/meta-oe/recipes-support/gradm/gradm_3.1.bb
index fe36fba58..252b19de2 100644
--- a/meta-oe/recipes-support/gradm/gradm_3.1.bb
+++ b/meta-oe/recipes-support/gradm/gradm_3.1.bb
@@ -9,7 +9,7 @@ HOMEPAGE = "http://grsecurity.net/index.php"
9SECTION = "admin" 9SECTION = "admin"
10LICENSE = "GPL-2.0" 10LICENSE = "GPL-2.0"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=4641e94ec96f98fabc56ff9cc48be14b" 11LIC_FILES_CHKSUM = "file://LICENSE;md5=4641e94ec96f98fabc56ff9cc48be14b"
12DEPENDS = "flex-native bison-native ${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" 12DEPENDS = "flex-native bison-native ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
13 13
14SRC_URI = "http://grsecurity.net/stable/${BP}-201507191652.tar.gz \ 14SRC_URI = "http://grsecurity.net/stable/${BP}-201507191652.tar.gz \
15 file://0001-Makefile-remove-strip.patch" 15 file://0001-Makefile-remove-strip.patch"
@@ -26,7 +26,7 @@ do_compile() {
26 'LLEX=${STAGING_BINDIR_NATIVE}/lex' \ 26 'LLEX=${STAGING_BINDIR_NATIVE}/lex' \
27 'FLEX=${STAGING_BINDIR_NATIVE}/flex' \ 27 'FLEX=${STAGING_BINDIR_NATIVE}/flex' \
28 'BISON=${STAGING_BINDIR_NATIVE}/bison' \ 28 'BISON=${STAGING_BINDIR_NATIVE}/bison' \
29 ${@base_contains('DISTRO_FEATURES', 'pam', ' ', 'nopam', d)} 29 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', ' ', 'nopam', d)}
30} 30}
31 31
32do_install() { 32do_install() {
diff --git a/meta-oe/recipes-support/libcanberra/libcanberra_0.30.bb b/meta-oe/recipes-support/libcanberra/libcanberra_0.30.bb
index 26638c3b9..f47377500 100644
--- a/meta-oe/recipes-support/libcanberra/libcanberra_0.30.bb
+++ b/meta-oe/recipes-support/libcanberra/libcanberra_0.30.bb
@@ -22,9 +22,9 @@ EXTRA_OECONF = "\
22 --disable-lynx \ 22 --disable-lynx \
23" 23"
24 24
25PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES','alsa','alsa','',d)} \ 25PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES','alsa','alsa','',d)} \
26 ${@base_contains('DISTRO_FEATURES','pulseaudio','pulseaudio','',d)} \ 26 ${@bb.utils.contains('DISTRO_FEATURES','pulseaudio','pulseaudio','',d)} \
27 ${@base_contains('DISTRO_FEATURES','x11','gtk gtk3','',d)} \ 27 ${@bb.utils.contains('DISTRO_FEATURES','x11','gtk gtk3','',d)} \
28" 28"
29PACKAGECONFIG[alsa] = "--enable-alsa, --disable-alsa, alsa-lib" 29PACKAGECONFIG[alsa] = "--enable-alsa, --disable-alsa, alsa-lib"
30PACKAGECONFIG[pulseaudio] = "--enable-pulse, --disable-pulse, pulseaudio" 30PACKAGECONFIG[pulseaudio] = "--enable-pulse, --disable-pulse, pulseaudio"
diff --git a/meta-oe/recipes-support/libee/libee.inc b/meta-oe/recipes-support/libee/libee.inc
index 5b552ca2a..256fa053b 100644
--- a/meta-oe/recipes-support/libee/libee.inc
+++ b/meta-oe/recipes-support/libee/libee.inc
@@ -18,7 +18,7 @@ inherit autotools ptest pkgconfig
18 18
19DEPENDS += "libestr" 19DEPENDS += "libestr"
20 20
21PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'ptest', 'testbench', '', d)}" 21PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'testbench', '', d)}"
22 22
23PACKAGECONFIG[debug] = "--enable-debug,--disable-debug,," 23PACKAGECONFIG[debug] = "--enable-debug,--disable-debug,,"
24PACKAGECONFIG[testbench] = "--enable-testbench,--disable-testbench,," 24PACKAGECONFIG[testbench] = "--enable-testbench,--disable-testbench,,"
diff --git a/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.34.bb b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.34.bb
index e3c833bf4..a4a0f3883 100644
--- a/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.34.bb
+++ b/meta-oe/recipes-support/libmicrohttpd/libmicrohttpd_0.9.34.bb
@@ -16,7 +16,7 @@ EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../ --disable-
16 16
17PACKAGECONFIG ?= "curl" 17PACKAGECONFIG ?= "curl"
18PACKAGECONFIG_append_class-target = "\ 18PACKAGECONFIG_append_class-target = "\
19 ${@base_contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \ 19 ${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
20" 20"
21PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,," 21PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
22PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl," 22PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
diff --git a/meta-oe/recipes-support/lm_sensors/lmsensors_3.4.0.bb b/meta-oe/recipes-support/lm_sensors/lmsensors_3.4.0.bb
index 62ea13176..857a57be5 100644
--- a/meta-oe/recipes-support/lm_sensors/lmsensors_3.4.0.bb
+++ b/meta-oe/recipes-support/lm_sensors/lmsensors_3.4.0.bb
@@ -55,7 +55,7 @@ do_install() {
55 install -m 0755 ${WORKDIR}/sensord.init ${D}${sysconfdir}/init.d/sensord 55 install -m 0755 ${WORKDIR}/sensord.init ${D}${sysconfdir}/init.d/sensord
56 56
57 # Insall sensord service script 57 # Insall sensord service script
58 if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then 58 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
59 install -d ${D}${systemd_unitdir}/system 59 install -d ${D}${systemd_unitdir}/system
60 install -m 0644 ${S}/prog/init/*.service ${D}${systemd_unitdir}/system 60 install -m 0644 ${S}/prog/init/*.service ${D}${systemd_unitdir}/system
61 fi 61 fi
diff --git a/meta-oe/recipes-support/lvm2/lvm2.inc b/meta-oe/recipes-support/lvm2/lvm2.inc
index a8d44daea..3a5e1c46a 100644
--- a/meta-oe/recipes-support/lvm2/lvm2.inc
+++ b/meta-oe/recipes-support/lvm2/lvm2.inc
@@ -17,7 +17,7 @@ S = "${WORKDIR}/LVM2.${PV}"
17 17
18inherit autotools-brokensep pkgconfig systemd 18inherit autotools-brokensep pkgconfig systemd
19 19
20PACKAGECONFIG ??= "${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}" 20PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
21 21
22PACKAGECONFIG[readline] = "--enable-readline,--disable-readline,readline" 22PACKAGECONFIG[readline] = "--enable-readline,--disable-readline,readline"
23PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux" 23PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux"
@@ -43,7 +43,7 @@ do_install_append() {
43 # Install machine specific configuration file 43 # Install machine specific configuration file
44 install -m 0644 ${WORKDIR}/lvm.conf ${D}${sysconfdir}/lvm/lvm.conf 44 install -m 0644 ${WORKDIR}/lvm.conf ${D}${sysconfdir}/lvm/lvm.conf
45 sed -i -e 's:@libdir@:${libdir}:g' ${D}${sysconfdir}/lvm/lvm.conf 45 sed -i -e 's:@libdir@:${libdir}:g' ${D}${sysconfdir}/lvm/lvm.conf
46 if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then 46 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
47 oe_runmake 'DESTDIR=${D}' install install_systemd_units 47 oe_runmake 'DESTDIR=${D}' install install_systemd_units
48 sed -i -e 's:/usr/bin/true:${base_bindir}/true:g' ${D}${systemd_system_unitdir}/blk-availability.service 48 sed -i -e 's:/usr/bin/true:${base_bindir}/true:g' ${D}${systemd_system_unitdir}/blk-availability.service
49 else 49 else
diff --git a/meta-oe/recipes-support/openct/openct_0.6.20.bb b/meta-oe/recipes-support/openct/openct_0.6.20.bb
index 319784550..bf1ff570b 100644
--- a/meta-oe/recipes-support/openct/openct_0.6.20.bb
+++ b/meta-oe/recipes-support/openct/openct_0.6.20.bb
@@ -24,7 +24,7 @@ SRC_URI[sha256sum] = "6cd3e2933d29eb1f875c838ee58b8071fd61f0ec8ed5922a86c01c805d
24LICENSE = "LGPLv2+" 24LICENSE = "LGPLv2+"
25LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=2d5025d4aa3495befef8f17206a5b0a1" 25LIC_FILES_CHKSUM = "file://LGPL-2.1;md5=2d5025d4aa3495befef8f17206a5b0a1"
26 26
27inherit ${@base_contains('VIRTUAL-RUNTIME_init_manager','systemd','systemd','', d)} 27inherit ${@bb.utils.contains('VIRTUAL-RUNTIME_init_manager','systemd','systemd','', d)}
28SYSTEMD_SERVICE_${PN} += "openct.service " 28SYSTEMD_SERVICE_${PN} += "openct.service "
29SYSTEMD_AUTO_ENABLE = "enable" 29SYSTEMD_AUTO_ENABLE = "enable"
30 30
@@ -73,7 +73,7 @@ do_install () {
73 install -Dpm 755 ${WORKDIR}/openct.init ${D}/etc/init.d/openct 73 install -Dpm 755 ${WORKDIR}/openct.init ${D}/etc/init.d/openct
74 install -Dpm 644 ${WORKDIR}/openct.sysconfig ${D}/etc/sysconfig/openct 74 install -Dpm 644 ${WORKDIR}/openct.sysconfig ${D}/etc/sysconfig/openct
75 75
76 if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then 76 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
77 install -d ${D}/${systemd_unitdir}/system 77 install -d ${D}/${systemd_unitdir}/system
78 install -m 644 ${WORKDIR}/openct.service ${D}/${systemd_unitdir}/system 78 install -m 644 ${WORKDIR}/openct.service ${D}/${systemd_unitdir}/system
79 fi 79 fi
diff --git a/meta-oe/recipes-support/openwbem/openwbem_3.2.3.bb b/meta-oe/recipes-support/openwbem/openwbem_3.2.3.bb
index 1b186329c..ed8ef267c 100644
--- a/meta-oe/recipes-support/openwbem/openwbem_3.2.3.bb
+++ b/meta-oe/recipes-support/openwbem/openwbem_3.2.3.bb
@@ -64,7 +64,7 @@ do_install() {
64 64
65 # fix up hardcoded paths 65 # fix up hardcoded paths
66 sed -i -e 's,/usr/sbin/,${sbindir}/,' ${WORKDIR}/owcimomd.service 66 sed -i -e 's,/usr/sbin/,${sbindir}/,' ${WORKDIR}/owcimomd.service
67 if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then 67 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
68 install -d ${D}/${systemd_unitdir}/system 68 install -d ${D}/${systemd_unitdir}/system
69 install -m 644 ${WORKDIR}/owcimomd.service ${D}/${systemd_unitdir}/system 69 install -m 644 ${WORKDIR}/owcimomd.service ${D}/${systemd_unitdir}/system
70 install -m 755 ${WORKDIR}/checkserverkey ${D}${sysconfdir}/openwbem/ 70 install -m 755 ${WORKDIR}/checkserverkey ${D}${sysconfdir}/openwbem/
@@ -93,7 +93,7 @@ do_install() {
93 touch ${D}/var/lib/openwbem/{classassociation,instances,instassociation,namespaces,schema}.{dat,ndx,lock} 93 touch ${D}/var/lib/openwbem/{classassociation,instances,instassociation,namespaces,schema}.{dat,ndx,lock}
94} 94}
95 95
96inherit ${@base_contains('VIRTUAL-RUNTIME_init_manager','systemd','systemd','', d)} 96inherit ${@bb.utils.contains('VIRTUAL-RUNTIME_init_manager','systemd','systemd','', d)}
97SYSTEMD_SERVICE_${PN} = "owcimomd.service" 97SYSTEMD_SERVICE_${PN} = "owcimomd.service"
98SYSTEMD_AUTO_ENABLE = "disable" 98SYSTEMD_AUTO_ENABLE = "disable"
99FILES_${PN} += " \ 99FILES_${PN} += " \
diff --git a/meta-oe/recipes-support/postgresql/postgresql.inc b/meta-oe/recipes-support/postgresql/postgresql.inc
index 806c63873..288a2d183 100644
--- a/meta-oe/recipes-support/postgresql/postgresql.inc
+++ b/meta-oe/recipes-support/postgresql/postgresql.inc
@@ -55,7 +55,7 @@ pkg_postinst_${PN} () {
55 fi 55 fi
56} 56}
57 57
58enable_pam = "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}" 58enable_pam = "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}"
59PACKAGECONFIG ??= "${enable_pam} openssl python uuid libxml tcl nls libxml perl" 59PACKAGECONFIG ??= "${enable_pam} openssl python uuid libxml tcl nls libxml perl"
60PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam," 60PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,"
61PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl," 61PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,"
diff --git a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
index ed41f0199..382dc5e30 100644
--- a/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
+++ b/meta-oe/recipes-support/syslog-ng/syslog-ng.inc
@@ -41,8 +41,8 @@ CONFIG_TLS = "--enable-thread-tls"
41CONFIG_TLS_arm = "${@base_conditional( "DEBUG_BUILD", "1", " --disable-thread-tls", " --enable-thread-tls", d )}" 41CONFIG_TLS_arm = "${@base_conditional( "DEBUG_BUILD", "1", " --disable-thread-tls", " --enable-thread-tls", d )}"
42 42
43PACKAGECONFIG ??= "openssl \ 43PACKAGECONFIG ??= "openssl \
44 ${@base_contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \ 44 ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \
45 ${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \ 45 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} \
46" 46"
47PACKAGECONFIG[openssl] = "--enable-ssl,--disable-ssl,openssl," 47PACKAGECONFIG[openssl] = "--enable-ssl,--disable-ssl,openssl,"
48PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,," 48PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,,"
@@ -57,7 +57,7 @@ PACKAGECONFIG[tcp-wrapper] = "--enable-tcp-wrapper,--disable-tcp-wrapper,tcp-wra
57PACKAGECONFIG[geoip] = "--enable-geoip,--disable-geoip,geoip," 57PACKAGECONFIG[geoip] = "--enable-geoip,--disable-geoip,geoip,"
58 58
59do_configure_prepend() { 59do_configure_prepend() {
60 eval "${@base_contains('DISTRO_FEATURES', 'largefile', '', 'sed -i -e "s/-D_LARGEFILE_SOURCE//" -e "s/-D_FILE_OFFSET_BITS=64//" ${S}/configure.in', d)}" 60 eval "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', '', 'sed -i -e "s/-D_LARGEFILE_SOURCE//" -e "s/-D_FILE_OFFSET_BITS=64//" ${S}/configure.in', d)}"
61} 61}
62 62
63do_install_append() { 63do_install_append() {
diff --git a/meta-oe/recipes-support/udisks/udisks2_2.1.5.bb b/meta-oe/recipes-support/udisks/udisks2_2.1.5.bb
index 72db88687..f365cfaaf 100644
--- a/meta-oe/recipes-support/udisks/udisks2_2.1.5.bb
+++ b/meta-oe/recipes-support/udisks/udisks2_2.1.5.bb
@@ -3,7 +3,7 @@ LICENSE = "GPLv2+ & LGPLv2+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=dd79f6dbbffdbc8e86b086a8f0c0ef43" 3LIC_FILES_CHKSUM = "file://COPYING;md5=dd79f6dbbffdbc8e86b086a8f0c0ef43"
4 4
5DEPENDS = "acl libatasmart polkit libgudev dbus-glib glib-2.0 intltool-native gnome-common-native" 5DEPENDS = "acl libatasmart polkit libgudev dbus-glib glib-2.0 intltool-native gnome-common-native"
6DEPENDS += "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 6DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
7 7
8RDEPENDS_${PN} = "acl" 8RDEPENDS_${PN} = "acl"
9 9
diff --git a/meta-oe/recipes-support/udisks/udisks_1.0.5.bb b/meta-oe/recipes-support/udisks/udisks_1.0.5.bb
index 8ddc20dab..eec69333d 100644
--- a/meta-oe/recipes-support/udisks/udisks_1.0.5.bb
+++ b/meta-oe/recipes-support/udisks/udisks_1.0.5.bb
@@ -5,7 +5,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=73d83aebe7e4b62346afde80e0e94273"
5DEPENDS = "libatasmart sg3-utils polkit libgudev dbus-glib glib-2.0 intltool-native lvm2" 5DEPENDS = "libatasmart sg3-utils polkit libgudev dbus-glib glib-2.0 intltool-native lvm2"
6# optional dependencies: device-mapper parted 6# optional dependencies: device-mapper parted
7 7
8DEPENDS += "${@base_contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}" 8DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
9 9
10SRC_URI = " \ 10SRC_URI = " \
11 http://hal.freedesktop.org/releases/${BPN}-${PV}.tar.gz;name=${BPN} \ 11 http://hal.freedesktop.org/releases/${BPN}-${PV}.tar.gz;name=${BPN} \
diff --git a/meta-oe/recipes-support/vim/vim_7.4.769.bb b/meta-oe/recipes-support/vim/vim_7.4.769.bb
index c257d9057..08e5027a8 100644
--- a/meta-oe/recipes-support/vim/vim_7.4.769.bb
+++ b/meta-oe/recipes-support/vim/vim_7.4.769.bb
@@ -32,8 +32,8 @@ do_configure () {
32 32
33#Available PACKAGECONFIG options are gtkgui, acl, x11, tiny 33#Available PACKAGECONFIG options are gtkgui, acl, x11, tiny
34PACKAGECONFIG ??= "" 34PACKAGECONFIG ??= ""
35PACKAGECONFIG += "${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}" 35PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
36PACKAGECONFIG += "${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}" 36PACKAGECONFIG += "${@bb.utils.contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)}"
37 37
38PACKAGECONFIG[gtkgui] = "--enable-gtk2-test --enable-gui=gtk2,--enable-gui=no,gtk+," 38PACKAGECONFIG[gtkgui] = "--enable-gtk2-test --enable-gui=gtk2,--enable-gui=no,gtk+,"
39PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl," 39PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"